Move Files updated the Modified Date, but not all

I had 6 folders with .jpgs and .avis that I wanted to consolidate into one folder. I simply did a Select All and a Move. Two of the six folders had some duplicate files, and I simply selected 'skip identical'. When finished, I noticed most of the files had been updated with the current date and time. But a few random ones did not. Nothing special about them, that I can tell.

Why did the move process change the dates at all? I have never experienced this. And though I can imagine a situation where one would perhaps choose such behavior, obviously it is not / should not be the default. And the fact that it did not effect ALL files leads me to believe it is a bug?


Is Preferences / File Operations / Copy Attributes / Preserve the timestamps of copied files turned on?

Are all the files being move from and to the same harddrive/partition?

Yes, all were in *\Temp\Source1, Source2, etc. and moved to *\Temp\Whistler

and yes, the 'Preserve the timestamps' option is enabled.

Moving a file between two directories on the same partition would not normally change the date at all.

Are you sure these files weren't modified separately from the move operation? e.g. Did you just rotate some of them before moving, or change the tags on some of them?

If you go up to the Libraries folder, then right-click the Pictures library and choose Properties, are all the folders in the library on the same drive partition?

If you move the same files again, back to where they were, do the timestamps change again? If so, is it the same files that change & don't change?

This sounds very similar to something I noticed a few months ago, and eventually concluded was unrelated to Directory Opus.

My workflow for digital photos used to be that I'd dump JPEGs into a working folder, add descriptions, keywords and other tags, and then move them to my main photos folder. The metadata tool I used would sync the file's Modified time with the Date Taken from the EXIF data. One day I noticed that after moving from the working folder, the JPEG files had a different modified date. Turns out something was messing with the metadata and altering the modified time. It seemed random which files were affected, sometimes it was one or two in a the destination folder, sometimes it was most or all of them. Once I even noticed modified files in my working folder before I'd even moved them.

I never did work out exactly what the something was, although I came up with a couple of theories, and shortly after I altered my workflow such that it wasn't an issue and I stopped noticing it. At the time, I was playing with Windows Live Photo Gallery and thought that maybe that had something to do with it. WLPG caused its own suite of difficulties so I dropped that pretty quickly, but a quick look at my photos now shows that the metadata-modifying-something is still occasionally active.

My guess now is that it's related to Windows 7's Libraries feature (or maybe Windows Search) in some way. Many (perhaps all) of the modified files have a "DateAcquired" stored in a Microsoft XMP tag, both working folder and my photos folder are included in the Pictures library (and indexed by Search), and I can't think of anything else I use that would add a tag like that.


I did think about what you are asking, as far as modifying or tagging, and I am certain I did not. I rarely tag or modify mass quantities of photos, other than rename, and sometimes changing the modified date to EXIF date. In this case I did neither. I had moved these separate folders from my laptop to my desktop several days prior. When I consolidated these folders, it was in preparation of cleaning out unwanted photos, renaming, and filing them. So I had not done any type of modifying yet.

As far as my Pictures Library, I only have two folders; my personal, and the Public. They are on different drives.

Another note: I have over 4000 photos in the parent folder alone (*\Temp). I checked the dates of all of them, none were changed, other than the ones I moved.
Also, the dates changed on videos, which also rules out any tagging process I may have done.

I have been managing my digital photos the same way for over 10 years, using the same software and procedures. I definitely have never seen this happen before, and am at a loss to explain it, other than some kind of bug. It's not the first bug I have experienced with the latest version of Opus (the other being file synchronization wonkiness)

I tried duplicating the issue, and was unsuccessful. The original folders were already deleted.

Thanks for you help,


Also, I noticed the change immediately, so I know the updated time exactly coincided with the time I performed the move.

If the files are being moved from one to the other then that might explain it, although I'm not sure.

What we really need is reproducible steps explaining exactly what gets copied from where to where, but that'll be difficult if it isn't always happening.

Let us know if you see it happen again, or notice anything else that might help understand/explain what happened.

(Be sure to use the latest version, too, if you're not already.)

The photos were not moved between different drives or partitions. As I mentioned, the source and destination folders shared the same parent.

I will keep my eyes open for it happening again.



Directory Opus 12.23 x64 is the latest version.
There was a problem.
When copying or moving a file (EXE, JS format), the "Modify Date" is changed to the current one!
The remaining dates are saved.

The file with the ISO, TXT format is copied with all dates saved!!!

I copy the file in different ways:

  • from the current folder (output file with the prefix "- copy")
  • from another disk
  • from another section

Everywhere the file system is in NTFS format.

What is the problem?

Is Preferences / File Operations / Copy Attributes / Preserve the timestamps of copied files turned on?

What happens if you do the same copy with something else?

If it only happens for executable files/scripts, I would suspect your antivirus might be doing something.

I have been working in Directory Opus for a long time.
The check mark is set
But I only noticed the date change now.
I didn't change anything.
Antivirus costs even longer.

You could try using Process Monitor to see of something else is bumping the file dates after the file is copied.

I want Directory Opus to set the date with its own software, not the system's.
That would always be correct!
Process Monitor has never been used :slight_smile:

Opus does set the date. Something on your system is screwing it up. You can use Process Monitor to diagnose what's going wrong. We can only really guess otherwise. My guess is it's antivirus, if it only happens with executable files.

There is a FAQ on how to use Process Monitor on the forum.

The log file you sent has all the event types turned off (except process/thread creation, which is no use here), so it can't tell us anything.

Filesystem events need to be turned on when logging (see the 3rd item in Process Monitor instructions).

Quoting the private message:

That indicates Opus is doing the right thing, and something else on your system is then bumping the timestamp. A proper procmon log should reveal what.

If it's only happening to new exe files, and not other types, then my guess is that your antivirus is involved.

Logfile.7z (16.6 MB)

Exiting from "Adguard 7.5.3" doesn't help either.

Your problem is caused by Comodo Internet Security.

If you search the web for CmdTcID there are lots of complaints about it writing metadata to new exe files and causing their timestamps to change in the process.


Thanks!!! Problem solved:
Comodo, uncheck the box:

Video confirmation: