MP4 files not displaying in viewer pane

Recently DOpus has stopped playing MP4 files in the viewer pane - it plays AVI files back just fine but not MP4 files. I've read the HOWTO but to no avail, even disabling the Movies plugin and reverting to the Office plgin to play video files doesn't work.

Has anyone got any suggestions? I've tried updating the video drivers but get told that the latest correct driver is already installed.

Playback of MP4s works fine in VLC Media Player, just not in DOpus or Windows Media Player

Help!!

Fixing Windows Media Player is what I would focus on first. If that isn't working then it won't work inside Opus either.

Have you tried the part of the FAQ which advises assigning the MP4 type/association to Windows Media Player (temporarily)? That often fixes things on its own.

Is it all MP4 files that don't play, or does it depend on the codec involved? (e.g. H265/HEVC MP4 files require extra components be installed for Windows to play them.)

Yes, I tried that part of the FAQ and currently MP4 file association is Windows Media Player
Given the timing, I've a feeling the most recent Windows 10 update is the culprit. I'm wondering if it's worth downloading a codec pack such as K-Lite?

I installed the latest x64 version 3.x of VLC Player and got the same issue with MP4s but a dark green screen rather than black, so I uninstalled it and re-installed the old 32 bit version 2.2 of VLC Player which works just fine playing everything I throw at it.

I don't think VLC uses external codecs (probably not for any MP4 files anyway) but it's interesting that the newer version doesn't work. Have you tried getting & installing the latest graphics drives for your GPU? Maybe that would fix one or more of the issues. (Windows 10 has trashed GPU drivers a few times and needed them reinstalling for me.)

You shouldn't need K-Lite for MP4 but it's possible that or something similar might fix things.

It's an old GPU (my PC was built back in 2009) so there are no latest drivers other than the one supplied with Win10. The event log for the driver doesn't indicate any recent changes so I am wondering if it is the driver. I tried the K-Lite codecs, they made no difference so I'm still stuck as to how I can view MP4s in DOpus.

Have you tried using the WMP Preview Handler? (There's a WMP ActiveX control but also a Preview Handler which works slightly differently.)

If the Movie plugin is disabled, you'll usually be using one of those or the other. You can choose which by configuring the ActiveX + Preview + Office + Web plugin and turning the Windows Media Player option on or off in the top part of the list, then Applying/OKing the change.

Make sure it also has the MP4 extension tied to it, if it's on. And if it's off, make sure the MP4 extension is listed against "Generic ActiveX 32-bit" at the bottom, as that's how the WMP ActiveX control is usually reached.

Thanks for the suggestion, but that doesn't work - still get a black screen