New Text Document and Ctrl-O not working

When I try to create a new text file from the File menu or Ctrl-O I get this error message: An error occurred creating a new file of type \txt': The system cannot find the file specified. (2). Thanks for your help!

What happens if you use the similar New Text Document menu item in File Explorer? Do you get the same error there?

There's probably something wrong with the .txt file type in your Windows registry. Please do the following in Opus:

  • Settings > File Types
  • File > Diagnostic (at the top-left of the File Types window)
  • Enter .txt as the extension
  • Click OK and a zip file will be created on your desktop.

Please attach the zip file in a reply.

Thanks for your help Leo (48.9 KB)

The registry settings look fine.

You mentioned the Ctrl-O hotkey. Maybe that has been modified. In Opus:

  • Settings > Customize Toolbars > Keys
  • Find Ctrl + O under the Toolbars category.
    (Don't confuse it with Ctrl + 0 (zero) in the Hotkeys category.)
  • Double-click it to edit it.

It should run FileType NEW=.txt

Does yours run that, or something else?

Also, have you tried creating the new file in another folder, e.g. on your desktop? Maybe the problem is that files cannot be created in the folder you were trying.

You didn't answer my earlier question:

What happens if you use the similar New Text Document menu item in File Explorer? Do you get the same error there?

Damn! It all works now in most any folder using File Explorer and DOpus with no changes. Must have been a problem between the chair and keyboard? THANKS very much for your help and GREAT support! Bill (Only thing I can think of is I was trying to create the new file in Google Drive BUT it works there now too.)

1 Like

Hello there,
I have the same problem as Hanzie2413.
I did the following:
in the "documents" folder (I am the only user of my laptop), i tried to create a new txt file, obtaining the same alert as Hanzie2413; the same happened when I tried to create a nex docx file, a new xlsx file, a new folder;
Windows Explorer can create everything without any problem;
I tried to do the same on the desktop and both Dopus and Windows Explorer can create files and folders;
I uninstalled and installed again Dopus.
No change.
Just to exclude incompatibilities between chair and keyboard, I tried all the same in another room. Same results.
I generated the diagnostic file as Leo suggested.
Any idea?
Thank you for your time, best regards. (49.8 KB)

The registry values look normal/OK.

If you type /desktopdir into the path field and try doing the same thing there, do you still get the error?

A Process Monitor log of what happens might reveal something. (If you make one, please let us know which folder you were in when testing to make filtering easier.) -- Process Monitor instructions

May be that I did not correctly explain myself.
The problem happens in the %documents% dir (and subfolders), not in the desktop dir.
Nevertheless, I tried to make a few files in the /desktopdir (txt, docx, xlsx) and everything went normal.
I use a localized version of Windows, so I don’t know if the variable is %document% or %documents%.
I try to make a process monitor log while I am in the %document(s)% dir.

One more info.
When I try to delete a file, while in the %documents% folder, Dopus asks for an administrator’s authorization. If I click on “continue” the file is deleted.

Thanks for sending the ProcMon log!

Here's a comparison of what happens when things are working normally (top) with what's happening in your documents folder (bottom):

(Note that "CreateFile" in Windows has a confusing name. It is used both to open existing files and to create new files, depending on the Disposition argument.)

The first two lines are the same on both our machines:

  • Opus is checking if a file called "New Text Document.txt" (or language equivalent) already exists in the folder, in case it needs to bump the name to "New Text Document (2).txt" or similar. "Disposition: Open" means it's checking if an existing file is there.

  • Those return "name not found", which is fine, and just means it'll try to create "New Text Document.txt".

On the third line, it tries to create "New Text Document.txt", with "Disposition: OverwriteIf" this time, which means create a new file, if none exists already, and overwrite any existing file if one does already exist.

That third line succeeds on my machine, and the rest of the activity isn't that important. (The file gets created and then some different things react by reading it. The important thing is that the creation succeeds.)

On your machine, the creation fails, and it does so in a strange way. The error is "NAME NOT FOUND", which doesn't actually make sense when asking to create (or overwrite) a file. (The parent folder definitely exists, too, based on other log entries, so it can't be an issue with that.)

This makes me wonder if your D:\ drive is on a network share or using an unusual filesystem, or anything like that? We have seen some non-Windows network shares behave very strangely at times, so something like that might explain things.

If Explorer is succeeding here, one possibility is that it's experiencing the same error and then falling back on a different folder for the file. (e.g. If you're accessing Documents via the library, Explorer could fall back on another member folder, and the result would look similar unless you checked its absolute path.)

It's also possible that Explorer is creating the file in a slightly different way, avoiding this apparent bug in the D:\ drive's filesystem (or server, if it's a network drive).

Another possibility is that antivirus (or a privacy tool or similar that blocks access to files if it thinks a program/action is suspicious) is intercepting the operation and causing it to fail, and that it isn't choosing a good error code for the failure.


Dear Leo,
Thanks for your answer and for your work.
The D: \ drive is not shared, it is a second drive in my PC. The file system is NTFS, as in the C: \ drive. The only protection I use on this PC is the one that comes with Windows (I guess the English name of that app is Windows Defender).
The strange thing is that I have been using Dopus for a long time and until a couple of weeks ago it worked great.
Is there a way to uninstall Dopus, thoroughly cleaning all traces of it in the Windows registry? Is it possible that one or more keys in the registry have been damaged for any reason and the new installation, without a previous thorough cleaning, is unable to restore them?
Best regards,

The normal uninstaller will wipe your config, but I doubt the issue is config related. Something is making the filesystem misbehave on your system (for some apps / actions).

Windows Defender has been known to do some strange things at times, FWIW, although if that was the cause I'd usually expect more reports.

I am having the same issue. DO cannot create a new txt file. It can create new folders, new .doc, new archives, etc. It only has a problem with .txt, File Explorer can create .txt documents though.

PS What is "Settings", I see "Preferences" and "Customize", but not settings? Is that old vernacular?

The thread has suggestions on things to check, as well as information you can send us that might indicate what is broken on your system.