GP SoftwareTwitter
Opus FAQsManualCommandsObjects

"No reboot" installer feedback (12.12.1 beta)


#1

From Directory Opus 12.12.1 (Beta)

  • We are trialing a new installation method which hopefully means you do not need to reboot after installing an update (the installer will offer to quit and restart Opus instead). Please let us know if you encounter any problems with this.

Installing 12.12.1 on top of 12.12 required a Retry for the help files and a reboot.

Installing 12.12.1 on top of 12.12.1 went straight through, no reboot needed.

Directory Opus Pro 12.12.1 (Beta) Build 6982 x64
OS 6.1 (B:7601 P:2 T:1) SP 1.0 "Service Pack 1"


Opus 12.12.1 Beta
Beta 12.12.1 successful install
#2

Installing 12.12.1 on top of 12.12 went 'butter smooth' ! It asked if I wanted to close DO for the install, then after it was finished installing, asked if I wanted to re-start DO. Went very smooth, and thank you for updating the installer so that no system restart is needed!

Windows 10 Pro 64 LTSB


#3

THANK YOU so much for this, i've been praying for this for the past decade!! every time i saw an update, i would have a warm and a dreadful feeling at the same time.. i have fifty million things open at the same time, restarts are costly!!


#4

Installed 12.12.1 over 12.12. On Windows 7 I had to reboot. On Windows 10 no reboot.


#5

Worked well here too - even though I had explorer replacement checked


#6

Congratulations! This worked well.


#7

This also worked for me (Windows 7). Nice work @Jon, @Greg, and @Leo.

This is a very welcome change, thanks :slight_smile:


#8

Worked for me on top of 12.12, shocked no reboot needed but a very welcome change :slight_smile:


#9

Upgrading 12.10 to 12.12.1 (Beta) still required me to reboot. :disappointed_relieved:

Windows 10


#10

No reboot needed on Windows 10. I updated from 12.12 without problems.:lollipop:


#11

Works as always. Good work, thank you!


#12

Works with Windows 8.1, thanks.


#13

Worked OK Win 10 Insider Build 18334.1


#14

I started the installer, then I manually exited Opus, then completed the install.

The listers I had open were not restored on the launch after the install.


#16

Confirmed.


#17

Required a reboot 12.12.1 over 12.12. Win 10 64-bit 1809 plus current updates.


#18

Thanks. We've made a change and distributed a new installer. "Works for me!" :slight_smile:

If you feel like it, please give it a try and report.


#19

Excellent, worked very well.
I didn't get the release notes after the new version started (maybe after a reboot)...


#20

Those are turned off by default now, but can be turned on via Preferences / Miscellaneous / Advanced [Behavior]: display_release_history if you liked having them.

You can also add Help RELEASENOTES to the Help menu (also there in the new default menus, if you reset the toolbar to factory defaults) to quickly open the release notes for the current version.


#21

When I did the reboot, I found there were Windows 10 updates waiting to be automatically applied. I wonder if they could have interefered with the DOpus update?