Not sorting folders starting with numbers as expected

For some reason, my Opus has started to not list my files by name. (see snapshot).

I put leading zeros in front of the filenames - the more zeros, the higher in the list, but it's started to list them randomly.

as you can see, it should be sorting by name.

I've got a workaround by re-numbering each file but I'd like it to work as before if possible.

Any help will be appreciated.



You may want to turn off Numeric order filename sorting in the folder format:

See Folder Formats: Quick Guide for how to make that apply to all folders.

The sorting in your screenshot is correct for when that option is turned on. All but the first folder will be treated as if they start with "0" followed by the non-numeric characters in the name. The last folder will be treated as if it starts with "2".

This is usually a good thing, as it means that you get this kind of order:

  • Folder 1
  • Folder 2
  • Folder 10

instead of strict character code order, which is usually worse:

  • Folder 1
  • Folder 10
  • Folder 2

But if you want the character code order, just turn off the option.

Thanks Leo, much appreciated.