Open Lister Set by Voice

I have just completed a reinstall of Opus 12.24 into the suggested default directory, on my C drive.

Now that I have my Directory Open install it properly. I am trying to do everything right, opening Opus and a Lister with an external command. So many people have tried to help me in the past, but here sit. I do know it's not the help I received that's the issue. It's me! I have done a lot of reading, as suggested by some but I just can't seem to find a topic that zeros in an opening a lister set. Even when searching our forum I come up short.

So far I have created toolbars and saved them (Save All Listers) naming LocationA-B.

I know the following works in Dragon 15.61 but no Lister Set:
Sub Main
AppBringUp "A:\UTY\Opus\dopus.exe"
End Sub
This as far as I got. Of course, this is before I reinstalled my C drive, so now my path will change.

Dragon is a program I am trying to accomplish this with. I want to do this inside of Dragon code before I do it the easy way in KnowBrainer. If I don't get a better understanding of the code in Dragon first, I'll still be behind the 8ball.

My whole problem is opening the Lister set when Directory Opus opens. Since I did a Save All Listers calling it "LocationA-B", I'm assuming I would be opening the Lister set called "LocationA-B.

I have tried to accomplish this several times in the past 5+ years. I wish it was as simple as saving a set of toolbars with a lister name and saying " Open Lister LocationA-B", but it's not. Well, I guess we can't have everything.

Your thread from last year has the command to open a named layout from outside of Opus:

I tried several different ways with moving "" around, including the following: I get an error (File Not Found). I know the path to DOpusRT.exe is right but not a clue as to where LoctionA-B might be.

Sub Main
AppBringUp "C\Program Files\GPSoftware\Directory Opus\DOpusRT.exe""/cmd Prefs LAYOUT=LocationA-B"
End Sub

Try this:

Sub Main
AppBringUp "C:\Program Files\GPSoftware\Directory Opus\DOpusRT.exe" /cmd Prefs LAYOUT="LocationA-B"
End Sub

No luck I get this:
Please correct syntax errors before saving a Macro.
This the same error I got from last week:

The only way I could save the macros is by using this:
AppBringUp "C:\Program Files\GPSoftware\Directory Opus\DOpusRT.exe""/cmd Prefs LAYOUT=LocationA-B"
Note .exe"" (No Space)/cmd
But it doesn't work.
I'm using Opus - Manage Custom Commands

That command syntax looks wrong, as you have quotes in the wrong places, but I have no idea how Dragon works. We can give you the Opus command-line you need to run, but you may need to ask them for help on how to make their tool run a command with arguments.

Thanks Leo. But why is Opus - Manage Custom Commands refusing to Save the way you have suggested.

I haven't even tried Dragon as yet. My problem to saving the macro with this code in
Manage Custom Commands

There's nothing called "Manage Custom Commands" in Opus, and nothing in Opus would use Sub Main or AppBringUp.

I think you are confusing Opus and Dragon there.

Oh boy. You are absolutely 110% right. Thanks again Leo.

Is there a way to run this from the Desktop, no Dragon?

This button will create a desktop shortcut to open a layout:

Thanks again. This might be what I needed all along.

The Bucks won and so did I. Thinks. I did not need to go any further than this code. I spoke the name " Layout LocationA-B and Opus opened up. Perfect! I was making it so hard when Opus made it so easy. 123 done!