Opus malfunctions with various functions regularly


I bought Opus a year and a half ago and it really is spectacular software, I can't live without it. It happens that a few months ago, it started to present several irregularities, suddenly stopping some basic functions, making the software very problematic for me. Every time I have to REBOOT the computer to try to use the software for a while without problems.

As I am always very busy, I let it go until it became almost unbearable to use it, like now that I had to stop all my work to come to the forum to see how to solve it.

  • Many times, F2 stop working ... need to click to rename a folder name or filename, and sometimes work after pressing multiple times. Clicking item allow me to rename, but F2 won't, only sometimes.

  • Renaming genarates errors liks error 32, file being used by another process, and that RETRY, and folder or file was not in use.

  • Stop working copy file or delete or move, like now, i tried to copy folder and nothing happens.

  • Other issues like these above that i don't remember now also happening

So this basic functions is causing many and many issues to my work.
I want to know what I need to do to solve, or send debug info to fix this issues.

I am developer and my computer is 100% fine, all my softwares are 100% fine, i have no virus of course, i have windows 10 PRO (21H2) build 19044.2251

I need to restart again now to make opus work more some hours.

Thank you,

It sounds like something is locking the files you’re working on. Possibly a virus scanner, or a shell extension something has installed.

What kind of files does it happen with?

What kind of drive or folder? Are network drives or cloud storage involved?

A Process Monitor log may reveal what’s happening. (If you aren’t familiar with it, instructions are in the FAQs.)


Sorry about delay, cause i was not using dopus, cause many and many issues happnening since some months ago.

I always had NORTON insalled, for years, so was working before.
I always had GOOGLE FILE STREAM installed, for years, so was working before.

I didn't insalled any shell extensions or something related to any file manager after bought Dopus.

Now i tried to use ... and other issue appeared, of list that i told ...

The "Copy File Names" is not working, no text is being copied to clipboard.

I want to debug to see what is causing this, what i need to do? software is almost unusable for me since this issues started months ago.

Thank you,

You need to provide more information. Leo asked a few questions which you haven't answered.

Hi Jon,

Here are Leo's answers:

What kind of files does it happen with?

Any file or folder, none specific.

What kind of drive or folder? Are network drives or cloud storage involved?

I am using all at G:/ a cloud drive mounted by google drive (Google Drive Stream)

A Process Monitor log may reveal what’s happening. (If you aren’t familiar with it, instructions are in the FAQs.)

I installed now latest v3.9.2, and i am following your instructions from here: Process Monitor instructions

It's logging filesystem event, as default, no filtering used.

I will keep running and when some issues happens, i will save and send to you, via private message to Directory Opus Resource Centre, also i will tell what i tried to did.

Thank you,

Hi, i sent now via private message my log from Process Monitor to you via private message as i explained above on my latest message. I am waiting urgent solution cause for now opus is unusable for me ... i am using 2 windows explorers, please help! thanks.

Replying here to the detail in the PM, to keep the information in one place:

That could just mean your hotkeys are messed up. Is F2 listed and enabled under Settings > Customize Toolbars > Keys, and is it set to run rename inline?

It could also be that something else has taken over F2 within Opus. For example, a tool like AHK could do if misconfigured. Some keyboard drivers also let you change keys depending on the active program.

Certain files/folders can also block inline rename (e.g. you can't use it on C:\Program Files, in Opus or Explorer), but those also block rename via a long click. So this sounds like something is up with the hotkey more than anything else.

This is the part which the Process Monitor logs would be most useful for. But if the problem happened after you stopped logging then the log won't help.

We need a log of that, and also details of what the file names/paths that had problems were, so that we can find them in the log and see what happened when Opus tried to copy them.

Details on how the copy is being performed would also be useful. For example, if you are using Ctrl-C / Ctrl-V to copy the files, then it's likely to tie in to your problems with other hotkeys not working and/or with the clipboard not working. If you're using the Copy Files button then it's more likely to be something else.

Are you doing that via the Edit menu, or via a hotkey? If it's a hotkey, try the menu in case something is wrong with the hotkey. (It could be the same issue as with the F2 key.)

It's also possible something is preventing Opus from modifying the clipboard, which could be antivirus/anti-ransomware/etc. or could also be things like clipboard monitoring tools.

The Process Monitor logs are unlikely to be useful for the hotkeys or clipboard issues, but should be very useful for problems when copying files. That's the main thing to focus on in terms of logging.

Also, please try everything on a normal folder in C:\ to see if some or all of the problems only happen with Google Drive FS. Google Drive FS complicates things greatly and can behave in strange ways, so it would be good to know which problems are general and which are related to it.

1 Like

Hi Leo,

Sorry always about delay, ... reason is that i am really out of time ... and having issues with Opus that NEVER HAPPENED before using entire year on my google drive ... is really causing too much stress.

Is not related to the KEY F2 or any key (it works everywhere renaming folders, except opus) ... F2 of course is enabled ... cause when i start computer or opus ... it works normally at OPUS also.

I told that opus when starts work ok ... and after sometime many functions didn't work, like copying files or folders, renaming files or folders, copying filenames.... hotkeys ... crashing ... only happens at opus.

I have other file managers that works PERFECT, but is not useful like opus. When opus stop working i am forced to use explorer commander or tabbed explorer from wintools, that never had any issues like opus (issues started few months ago).

If you are saying that opus don't work anymore on google drive like always did ... this is very serious and CRITICAL problem for your company. Nobody works anymore on C:/

I NEVER had ANY issues with opus an ENTIRE YEAR working like now ... doing same stuff on my google drive (G:/) google file stream.

I am sending via private message anohter log file trying to DELETE a file.
Only at opus i can't delete file. any other system or explorer i can do. at SAME FILE that opus is failing.

Please check private message same way i did last, i am putting there also link to my thread here.

Thank you,

In Opus, what F2 does can be changed by your configuration.

Please look under Settings > Customize Toolbars > Keys to see what F2 is assigned to. It should look like my screenshot above.

Hi Leo,

I am telling since the 1rst message here that opus start malfunctioning a few months ago on MANY BASIC functions. is not related to key. is related to OPUS AND FILES. there is something only at your code that is not working. If is not working on mine is not working on thousands. I can assure you.

Is not anyone that have time to debug issue with an explorer.

But i love OPUS, is really a FANTSTIC SOFTWARE, so i really want to solve these issues that NEVER happened before.

Here is print.

Thank you,

The forum would be flooded with similar posts if it was affecting other people.

You said that rename didn't work via F2 but did work via a long click, which suggests an issue with hotkeys not working is at least worth looking into.

When you start an inline rename (via F2 or long click), the file hasn't been renamed yet; that only happens after you type the new name and push return. Nothing is done to the file before that. If I have understood what you said before correctly, the problem was that pushing F2 did not do anything at all, which I took to mean you could not even start typing a new name via F2, only via a long click. Please correct me if I am wrong.

The screenshot of the keys list in your last post looks correct so far, but you didn't double-click the hotkey to see which command it runs (like I showed in my screenshot).

I've checked the ProcMon log you sent and it doesn't show Opus trying to delete the file, so whatever is going wrong is happening before the delete is even attempted. According to the log, the only time Opus tries to access the file is from the background thread that populates file metadata details.

The log also shows that the file is under the Google Drive FS folder. Please reproduce the issue on a normal, local drive so that we can tell if the problem involves Google Drive FS. GoogleDriveFS.exe is constantly doing things in the log while files on that drive are accessed, and it would be good to rule it out.

Testing with a default Opus config may also be worth a try:

  • First, backup your current config using Settings > Backup & Restore. Put the backup somewhere safe.
  • Then uninstall Opus via the usual Windows Settings panel. This will clear the existing config.
  • Reinstall Opus and see if the problem still happens with a default config.
  • After you're finished testing, you can restore your original config via Settings > Backup & Restore.
1 Like

Hi, Leo,

I will do this:

  1. Delete completely opus, after making full backup
  2. Reboot computer
  3. Reinstall opus
  4. Try to work as before on google drive folders
  5. If issues persists, I will reboot computer and try to reproduce on C:/

But i need probably 1 week to do this, i am completely out of time and for now use opus only when not failing.

I will post here results when i have.

Thank you,


You've got a problem that you only see in Opus, so that's where you start looking for a solution. Understood.

But you've been using Opus without problems for a year. Then suddenly everything stops working.

You keep making statements that seem intended to imply that you've been using google drive without problems for a year, so the problem must be with Opus. Maybe it is, but isn't it just as logical to say that you've been using Opus without problems for a year, so the problem must be with google drive (or something else)?

As far as you've told anybody, you haven't changed anything in Opus or the version of Opus.

Doesn't that indicate to you that the real cause of the problem just possibly might be somewhere other than in Opus?

If you have started using a more recent version of Opus since before you had any problems, have you considered reinstalling whatever version you were using before you had problems?

Maybe you will still have problems. Maybe you won't. If you do you can be pretty sure that factors other than Opus are involved.

Why reboot the computer? Why not just try another drive while the problem is happening?


As i told i did that items on list that i said:

I reinstalled opus and it worked normally at google drive folders. No issues after hours working.
So I'm pretty sure the problem is gone.

About reinstalling, i DID NOT use any "feature" that opus offered at my computer at installer wizard.
I marked NO to all options (like replace explorer, double click, and all options i marked "no").

For me find reason, the less "opus" trying to change the system, the less risk of having problems, since I don't know what it is, i prefer less risk for now.

Now i want to restore my opus backup file to test if will work normally.

I have a question about opus "label" ... how did opus know which files has labels or other opus meta? It is stored at backup file? Restoring backup will restore my labels at files?

Thank you,

So the problem was almost certainly in your configuration.

It's stored in the filesystem by default.

Hi @Leo

I tried again to restore my full configuration and opus again started that issues some time later.

Then i uninstalled again, rebooted again, and installed again opus from scratch.

After verifying again that all is ok and working without issues, I restored again my full backup configuration but didn't checked the latest checkbox "Replace existing configuration completely"


For now all seems ok, so i will return here to say if this setttings solved the issue.

Thank you,

Hi, what i told here last message 1h ago ... didn't worked.
Again issues.

My main issue using default configuration at opus is that all LABELS is gone.

Only restoring my backup that labels at files are appearing ...
and at backup as i told there is something that i don't know is messing opus.

how to solve this? i want my labels at least ...the rest i can restart configuring opus item by item until find what is issue.

thank you,

What are the issues? Did the old problems come back, or do you mean the labels aren't restored without doing a full config replacement? That would be better discussed in a separate thread as it's already quite hard to keep track of exactly which issue(s) we're trying to solve in this thread.

Please give more detail.

From my reading, I THINK what is wanted (temporarily) is a way to modify the default config by only adding the pre-existing labels. I don't know if that is possible or not.