PDF files no longer previewed but fine in Windows Explorer

Windows 11 File Explorer shows the previews still but suddenly DO no longer does.

Which PDF viewer are you using?

If it's FoxIt, please see here: FoxIt PDF viewer not working - #2 by Leo

I don't believe I'd installed a PDF viewer so whichever one File Explorer normally uses. I downloaded Foxit based on your response here but nothing has changed. I've paste a screenshot showing how the plugins are configured.

You have four PDF viewers there, and the one PDF is assigned to has been disabled.

Try enabling it. If it still doesn't work, try assigning PDF to any of the others.

Thanks Leo but unfortunately that didn't help. I don't see how I add a file type to an app's list of extensions but I reset the ActiveX etc plugins to defaults but no change.
Screenshot attached.

Select a viewer, type the extension on the right and click Add.

I cannot do that: when I select a viewer and then click in the File Extensions box on the right I am not able to type anything. A gray dotted line box appears but I am not able to type anything. Double clicking doesn't work either.

Click here to type the extension in, once you do the Add button will activate.

Thanks for your patience with me Leo! All good now!