PDF opens with notepad in Dopus

Sometimes when I try to open a pdf file while in Dopus it will open in notepad instead of Adobe. If I move the file to the desktop it will then open in Adobe. Or, I can leave the pdf in the original folder, use Windows Explorer and double click to open in Adobe. I only have the problem with Dopus. Adobe is set as the default application for *.pdf.

I am using the Adobe app in Windows 8. I had the same problem in Windows 7 x64. When I was running Windows 7 I used Sumatra PDF to view pdf files. Again, the file associations were correct but sometimes the pdfs would open in notepad. The weird part is that sometimes the file would open correctly but sometimes not. The filenames are simple so that can't be it.

So it depends on the folder where the PDF is, not the contents of the PDF?

What kind(s) of folder does it fail in?

Could you post a couple of screenshots showing the same PDF in two locations, one where it works and one where it doesn't? Maybe something will become apparent from the details in that. (e.g. One location being a virtual folder or similar.)

If I navigate to the desktop with Dopus, it will not open the pdf. If I just use the Windows desktop itself the pdf will open. Here is an example of a pdf in D:\Downloads that doesn't open in Dopus but will open with Explorer.

(Broken external image links removed.)

Which folders does it work in?

Is that Adobe Reader in the 2nd screenshot, or the Windows 8 PDF reader?

The .PDF icons look like Windows 8 ones rather than Adobe Reader icons, and I didn't realise there was a Metro* version of Adobe Reader, although I may be wrong. (*Or whatever Microsoft end up calling The Thing That Must No Longer Be Called Metro All Of A Sudden. :slight_smile:)

It doesn't seem to matter which folder I use but if I go there in Dopus it won't open. Yes, that is the "Metro" reader app. I'm running the released version of Win8 Pro x64. Actually, you can still see the source ISO in my screenshot. As mentioned before, I had the same problem in Win7 using different pdf readers (Sumatra and PDFXchange before that). Some pdfs open fine and some don't. The ones that don't will open fine in Explorer or if I use "Open with" from the right click context menu.

I'm not sure it is the same problem if on the Windows 8 machine with Microsoft Reader, none work in any folders, while on the Windows 7 machine with other PDF readers some PDFs worked in some folders but not others.

You might have something unusual configured in your PDF filetype, I guess, assuming you imported your Opus configuration from Windows 7 to Windows 8. (Or there might be something in the registry itself if you installed Windows 8 in-place instead of a clean install.)

Do you still have the Windows 7 install? Which folders did things work and not work in on that?

Okay, I uninstalled Dopus, rebooted and reinstalled. I left it in it's original configuration without importing my preferences. I still had the same problem as before. I was not able to open the pdf in D:\downloads. I was able to open a pdf in "D:\dropbox\my documents". So, I moved the pdf from downloads to My Documents but it still wouldn't open. So, folder location doesn't seem to matter.

One odd thing is that when it is able to open a pdf correctly, it first opens a viewer window then sends it to the Reader app. After closing the Reader app I am left with the blank viewer window. At least I think it is a viewer window.

(Broken external image link removed.)

Oh, have you installed the Universal Graphics Viewer plugin?

If so, either uninstall it or install the latest Opus beta version which has a workaround for that problems that plugin causes with pdf files.

I have not installed any Universal Viewer and I am running Dopus (4605) x64. This is a fresh install of Windows and above was a completely fresh stock install of DirOpus.

What happens if you right-click a pdf and use Open With / Choose Program (or similar, the exact name may vary)?

Open With context menu works fine to have it open in Reader. And "Always use this program" is checked. Another thing I noticed is that some pdfs that I was able to open inside of Dopus before, I can no longer. Now it seems all my pdf's open in notepad if opened in Dopus. Explorer still works fine.

I just reassigned Sumatra as the default pdf reader app and everything seems to work fine. I'm not getting the Viewer app either. I'm going to chalk this one up to the Metro Reader app being the cause.

I have the following problem:
When I want to open two or more .pdf files in Opus Directory, it always tries to open it with LIbreoffice. Even though Foxit Phantom Pdf is defective for pdf files?
Thanks for help

Try using Right-Click > Open With > Choose Default Program on a PDF file to fix things.

I tried to select 3 pdf files and when I click the mouse, it only allows me to open one file. When I select all 3 pdf files and click the enter on my keyboard, it opens libreoffice for me

Are you right-clicking them? You should see a context menu.

(PS: Please link your account.)