Problem with RAR extract context/drag&drop menus

Hi All,

I've followed the faq here and got it to work briefly under opus 9.002.
I now have 9003 installed.

The problem now is that i dont see any context menu items anymore when right pressing a *.rar file. I have the VFSP plugin enabled, see rar.dll and unrar.dll file in the VFSPlugins directory. Furthermore, a rar type file doesnt display the rar icon associated with it anymore. It now displays a default type icon, although when i edit the rar filesystem type, it can see the correct icon association.

Any ideas why the context menu's and filetype icons arent displayed? I have Winrar installed but this didnt make it stop working perfectly earlier.

It sounds like RAR files aren't being matched to your RAR filetype.

Could you show us a screenshot of your RAR filetype?

If you view a directory with some RAR files in it, what is displayed in their Type columns?

An image of the rar file type:

An image of the detailed rar file type:

"If you view a directory with some RAR files in it, what is displayed in their Type columns?"

The Type column displays "Rar File"

That looks right. Pretty much what I have here.

Just to eliminate one thing, the RAR files you're trying with are in a normal directory and not a "virtual" one like Desktop, right? (The context menu items won't be displayed in folders handled by Explorer, since they run Opus commands. There's a workaround for that if you need it.)

If you create a toolbar button which runs this command:

FileType EDIT

then select a RAR file and click the button, does the RAR filetype open up? (Wait a couple of seconds after the filetype list appears. The RAR filetype should open in a second window once Opus finishes reading the list of filetypes.)

hi Nudel,

Thanks for your time

Erm, the rar files are in a normal directory, altough i would like to have the context menu items for rar files located in the "Desktop" virtual folder also. I happen to save files in that location a lot due to the annoying common (save/open) dialog windows in Explorer. (Isnt Opus able to replace these?!)

anyway, the FILETYPE Edit button does exactly what it's meant to do, it opens the rar file type without problems.

Furthermore, the VFS Plugin seems to work since the left double click event opens the rar file in the current lister.
How come the file type asociation at the visual level went wrong altough underneath its working fine?

What do you recommend? Remove and create a new rar filetype?

I checked the file type again and pressed Change, see the image below where again the file type icon isnt what it should be;

I also checked the /dopusdata\filetypes folder. It displays two entries for rar type files. One is called rarfile.oxr and the other WinRAR.oxr. Both are attached to this post. (717 Bytes)

If you point RegEdit at HKEY_CLASSES_ROOT.rar, what's the default value set to? rarfile or WinRar?

It's possible to convert the commands into ones which will work in Explorer, using dopusrt.exe, but it's a bit messy too. If the Desktop is the only folder where you care about this then you might find it better to navigate to /desktopdir instead, which is the real folder containing your desktop items. Opus will handle that by itself. As a bonus, it isn't cluttered up with other icons that you most likely don't want to see in the file display (Recycle Bin, Computer, etc.).

Opus doesn't patch the common dialogs in other programs. AFAIK there isn't a safe way to do so without introducing potential problems, but I have never looked into it in detail.

That's worth a try. Delete the filetype, then delete both the .oxr files (just in case) and restart Opus, then create a new one.

I don't know if it will work for sure but it's definitely worth a try. Something somewhere is mismatched.

Ok, ive checked the registry and the entry was configured correctly.
So in order to move this issue forward, i deleted the rar filetype and removed the custom oxr files from the filesystem and re-created the rar file type.

All is working correctly now

Thanks!! :stuck_out_tongue:


could you please give more detail on how to solve the problem ? This particular problem also happened to me. Just suddenly.

I tried to delete the system file type of rar and create a new one . I've check the registry and everything was fine with value point to Winrar Archiver. ....

it's very annoying living without winrar context menu :blush: . please help .

Hi Apache,

Why would you configure Winrar as the default rar handler? You have to use the rar plugin that ships with opus (Settings--> VFS Plugins --> Rar)

My advise would be to remove the rar file type again (and all other rar filetype extentions also!) and recreate the default .rar file type.

Also, delete the rar.oxr file (or similar) from the /dopusdata/filetypes.

  1. Remove all rar filetypes
  2. Check whether the RAR plugin is enabled
  3. remove the ocx file if applicable
  4. Reboot your machine or quit/start Opus.
  5. Add addiotnal extentions (r01 r02 etc) through the rar plugin configuration under VFS Plugins.

I remember a reboot was necessary in order for it to work, but dont know when exactly it was.

Let me know!