Problem with videos on the viewer pane

So, I'm using the most recent build of Windows 10 (Build 17763) and if I don't install any codec I can't preview videos on the viewer pane at all using the movie plugin. So I tried to install FFDShow + some MPC-HC splitters like Leo suggested in the FAQ about playing videos and it didn't work. So I removed it and tried to install LAV Filters and it kinda works now, but in a really weird way.

If I just use the viewer pane, the video plays, I can hear the audio, seek, pause, change volume, but the video screen is black. If I open the video with the standalone viewer (using the >show command) the same thing happens, but the video is white. Maybe it has something to do with the colors I choose or something.

But the weirdest thing is, if I enable the viewer pane and open a video on the standalone viewer while previewing it on the pane, it works perfectly on the standalone one, while the pane is still black. Really weird.

But well, maybe i can try other plugins. So I tried to use the ActiveX one, that embeds a WMP player with autoplay, and it works perfectly for mp4 and mkv files, but most of my files are webms and it can't play them at all, even if I open it with WMP it works. Besides that the ActiveX can't zoom in, I have to change the volume for each video, it's not ideal. I tried the Windows Media Player option too, and it works with everything, mkv, mp4, flv, webm... But it does have the same problems that the ActiveX one has, and doesn't have autoplay, it just sucks.

I even reinstalled my Windows, maybe it was some weird interaction with old codecs or something funny on the registry, but it still didn't work without the LAV Filters. Already tried things suggested on Enable/fix playback of various media formats in Opus 9, but nothing worked. Now I'm with this problem, where I have 3 solutions and none of them works for me.

Any suggestion on how can I fix this? Is the video playback broken for anyone else?

You could take a look at Codec Tweak Tool and go through some of the Fixes under General and see if it fixes your problem. If not, what I would try to do is uninstall all of the codec related stuff including FFDShow, splitters, LAV filters, the Codec Tweak tool itself, and others, restart your computer, install K-Lite Standard Codec Pack, and then go through Code Tweak Tool again (it's packaged with K-Lite), go through the Fixes, and then try to do a Reset under Settings, which is also through the Codec Tweak Tool.

I rarely install codec components individually because codecs are a royal pain in the rear and can easily break due to weird conflicts. Codec packs are a lot easier to deal with since they're tested and put together by a single group to make sure everything plays well together. K-Lite Standard should include everything you need such as FFDShow, splitters MPC-HC player, LAV filters and more. Alternatively, there is also CCCP: Combined Community Codec Pack but I haven't used them in years but they used to be the go-to for anime watchers.

Otherwise, if it still does not work, I don't know what else can be done. As for me, it's working perfectly fine across all my computers.

Maybe I should have said that I already tried the K-Lite Codec Pack and the Shark007 one too. Both use mainly LAV Filters, but they have two alternatives, the MPC and Haali splitters. Neither of them works at all for me. The Haali one is even weirder because the video doesn't play, but Dopus keeps opening a new instance for each video that it tries to preview, so after navigating a folder full of videos, I had to use the task manager to kill multiple instances of the Haali splitter.

I have no idea how to fix this if even the vanilla Windows 10 can't play them for me. :thinking:

You've tried most of the things I can think of.

Maybe there is another preview handler for videos which someone has written (e.g. for better video playback in Explorer's viewer pane as well), but I haven't come across one.

We probably need to overhaul the Movie plugin as it is getting harder to make it work with Windows 10. I'm not sure why, but something it depends on seems to no longer work as well as it used to in newer Windows builds.