Program error 0xC0000005?

I'm getting the follwing error periodically. Generally when DOpus is running the in the background, and I haven't touched it in a while.


Let me know how I can give you more info, like a log or something.

Windows 10
DOpus v12.17

Information on how to find and submit crash logs here:

Just sent the minidumps in a private message!

Sorry for the delay, I had gone home after you replied last time, and it hasn't happened since then. Ironically, it happened 3 times in a row today - twice when I tried reopening DOpus after the initial crash.

Hope that helps!

Thanks for sending the crash dumps.

The crash is happening in a Windows DLL, when the folder tree asks the OS for the label of a network drive (by the look of things).

Sometimes that can be caused by memory corruption that Opus itself or another DLL (e.g. 3rd party shell extensions) has caused, but all three dumps crash in exactly the same place in the same Windows DLL, so it looks likely to be a fault of the DLL itself to me.

The dumps indicate you have not updated Windows 10 in two years, so that would be the first thing I would try. Please do that and let us know if you still get the crash.

Hmm, that makes sense - I see DOpus disconnecting and reconnecting to the networked drives sometimes. And if I leave a tab open to a networked drive folder, eventually it'll get cleared (as in just show the default "This PC").

Think you can narrow it down to a 3rd party shell extension? Or let me know which DLL exactly?

Unfortunately, it's a PC at work so I have no control over the updates.

From what I can see, it's more likely to be a bug in Windows 10 which was fixed later on. The DLL that's indicated did have some crashes in it in the past.

You could try disabling shell extensions via ShellExView but the dumps don't point to any, only to one of the system DLLs, so if the problem is caused by an extension it could only be found via trial & error. But it seems more likely it's a bug in the old system DLL.

Damn, so best bet is to just wait till my company decides to update Windows?

I think the only alternative would be to turn off the folder tree, or disconnect that network drive. The crash is happening in when the tree asks Windows for the network drive's icon.

It's probably this bug, which also made Explorer crash in relation to network drives:

That has some suggestions in it but I'm not sure if they'd work, unless you have some network drives pinned to the Quick Access folder (in which case definitely try unpinning them to see if that helps, or turn off Quick Access in the Opus folder tree).

There are several other threads about the same DLL crashing Explorer in (mostly) older versions of Windows but the ones I found didn't mention network drives, so that thread seems the most relevant to what you're seeing.

I'll take a look at that thread then.

I do have networked drives in DOpus's Favorites - would that cause the issue as pinning to Quick Access?

Removing them is worth a try, but it might happen if the icon is anywhere that is displayed by the tree (e.g. under This PC or Network).

It may also not be restricted to the folder tree, since the same icons are displayed in other places (but only when you go to the network drive, or a folder like This PC).

The option Preferences / Folders / Names and Icons / Show generic icons for... in Opus may help here, but I'm not sure if it applies to the network drives themselves, or only files and folders on the drives. Worth a try as well, though.

I've been experiencing this program error for many, many years.
So to test the suggestion that it's a Windows DLL bug I have a brand new computer in performed a fresh install of Windows 10 Professional 64bit released Oct. 2020.
Guess what? I still get that error. Perhaps Microsoft isn't aware of that error crops up when using Directory Opus? Just say'n.

I tested the theory on a brand new Lenovo with the latest build of Windows 10 Professional 64bit, October 2020.
Still get the error.
You'll have to wait longer than it takes for your company to update Windows because that won't fix it.

It's almost certainly a different problem to the original one in this thread - the 0xC0000005 error code is quite generic. If you send us crash logs we can take a look.

Hi Jon,
I'm finally well enough to return to this forum concerning the error.
Attached is the crash log. I hope we can put this to rest once and for all!
Terry (332.2 KB)

The version of Opus 12 you're using is 4 years old (12.9 from May 2018). Please update it. If the bug is in Opus itself, it may already have been fixed. We also don't keep debug symbols for older versions, so we can't see much from the crash logs for such an old version.

One of the crash logs indicated that BMDCodecMJPG64.dll had crashed, and at least one of the others showed something was being done with video files when the crash happened. So it's possible that that codec is what is crashing, rather than Opus itself, but it's difficult to say with such an old version. There are a few threads on the net indicating (some versions of) that codec (apparently installed by Blackmagic Design) cause crashes in other things, and deleting it can fix things. Updating it may also fix them. Blackmagic Forum • View topic - PP CC 2014 crashes when reading a file in mjpeg

I have the same issue.

For the past few months, Directory Opus crashes quite often. I've seen this error popup many times, sometimes more than 4 times a day. I had this problem both before and after I upgraded my RAM and CPU (from Ryzen 3 2200g to Ryzen 5 5500). I also cleaned installed Windows recently.

The popup says one of these, the error is the same but the rest varies (I've only recently starting documenting the thread and addresses):

The error (0xC0000005) occurred in thread 0x32EC at address 0x00007FFFCBID360C
The error (0xC0000005) occurred in thread 0x1058 at address 0x00007FF80634360C
The error (0xC0000005) occurred in thread 0xlCC8 at address 0x00007FF9EEF360C.
The error (0xC0000005) occurred in thread 0x8D4 at address 0x00007FFF3286360C.

I'm using Dopus 12.33, on Windows 10 Pro (64 bits), version 22H2, build 19045.3570.

I've looked at Blackmagic Forum • View topic - PP CC 2014 crashes when reading a file in mjpeg but, although I have Resolve installed on my system, I do not have the two DLL files mentioned anywhere. (25.2 KB)

The DMP shows another component loaded a DLL into our process, and then unloaded it while it was still being used, causing a crash on thread exit.

I can't tell what the DLL was, since it is unloaded at the time of the crash. But it's probably a shell extension.

Firefox's bug tracker 1683033 - Crash in [@ kliveshellext64.dll | RtlpFlsDataCleanup | LdrShutdownThread] mentions a similar crash with a cloud storage shell extension, but if that isn't on your machine then it could be another one.

The only real way to track down a problem like that is to blocking lots of shell extensions until the problem stops, then unblock a few at a time to narrow down which one is causing the problem. In Opus 12, using ShellExView to do that is best. In Opus 13, you can do it via Preferences / Miscellaneous / Shell Extensions.

1 Like