Recovery Volume showing drive letter

If you use Opus to create a folder under C:\Program Files, do you get a UAC prompt?

Also, does Windows Explorer show a drive letter for the partition the same as Opus does?

No, I don't get a prompt.

It does not show up in Windows Explorer.

It does not have a drive letter in disk management.

P.S. It does not show up when I select Disconnect Network Drive

If you can create folders under Program Files without seeing a UAC prompt then that means either UAC is disabled or Opus is running elevated. (Or the Program Files permissions are messed up.)

If Opus is running elevated then that would explain why the recovery partition drive-letter is showing in Opus but not elsewhere. Elevated processes will potentially see a different set of drives to normal ones. (One of several reasons not to run Opus elevated.)

Assuming UAC is turned on, see the How to turn off "Run as Administrator" section of Why not to run Opus as Administrator under UAC for advice.

All the settings were already as suggested in the link. Apparently, it wasn't running elevated.

Any other suggestions?

Thanks for your help.

What do you see in the file display (note: ignore the folder tree for now) for My Computer if you turn off:

Preferences / Folders / Virtual Folders / Native display of 'Computer'


It's still there.

Find a .txt file in Opus, and double-click it to open it in Notepad, and then select File->Open to display the file browser dialog. If you navigate to My Computer in that dialog, do you see it?

Yes. (My default txt opener is EditPad Pro, but I don't think that matters. for this exercise.)

You've almost certainly got Opus running elevated as administrator, and that's what's causing the unwanted drive letter to appear.

How are you launching Opus?

Either from icon in Taskbar or Start Menu Group. Either way, it's there.

Please do the following (all shown in the video below in case anything is confusing):

[ul][li]Download and run Process Explorer.
[li]Add the Integrity Level column.
[li]Find dopus.exe in the list. (Note: Not dopusrt.exe, although that may also be interesting for other reasons.)[/li][/ul]

Please take a screenshot showing dopus.exe and the Integrity Level column, as well as anything in the process tree which is above dopus.exe.

LIke this:

(That shows dopus.exe has Medium integrity, which is what it should have. It also shows that dopus.exe was launched by dopusrt.exe, which in turn was launched by explorer.exe, both also having Medium integrity. You might see something slightly different, depending on how Opus was launched, but Opus and everything that launched it should be running at Medium.)

(If Process Explorer shows a flat list instead of a tree, click the top of its Process column until it starts showing a tree again.)

(To post screenshots, click the Reply or Full Editor buttons at the bottom of the page. There will then be an Upload Attachment tab which accepts PNG, JPG and GIF files.)

Here's the video showing what to do:

Mine's high. How to fix?

Sorry ... didn't include process tree from upper level before.

By the way ... I had set my UAC to "Never Notify". Is that a problem?

On Windows 7, that setting turns UAC off entirely.

You may not want to do that (even if you dislike the UAC prompts, it disables other things like Internet Explorer's Protected Mode), but that's up to you and it shouldn't affect this particular problem (as far as I know, at least).

It does mean most of the previous questions become irrelevant, since UAC was off.

Are you sure these drive letters do not display in Explorer? It seems very odd if Opus and Explorer are running in the same context (both High integrity) and (presumably) as the same user. It's also very odd that if Opus or Notepad show an Explorer-generated list of drives, they get different results to Explorer itself.

I promise I'm not making this up. Opus:


What happens in Explorer if you turn on the "Show all folders" option (Tools -> Folder Options -> General)?

If I understand correctly and this is the option you wanted me to select, then it still doesn't show in Explorer.