Right click drag & drop stops working after network password prompt

Right click context menu(copy etc) stops working when i login to another pc folder using a user that im not logged in with. If i login wioth that user account all is well. Right click is fine until i open the folder and enter the users details.

Dopus v12.14. Windows 10 V1809 build 17763.437

AMD Ryzen 2700x, 32GB 3200 Corsair Vengence Pro. No Overclocks.

No context menu appearing can just mean you don't have permissions to do anything (even open or read) the thing you have right-clicked.

Can you open the file or folder you are right-clicking?

Does the same menu work in the same situation in Explorer? (Try using some of the menu items to check they work, not just that they appear.) Still in Explorer, does the full menu display, or just a reduced menu with basic options?

What do the debug steps in Crash, exit or high CPU when viewing certain directories output? Does disabling shell extensions ("Hide Windows items...") make a difference?

Sorry should have been more clear. Its the right drag menu, copy, move.

The problem occurs for all files/folders. Right drag is working in explorer. The problem occurs as soon as the Enter network credentials window opens. Dosnt matter what I do at that point, i'm bugged. Accessing files and folders that have the everyone permission are fine. Its only with files that are locked behind user accounts that your not logged in with on this PC. All other functions are unaffected(as far as I can tell) and its only in Dopus.

I dont have the mini.dump folder. Ive tried disabling shell extensions. Even tried debugview, nothing for right drag.


tried uninstall and reinstall, vanilla config. No difference.

Thanks for clarification. I've updated the thread title.

How are you triggering the password prompt? e.g. What are you clicking on or dragging from/to at the moment it appears?

Does left-click drag & drop still work after that point, or is that then failing as well?

If you fully exit Opus (via File / Exit Directory Opus, don't just close the window) and restart it, does everything work again?

Thx for the title update.

Going to network, PC, then the shared folder. Haven't tried any other way(favs/networked drives, but will later.

Left drag works.

Restarting Dopus sorts it :smiley: Until next reboot

Using a mapped networked drive with saved credentials works. Any other method i've tried that involves the enter user/password popup causes the problem.

I haven't been able to reproduce this, but the Network folder barely works on any of my machines to be able to try it. In Opus or Explorer, it almost never lists any computer except the one I am on.

If you can trigger it via another method (e.g. typing the UNC path directly), let me know and I'll try that, but so far I haven't found a way to reproduce the problem locally.

The network credentials dialog in Windows 10 has had some bugs in the recent past that caused programs (not just Opus) to crash after it was displayed. We added workarounds for those, and I think Microsoft also fixed the issue eventually, but there may be other bugs lurking in there which manifest in different ways. Make sure you have the latest Windows updates if you haven't already, in case it's something Microsoft have fixed.

Using the unc path triggers it. Any method i've tried that involved the credentials popup triggers it.

That's something I do regularly (including UNC paths that trigger a login prompt) and I haven't been able to repro this so far.

Creating a manually generated dump might be wroth a try, to see if it indicates a thread is stuck somewhere.

sent a dropbox link to the email on the dump instructions.

Nothing stands out in the dump, unfortunately. All the threads are just waiting for user input by the look of things, with nothing stuck.

Re-reading the thread, I realise I'm not sure exactly what is going wrong. Does the right-click-drag menu not appear at all? Or does it appear but nothing happens when you select something in the menu? Or something else?

right drag dosnt appear


When the problem starts happening, if you click on the View menu, which display mode does it indicate you are in? (e.g. Details, Thumbnails, Power, etc.)

list, tried the others, makes no difference.

anymore ideas?

None currently, nor any similar reports. It's most likely a Windows issue, given problems caused by that dialog in the past, but we can't reproduce what you're seeing or think of any reason why it would happen on one machine and not others.

The only difference I can see between our machines based on the dumps is that you seem to be using WiFi while I'm using wired, but it would be strange if that made a difference (unless the network credentials prompt is also triggering connection to wifi).

We'll see if we get any more reports, and the issue could also go away by itself with Windows updates, if it's another bug in that dialog, as has happened in the recent past.