Run Macro-Works in the Address bar But..,

I'm conquering OneNote using the following macro. I have created close to 200 macros that give me total control over OneNote. I'm using code that you helped me with over a year ago, thanks again for all your help.

Open Lister using a Macro Program

The base for macro:
AppBringUp "onenote:///B:!MS!OneNote!MST-SYS\MacroX!Dragon\{A5644D4C-897A-4CB4-B98F-98DF98477104}&end"
Wait 5.35
AppBringUp ""

Now I'm trying to get a little more control over my Opus. I have tried using the following with no luck:
ShellExecute "C:\Program Files\GPSoftware\Directory Opus\dopus.exe /cmd Prefs LAYOUT=opusComputer"

This code C:\Program Files\GPSoftware\Directory Opus\dopus.exe /cmd Prefs LAYOUT=opusComputer works fine when I execute it from RUN. It will not run in my Dragon Macro, I get a PLEASE, correct syntax errors before saving a macro.

If it's a path issue here are my paths:
C:\Program Files\GPSoftware\Directory Opus
C:\Users\ameri\AppData\Roaming\GPSoftware\Directory Opus\Layouts\Computer.oll

My plan is to load Opus when I run the above working macro, when loading OneNote & Google Chrome, which works great.

PS Why or what is opus in relationship to LAYOUT=opusComputer?

It doesn’t sound like the issue is anything on the Opus side of things.

If you have a command that works when run from one place (the Run dialog), then you know the command is the right one.

If a second tool (Dragon) says there’s a syntax error when trying to run the same command then the issue must be in the syntax you’ve used to tell the second tool which command and arguments to run. Since that tool isn’t one I’ve used (and isn’t Opus), and I have no knowledge of Dragon’s scripting language (which seems to be what the code in your post is written in), I couldn’t tell you the syntax it expects, but the support team for Dragon should be able to help.

Thanks, Leo. I'll check it out with Dragon.