Set/Clear/Extract WMA/MP3 Cover-art + Populate AlbumArtist

See Also: Download Album Cover Art in one click

Opus toolbar buttons, and an included program I wrote, which solve two problems:

  1. Populating, Clearing and Extracting the embedded cover-art of WMA and MP3 (ID3v2) files based on the folder.jpg or cover.jpg files in the same directory.
  2. Populating the AlbumArtist field on WMA files automatically, with support for Various Artists compilation albums.
Full description, download and source code can be found here:

Notes for newer versions of Opus:

  • Opus 10 can set and clear and extract cover-art in music files using the Metadata Panel.
  • Opus 10 can also set and clear cover-art via commands.
  • Those make much of the WMAlbumArtist tool obsolete if you have Opus 10 or above, although the special AlbumArtist handling and the ability to batch-extract covert-art into image files may still be useful.


This little tool (plus the accompanying Opus toolbar buttons) can now extract the covert art image(s) from WMA and MP3 files.

I made this since the new NIN album (edit: and the new new NIN album!) has a different image embedded in every track and I needed them to be saved as separate image files for them to show up in my music player. :slight_smile: Should you ever need to do the same it's now one click away in Opus...

Hi leo,
DOpus 10 doesn't seem to be able to display Images applied with WmaAlbumArtist.exe. I don't think your tool isn't working correctly. I'm pretty sure it's a bug in Dopus 10.

It seems to work okay here. Which file format are we talking about, MP3 or WMA?

FWIW, yesterday I found some bugs in Opus's WMA code which could cause things to fail, although I have never seen it result in the cover not being shown at all. The fixes will be in the next update.

Do you see the covers in Windows Explorer? If so, temporarily turning off the WMA plugin in Opus may help, by making Opus fall back on the shell to get the thumbnails, although it will also lose you WMA metadata as well.

We're talking about MP3's.
Sorry, I didn't talk about showing Thumbnails. This is working OK in DOpus. What I meant is they aren't shown in the Metapane Coverart-Field.

Works fine here:

Maybe there's some other tags in the MP3 file(s) you are editing which are confusing things.

I used "folder.bmp" as source Image which was working when applying it with DOpus. It's working when I use "folder.jpg" like in your video. Thanks.

So the bug in Opus is where, exactly?

Coverart tags can only store PNG or JPG data.

If you tell Opus to add a BMP, Opus converts it to JPG.

WMAAlbumArtist.exe assumes whatever you give it is a JPG file, and does not check that it really is or try to convert it if it isn't. If you tell WMAAlbumArt to add a BMP, it blindly adds the file to the tags and flags it as a JPEG file, producing an invalid tag which Opus is right not to understand.

So if there is a bug anything, it's in WMAAlbumArtist.exe (or how you are using WMAAlbumArtist.exe; I doubt I'll find time to make it check that the given JPG is really a JPG).

Thanks for clarifying this leo. So it's not a bug but lack of knowledge on my side.

Leo, I've only just started using this. It's awesome.

One problem though.... When I run the "WMA Add Cover" command, my firewall (Comodo) pops up with an alert "dop201402182055100324.bat is trying to access the disk directly". I select Allow > Treat as a trusted Application and check "remember my answer". This is proceeded by another popup "dop201402182055100324.bat is trying to execute chcp.exe". Again, I allow this and all works fine. When I run the command again the same popups appear but with a different filename (dop201402182052250877.bat) meaning I have to go through the same process with Comodo every time I run it.

Other than switching off Comodo, is there a way of avoiding this?

Comodo is being silly, to be frank. If something is already able to run code to create .bat files in the temp dir and then execute them, then it could be doing anything else that it wants. There's nothing particularly suspicious about a .bat file in the temp dir.

That will affect all Opus MS-DOS Batch Type buttons, unless a particular line in the .bat file is triggering Comodo. (It Comodo only does it for some buttons / .bat files then maybe it happens if a .bat file looks like it will run a program flagged as downloaded from the web, or maybe it has other heuristics; I have no idea to be honest. Best ask Comodo about that as it's the thing causing the problem.)

Cheers Leo, I'll get onto Comodo. Is this the right place to ask what firewall you use/recommend?

I use a hardware firewall.

I don't know what they are but I'll do some Googling, thanks Leo.