Slow Reading Folder

My DOpus has become if not unusable then quite annoying. The problem I'm having is that the first time opening a folder with a file of any size at all (say 200MB to 2GB) I get a "Reading Folder" with a green progress bar with also an option to Abort. This will take anywhere up to five to eight seconds before the file becomes available. Once I've opened that folder the next time I go back the file is instantly available without the wait.

I am using the current version of DOpus. I can't pinpoint when this problem began, but I've been a user for well over 10 years and never recall this problem happening before. I should also say I've experimented with other file managers and I don't have this problem.

I have gone through all the folder help guides and turned off everything recommended. I also changed the Registry thumbnail view to 0. Nothing seems to help so I welcome any further assistance so that when I open a folder the file within is available immediately as it used to be.

Thank you.


That sounds like either:

  • The drive is spinning down and going to sleep, and you have to wait for it to spin up again the next time it is accessed.

  • Antivirus is getting in the way somehow and blocking things for a long time that would normally be fast.

If neither of those explain things, please link your account and send some Process Monitor logs and we might be able to work out what's happening on the system that is slowing things down.

Checking the same thing in other software in case it's not limited to Opus is also a good thing to verify, although it might be difficult if it never happens twice in a row.

Thank you for your response. Per the spinning down hard drive I changed the power setting to 240 minutes to test. I will say it seems to have worked to a certain extent but the problem still exists.

Per the process monitor log file I sent you the file I tried to open took over six seconds. I ran PM from the taskbar, opened DOpus, then clicked on the folder where the file was located. Once it was read I then captured the PM events which I've already sent to you.

When I was trying to think of when this problem started I remembered I upgraded from V11 to V12 in December 2018. I'm not stating specifically I'm certain that's when the problem began, but I know I never had it in V11.

I tried another file manager and the files were available instantaneously.

Like I said previously, when going back to the folder where a file has already been read at least once it is available instantaneously. But, it's a crap shoot reading a folder for the first time.

Let me know if there's anything else I can provide.

Thanks again/Randy

Edited to provide further clarifying information.

You mean folder, not file, right?

In the log file, which folder was slow to read? The log seems to show several different folders being read and I'm not sure which to focus on.

Yes, I'm sorry, I clicked on the folder and it took roughly six seconds for the file to appear in the other pane.

This is my first time using Process Monitor so maybe I'm doing something wrong. Like I stated previously, I restarted my computer, opened PM from the taskbar, opened DOpus from the taskbar, navigated to the folder and then once the file was available went back to PM and captured the processes to that point. I navigated to an E:\ drive which I'm not seeing there.

I can try this again if you have an idea how I can do it to make it easier for you.


The root of E:\ or a sub-folder? What was the full path of the folder which was slow to load?

E:\Newsleecher\Awaiting Burn

This looks like a network drive, is that correct?

When you changed the spin-down time, did you change that locally on your machine, or did you change it on the server the drive is inside of? The change would only make a difference (to that drive) if it was done on the server.

Some drives also ignore the Windows setting and do their own thing regardless, sometimes with their own settings tools to change it (sometimes with no way to change it).

Something a bit random that may not be related: During one of the delays it looks like some Apple software is talking to an Apple device (probably an iPhone) over the network. That could be delaying things if Opus is showing the device in the folder tree or on toolbar drive-buttons and it is taking a long time to query (e.g. for its label / icon / free space details). Worth a try disconnecting that if it is there, in case it makes a difference. It may not be involved, though.

It is not a network drive. It is a 7200 RPM HDD SATA drive off the network and fully defragged.

Let's back up a bit here. I downloaded Total Commander to test its reading of my folders. I had it open in dual pane just as I do with DOpus. Clicking on a folder in the left pane of TC results in an immediate availability of the file within in the right pane.

Some DOpus folders have near immediate availability of the file within, others take 5-6 seconds or more.

I've had my iPhone over a year and this problem didn't exist when I first got it so I don't think that's the problem.

Also, as I've said before, I've used DOpus for over 10 years without this problem until V12.

Thank you for your continued efforts to isolate this problem.

I don't know why but this seems to have fixed the problem.

Before I had E:\Directory\Subdirectory in which reading folders in the Subdirectory was the problem. So, I changed the Subdirectory to E:\Directory1 and now the files from those folders are available instantaneously just as they used to be.

I don't know how or why this problem manifested itself as I'd been using the original set-up for years without a problem. But, all's well that ends well.

Thanks for your help with this, and I hope it helps someone else in the future.