GP SoftwareTwitter
Opus FAQsManualCommandsObjects

SSL error with version 10.0.2.0


#9

Just a possbility but unlikely to help it seems. Use the Opus 9 SSL libraries.


#10

My Win7 x64 machine at home is also having this problem :confused:


#11

The files in the zip did not make any difference on my x64 machine.

Will be trying the x32 files in a while here.


#12

Sorry to say that the 32 bit libraries did not work on the XP x32 machine either :confused:

Thanks for the attempt!


#13

I have exactly the same problem with Opus x64 version 10.0.2.0 running on Windows 7. I updated directly through Opus which may be part reason why it has a problem?


#14

That shouldn't be a factor, provided you rebooted after installing the update.


#15

I rebooted.


#16

I have tried using the old version 9 libraries as suggested in the above post but the problem still persists.

I am presuming then it may not be an issue with the libraries but with Opus itself?


#17

(Edit: Don't worry about this for now as the info may not be needed. If it turns out we need it again, I'll post another request.)

Hi everyone,

I plan to post some test/diagnostic programs for you to run in the next few days to try to get to the bottom of this.

In the mean time, it would be really useful if everyone experiencing the issue could post a list detailing:

[ol][li]Version of Windows (including 32 or 64 bit).

[/li]
[li]Version of Opus the problem was first seen in.

[/li]
[li]Whether or not SSL worked in older versions. (i.e. Was the problem first seen because it's the first time you ever used SSL, or were you using it before and it stopped working after an update.)

[/li]
[li]Any anti-virus or firewall software you have (ignoring Windows Defender and the Windows Firewall).

[/li]
[li]A list of non-Microsoft tools you have installed which include shell extensions.

This may be important! Jon, Greg and myself have been unable to reproduce the problem on our own machines and on vanilla Windows installs, so the problem may be caused by something that gets loaded into the Opus process (via a shell extension) which, for example, has already loaded a conflicting version of the SSL libraries.

Making this list is easy:

[ul][li]Download ShellExView (64-bit users, be sure to get the x64 version).

[/li]
[li]You don't have to install it, just unzip the archive and run ShellExView.exe.

[/li]
[li]In ShellExView, Make sure Options -> Mark Non-Microsoft Extensions is enabled. (You should see some of the extensions highlighted with a pink background.)

[/li]
[li]In ShellExView, sort by the Company column. You should get a bunch of pink, non-Microsoft items at the top of the list, and another bunch at the bottom, with the Microsoft ones in the middle. Like this:




[/li]
[li]Go through the pink items and make a list of the software that installed them. Some software will install multiple items; you don't need to list every individual item, just the software that it is a part of.

For example, if you saw something like this you'd only need to list Directory Opus, TextPad and TortoiseSVN:




[/li]
[li]Don't forget to do the items at the bottom of the list![/li][/ul][/li][/ol]

Thanks!


#18

OS:
Windows 7 64bit

DOpus Version:
10.0.2.0.4269.x64

SSL worked in previous versions: 10.0.1...

Antivirus:
Vipre 4.0.4194

Shell Extensions:

"..." means multiple entries from software.

Bluewire General Property Sheet             	Property Sheet       	ContextH Application                         	1, 0, 0, 1  	ContextH Application
FileZilla 3 Shell Extension                 	Copy Hook Handler    	fzshellext Dynamic Link Library              	3, 2, 7, 0  	fzshellext Dynamic Link Library
Microsoft XPS Rich Preview Handler          	Preview Handler
NuSphere Debugger ToolBar                   	IE Toolbar           	NuSphereIEBar Module                         	6.1.0.6116  	NuSphereIEBar Module
InDesign Icon Handler                       	Icon Handler         	Icon Handler Plug-in                         	7               Adobe InDesign                         	Adobe Systems Incorporated
Hex Workshop Shell Extension                	Context Menu         	Hex Workshop Shell Extension                 	6.5.0.5050  	Hex Workshop                           	BreakPoint Software, Inc.
BtwContextMenu2 Class                       	Context Menu         	BtwNamespaceExt DLL                          	6.3.0.8200  	Bluetooth Software                     	Broadcom Corporation.
BtwSendtoExplorer Class                     	Drop Handler         	BTNCopy Module                               	6.3.0.8200  	Bluetooth Software                     	Broadcom Corporation.
...
ImageHandler3 Class                         	Thumbnail            	Artisteer Thumbnailer for Windows Explorer   	1.0.0.1     	Artisteer                              	Extensoft
DVDFAB64                                    	Context Menu         	DVDFab Shell Extension - x64                 	2.0.1.0     	DVDFab Shell Extension                 	Fengtao Software Inc.
Directory Opus Context Menu                 	Context Menu         	Directory Opus 10 Support Library            	4, 0, 2, 7  	Directory Opus                         	GP Software
...
7-Zip Shell Extension                       	Context Menu         	7-Zip Shell Extension                        	9.22 beta   	7-Zip                                  	Igor Pavlov
...
MBAMShlExt Class                            	Context Menu         	Malwarebytes' Anti-Malware                   	1.50.1.0000 	Malwarebytes' Anti-Malware             	Malwarebytes Corporation
WinSCP Shell Extension                      	Copy Hook Handler    	Drag&Drop shell extension for WinSCP (64-bit)	1.1.9.119   	WinSCP                                 	Martin Prikryl
DesktopContext Class                        	System               	NVIDIA User Experience Driver Component      	7.17.12.7533	NVIDIA User Experience Driver Component	NVIDIA Corporation
NVIDIA CPL Context Menu Extension           	Context Menu         	                                             	275.33	NVIDIA Shell Extensions                	NVIDIA Corporation
PowerISO                                    	Context Menu         	PowerISOShell DLL                            	4, 5, 0, 0  	PowerISO Shell Dynamic Link Library    	PowerISO Computing, Inc.
EDPShellExtObj Class                        	Context Menu         	ExamDiff Pro Shell Extension                 	5	ExamDiff Pro Shell Extension           	PrestoSoft LLC
FTP Voyager Drag and Drop Copy Hook Handler 	Copy Hook Handler    	FtpTree Shell Extension DLL                  	15, 2, 0, 15	Rhino Software FtpTree ActiveX Control 	Rhino Software, Inc. +1(262) 560-9627
DSShell Class                               	Context Menu         	Right Hemisphere Thumbnail Provider          	           	Right Hemisphere Thumbnail Provider    	Right Hemisphere
...
NFO Preview Handler                         	Preview Handler      	Source Preview Handler                       	1.0.1.0     	Source Preview Handler                 	SmartSoft Ltd.
...
BackedUpOverlay Class                       	Icon Overlay Handler 	SugarSync Explorer Shell Extensions          	1.0.0.1     	SugarSync                              	SugarSync, Inc.
...
Java(tm) Plug-In 2 SSV Helper               	Browser Helper Object	Java(TM) Platform SE binary                  	6.0.250.6   	Java(TM) Platform SE 6 U25             	Sun Microsystems, Inc.
ShellExtInit Class                          	Context Menu         	Secure File Eraser Shell Extension           	4.0.4194    	VIPRE Antivirus                        	Sunbelt Software
...                  

#19

I thought it a bit strange when this problem appeared because I was sure I had already connected using TLS and was able to view files with the viewer pane after upgrading to 10.0.2.0. This evening I managed to get it working again and I have a sort of fix. When you connect and login with your lister it must some how lock the DLL from Opus process using it again? A way around it is to stay connected and let Opus timeout the connection (you will hear that typical Opus lose FTP connection sample sound). Next open your viewer pane and then select a file on the FTP to view. Opus reconnects and then views the file. Select another file and it must drop connection before reconnecting and viewing again. As soon as I refresh the lister so that Opus reconnects and logs back in and I go to view a file it produces the error message.


#20

Many thanks, Mr Hall.

The combination of a TLS site and the viewer pane makes the error message appear for me as well.

We'll look into it further and I'll post an update here when I have some news.


#21

Here is a preliminary fix for those who wish to try it:

< Links removed; the fix is now part of Opus 10.0.2.1 >

(The EXE files inside are digitally signed, for those who wish to verify them.)

This is hot off the compiler and only tested on my own machine. It's up to you if you want to try the fix now or wait for the dust to settle.

To install:

[ul][li]Make sure you already have Opus 10.0.2.0 installed.

(The fix will only work if applied on top of 10.0.2.0, which is currently the latest version.)

[/li]
[li]Download the appropriate zip and extract it to somewhere (e.g. your desktop).

(Each zip contains a new dopus.exe file and nothing else.)

[/li]
[li]Exit Directory Opus.

[/li]
[li]Using Windows Explorer (or anything other than Opus itself), copy the replacement dopus.exe that came from the zip over the top of your your existing copy, which will usually be in C:\Program Files\GPSoftware\Directory Opus.

(If the file is in use and cannot be overwritten, you probably didn't exit Opus properly, or you did something that caused it to start up again.)

[/li]
[li]Start Opus again.[/li][/ul]

Please let us know if it solves the problem for you.


#22

I found a problem with the fix from earlier and have replaced it with a new version, linked above. (Make sure the zip you download has "TestB" in the name, not "TestA".)


#23

I can confirm that "TestB" (I didn't try TestA) seems to work on TLS ftp.

Excellent!

Are you able to reveal the nature of the issue?
Also would you consider this "stable" enough for use, I should we roll back to 10.0.1.x again?

Thanks,

Adrian.


#24

[quote="agwd"]I can confirm that "TestB" (I didn't try TestA) seems to work on TLS ftp.

Excellent![/quote]

Great! Thanks for testing & confirming it.

There was a bug to do with how multiple concurrent SSL/TLS connections were handled.

The changes are quite isolated and so should carry a low risk, but it is also untested code (apart from the testing we're doing now!) and could bring with it unexpected problems.

I think using it should be fine, and I am using it now myself, but I guess it really depends whether or not the 10.0.1.0 -> 10.0.2.0 changes are important to you.


#25

Yes, it is working for me now, thank you. I noticed every time you view something in the viewer pane it has to create a new connection rather than using the same connection from the lister layout. Is there a way around this so it does not always need to establish a new connection?


#26

Not thay I know of. I don't know if that is how it has always been or not, since I don't use SSL/TLS sites or the viewer on FTP much myself, but I'll mention it to Greg and Jon.


#27

Hi Leo,

It's working here on the XP x32 machine so far. Will test it further tomorrow. Will also download the x64 version tonight and test it on my Win7 machine and let you know how that goes.

Thanks!


#28

Hello again Leo,

It is working well here on Win7 x64 as well :slight_smile: