SSL error with version

After making a connection to an FTP server using Secure TLS explicit the directories will not expand in the tree view. I can click on subdirectories in the file pane but then moving back up the error is given again. There are no errors in the FTP log that I can see. The error is attached.

Which version of Windows are you using?

Do you know if this only started happening for you with, or is this the first time you've tried to use FTP+TLS?

Hi Leo,

This on on Windows XP SP3.

This has just started happening yes. I have occasionally seen DO crash while connected to FTP but this is the first time in version 10 that I have gotten this error.



The SSL libraries were updated in Opus 10 for OpenSSL 1.0.0d for security and to ensure Opus provides the latest SSL support. The original Opus 10.0 version of these were compiled as the default OpenSSL libraries which unfortunately uses dynamic linking so the Microsoft VS Assemblies are also required. If you are using an Opus 10 version that less than version 10.0.2, please upgrade to the latest versioin. We upgraded the SSL libraries to be correctly statically linked so as not to require extra MS libraries.

If you are using 10.0.2, then note that OpenSSL changed the linking in the libraries to use the later version of winsock (now WS2_32 - winsock2) used in the compile whereas the older 0.98 versions still used a much earlier wsock32.dll library (essentially from windows 98 as I remember).

Check if ws2_32.dll is installed on your machine and if not upgrade the winsock part of your OS as per Microsoft instructions.

If this does not resolve the issue, note that we have seen a very rare case on 64-bit systems where these new 1.0.0.d libraries do not work and we are unable to really define why this is so. The solution is to downgrade the OpenSSL libraries used in Opus 10 and use the original ones from Opus 9.

You can download the older Opus 9 OpenSSL libraries from here. Unzip and replace the ones in the Opus home folder.

(UPDATE: A more likely fix is on the second page of this thread. Try that before this one.)

Hi Greg,

I do have the file ws2_32.dll in the system32 directory and it is dated 4/14/08.

This is just 32 bit Win XP but I will see if downgrading the OpenSSL in DO fixes it.



Just realized that that is a x64 download so did not do it after all.

You (Greg) and I worked on an issue between DO and Pure FTP previously, do you think that this could be related? It is the same server that I am trying to connect with. Although there are no errors in the local FTP log nor in the server log so I am at a loss here.

At least I can still connect without TLS.

(UPDATE: A more likely fix is on the second page of this thread. Try that before this one.)

I'll post the 32 bit OLD versions later today. They will be

If this does not solve the issue then talk to us directly via email please.

hi guys, I just updated with for Win7x64 and this happened too.

What's the winsock patch referring to, and does it apply to win7x64? should I use the dopus 9 libraries?


Just a possbility but unlikely to help it seems. Use the Opus 9 SSL libraries.

My Win7 x64 machine at home is also having this problem :confused:

The files in the zip did not make any difference on my x64 machine.

Will be trying the x32 files in a while here.

Sorry to say that the 32 bit libraries did not work on the XP x32 machine either :confused:

Thanks for the attempt!

I have exactly the same problem with Opus x64 version running on Windows 7. I updated directly through Opus which may be part reason why it has a problem?

That shouldn't be a factor, provided you rebooted after installing the update.

I rebooted.

I have tried using the old version 9 libraries as suggested in the above post but the problem still persists.

I am presuming then it may not be an issue with the libraries but with Opus itself?

(Edit: Don't worry about this for now as the info may not be needed. If it turns out we need it again, I'll post another request.)

Hi everyone,

I plan to post some test/diagnostic programs for you to run in the next few days to try to get to the bottom of this.

In the mean time, it would be really useful if everyone experiencing the issue could post a list detailing:

[ol][li]Version of Windows (including 32 or 64 bit).

[li]Version of Opus the problem was first seen in.

[li]Whether or not SSL worked in older versions. (i.e. Was the problem first seen because it's the first time you ever used SSL, or were you using it before and it stopped working after an update.)

[li]Any anti-virus or firewall software you have (ignoring Windows Defender and the Windows Firewall).

[li]A list of non-Microsoft tools you have installed which include shell extensions.

This may be important! Jon, Greg and myself have been unable to reproduce the problem on our own machines and on vanilla Windows installs, so the problem may be caused by something that gets loaded into the Opus process (via a shell extension) which, for example, has already loaded a conflicting version of the SSL libraries.

Making this list is easy:

[ul][li]Download ShellExView (64-bit users, be sure to get the x64 version).

[li]You don't have to install it, just unzip the archive and run ShellExView.exe.

[li]In ShellExView, Make sure Options -> Mark Non-Microsoft Extensions is enabled. (You should see some of the extensions highlighted with a pink background.)

[li]In ShellExView, sort by the Company column. You should get a bunch of pink, non-Microsoft items at the top of the list, and another bunch at the bottom, with the Microsoft ones in the middle. Like this:

[li]Go through the pink items and make a list of the software that installed them. Some software will install multiple items; you don't need to list every individual item, just the software that it is a part of.

For example, if you saw something like this you'd only need to list Directory Opus, TextPad and TortoiseSVN:

[li]Don't forget to do the items at the bottom of the list![/li][/ul][/li][/ol]


Windows 7 64bit

DOpus Version:

SSL worked in previous versions: 10.0.1...

Vipre 4.0.4194

Shell Extensions:

"..." means multiple entries from software.

Bluewire General Property Sheet             	Property Sheet       	ContextH Application                         	1, 0, 0, 1  	ContextH Application
FileZilla 3 Shell Extension                 	Copy Hook Handler    	fzshellext Dynamic Link Library              	3, 2, 7, 0  	fzshellext Dynamic Link Library
Microsoft XPS Rich Preview Handler          	Preview Handler
NuSphere Debugger ToolBar                   	IE Toolbar           	NuSphereIEBar Module                  	NuSphereIEBar Module
InDesign Icon Handler                       	Icon Handler         	Icon Handler Plug-in                         	7               Adobe InDesign                         	Adobe Systems Incorporated
Hex Workshop Shell Extension                	Context Menu         	Hex Workshop Shell Extension          	Hex Workshop                           	BreakPoint Software, Inc.
BtwContextMenu2 Class                       	Context Menu         	BtwNamespaceExt DLL                   	Bluetooth Software                     	Broadcom Corporation.
BtwSendtoExplorer Class                     	Drop Handler         	BTNCopy Module                        	Bluetooth Software                     	Broadcom Corporation.
ImageHandler3 Class                         	Thumbnail            	Artisteer Thumbnailer for Windows Explorer     	Artisteer                              	Extensoft
DVDFAB64                                    	Context Menu         	DVDFab Shell Extension - x64             	DVDFab Shell Extension                 	Fengtao Software Inc.
Directory Opus Context Menu                 	Context Menu         	Directory Opus 10 Support Library            	4, 0, 2, 7  	Directory Opus                         	GP Software
7-Zip Shell Extension                       	Context Menu         	7-Zip Shell Extension                        	9.22 beta   	7-Zip                                  	Igor Pavlov
MBAMShlExt Class                            	Context Menu         	Malwarebytes' Anti-Malware           	Malwarebytes' Anti-Malware             	Malwarebytes Corporation
WinSCP Shell Extension                      	Copy Hook Handler    	Drag&Drop shell extension for WinSCP (64-bit)   	WinSCP                                 	Martin Prikryl
DesktopContext Class                        	System               	NVIDIA User Experience Driver Component	NVIDIA User Experience Driver Component	NVIDIA Corporation
NVIDIA CPL Context Menu Extension           	Context Menu         	                                             	275.33	NVIDIA Shell Extensions                	NVIDIA Corporation
PowerISO                                    	Context Menu         	PowerISOShell DLL                            	4, 5, 0, 0  	PowerISO Shell Dynamic Link Library    	PowerISO Computing, Inc.
EDPShellExtObj Class                        	Context Menu         	ExamDiff Pro Shell Extension                 	5	ExamDiff Pro Shell Extension           	PrestoSoft LLC
FTP Voyager Drag and Drop Copy Hook Handler 	Copy Hook Handler    	FtpTree Shell Extension DLL                  	15, 2, 0, 15	Rhino Software FtpTree ActiveX Control 	Rhino Software, Inc. +1(262) 560-9627
DSShell Class                               	Context Menu         	Right Hemisphere Thumbnail Provider          	           	Right Hemisphere Thumbnail Provider    	Right Hemisphere
NFO Preview Handler                         	Preview Handler      	Source Preview Handler                   	Source Preview Handler                 	SmartSoft Ltd.
BackedUpOverlay Class                       	Icon Overlay Handler 	SugarSync Explorer Shell Extensions      	SugarSync                              	SugarSync, Inc.
Java(tm) Plug-In 2 SSV Helper               	Browser Helper Object	Java(TM) Platform SE binary            	Java(TM) Platform SE 6 U25             	Sun Microsystems, Inc.
ShellExtInit Class                          	Context Menu         	Secure File Eraser Shell Extension           	4.0.4194    	VIPRE Antivirus                        	Sunbelt Software

I thought it a bit strange when this problem appeared because I was sure I had already connected using TLS and was able to view files with the viewer pane after upgrading to This evening I managed to get it working again and I have a sort of fix. When you connect and login with your lister it must some how lock the DLL from Opus process using it again? A way around it is to stay connected and let Opus timeout the connection (you will hear that typical Opus lose FTP connection sample sound). Next open your viewer pane and then select a file on the FTP to view. Opus reconnects and then views the file. Select another file and it must drop connection before reconnecting and viewing again. As soon as I refresh the lister so that Opus reconnects and logs back in and I go to view a file it produces the error message.

Many thanks, Mr Hall.

The combination of a TLS site and the viewer pane makes the error message appear for me as well.

We'll look into it further and I'll post an update here when I have some news.