Symlink, OneDrive and problems saving

I have a symlink (soft link, Win 10) on my D-drive which point to an Excel-file residing on my E-drive in my OneDrive directory (and a local copy is always saved).

When I click on the symlink, the Excel-file opens, but then I can't save any changes: I get an error message talking about sharing problem and then it saves a strangely named file without file suffix inside the symlink directory. Why? How to fix?

If I do exactly the same, but use Windows Explorer instead of DO, it works just fine (and as expected).

I use DO 12.23. I use OneDrive for Business in a single user environment.

What does the error message say exactly? Please post a screenshot.

If you go into the target of the symlink in Explorer and double-click the file there, do you see the same problem?

Opus may be resolving the symlink to its target before asking Excel to open it, but it should not make a difference.

If you're using Windows Defender, or any similar anti-ransomware protection, that can get in the way of programs opening and writing to your document files/folders. It would normally be Excel writing to the file, not Opus, but it could be treated differently if it's launched from Opus (or other software) vs Explorer. See Problems caused by Windows Defender (strange behavior when using Opus) if that seems like a possibility.

The error says: "Changes could not be saved to [the file name] because of a sharing error. Try to save to another file."

It takes like 10 seconds before this error shows up. Auto saving is not used with DO. If I open in WE auto saving is chosen by default (and also works).

It doesn't matter if I open the file with the symlink or if I double click the target when I use WE - it works fine either way.

Disabling Bitdefender doesn't seem to help.

Do you have the viewer pane open and showing the file or anything like that?

The error is coming form Excel and indicates that something else has the file open/locked. Opus shouldn't actually be involved there, unless some part of Opus (or a viewer opened on Opus's behalf) has the file open, or unless Excel is being confused in some way by being asked to open the file in a slightly different way (which is strange, but OneDrive and Office can be weird at times).

No, I don't.

As a test, please select one of the Excel files in Opus, then type a > into the file display, so the Command Field appears at the bottom, and paste in this command:

FileType ACTION=shellex

Push return and the file should open in Excel. Does it save OK when you do that?

If I do that, it works ok to save!

That's odd, but good as well. It seems like an Excel issue which depends on exactly how it is asked to open the files.

As a workaround, you should be able to make things work by putting the same command (FileType ACTION=shellex) as the Excel file type's Left Double-Click event:

  • In Opus, Settings > File Types
  • then System File Types > XLSX
  • then the Events tab
  • Double-click Left double-click in the list, and set it to FileType ACTION=shellex

Doing the same for XLS probably makes sense as well.


Actually it is not Excel-files in general that is the problem, but only symlinks referring to e.g. Excel-files. But I tested to open the real file (target) with your command "FileType ACTION=shellex" and that didn't change anything in a bad way as far as I can see. But is there an alternative to "FileType ACTION=shellex" which only works for symlinks?

It's Excel itself that's having the problem, or maybe OneDrive, for whatever reason. Once Excel opens the file (which obviously works), Opus is out of the picture. But for some reason, depending on how Excel is told to open the file, it can run into issues when saving it.

There shouldn't be any drawback in using the workaround all the time. No reason to complicate things by only using it with symlinks or OneDrive/


Maybe I am blind... but I don't see the Events tab in step 3...??

I don't have Excel on this machine so I've used the XPS file type, but you should see the same sort of thing for Excel's types:

Found it, thanks!