The Specified Procedure could not be found

I have this 'error' pop up when I double click a file that usually has always opened its associated program, for example an avi or jpg.
The requester pops up, but when I close it, the program needed runs as normal.
Any idea's please?

Does the same thing happen in File Explorer?

Which program is opening the files?

Please paste a screenshot of the message to the forum.

This is what pops up, then when I close it, the associated program runs.
I have Dopus as my Explorer replacement so don't really know how to use Explorer.

You can launch Explorer via the Start Menu, or explorer.exe, or from within Opus via Tools > Open in Explorer.

That's the long way around, but no, the requester does not appear.
Also, I have tried to re-affirm filetypes associated with the files and they are all fine.

Which program is opening the files?

In the case of the avi files, the Microsoft’s Media player opens it.
What I find interesting is I have the file typos set to use Film & Tv.
This works till I close that and then try again to reopen it, in which case it shows that request or again and then opens in Media player again.

Have you tried using Right-click > Open With > Choose Default Program on a file to assign Media Player (or whichever program you want) as the default?

That will sometimes override things at a higher level than assigning extensions via Windows Settings, and sometimes resolves issues like this.

If that still doesn't work, you may be able to work around the issue by using Settings > File Types in Opus to override the double-click event for the file type (or file type group, e.g. Movies). Doing that will tell Opus to run a specific program on the file directly, without having to worry about the Windows registry.

Thanks for giving me a hand with this Leo, yes, both of those methods work, but I still get the request or when I just double click the file within Dopus itself. It’s a weird one.

While the error message is on screen, could you generate a process snapshot and send it to us?

In this case, one should be enough, contrary to the instructions. (Usually more are needed, but not in this case.)

Hi Leo,
followed your detailed instructions and sent a dropbox link to crashdump.


1 Like

Thanks for sending in the snapshot.

The error is coming from the Windows shell, which seems to be reacting to something in the registry being wrong for that file type.

If you right-click the same file and choose Open, do you get a similar error message? If so, does the same happen in File Explorer as well?

Failing all else, you may be able to fix things by doing this:

  • Settings > File Types.
  • Double-click the relevant extension in the list.
  • On the Events tab, set Left Double-Click to run this:
    FileType ACTION=shellex

That will force the double-click to be handled in a different way, which may bypass the problem in the registry.

Hi Leo,
The problem has ceased…at the moment, so I can’t follow your instructions…yet.
It has done this before, so as soon as it comes back, I will give it a go and see what it gets me.
Your help is greatly appreciated.

1 Like

mp4 / avi does this same thing for me,
right click in opus, then picking "open with" works correctly in opus
double click on file in opus gives me the error message on the first file of such type. Clicking OK on the error then opens player correctly
on second double click with player still open though (now on different file), nothing happens

error message is a modal dialog with first line being a path to the file, and second line blank, and third line in dialog is "The specified procedure name could not be found."

only one option is presented of "OK"

latest opus 12.26.1 beta, with win version 21H2 build 22000.438

one other note - adding the suggested "FileType ACTION=shellex", makes it always fail with the error shown when added to .mp4 file type, or to movies group under Events

Have you tried using Right-click > Open With > Choose Default Program?

right click -> open with - Seems to always work
double click - one of three things happens
- get spinning cursor for a bit, and then nothing
- opens video OK in correct app
- nothing apparant happens

Of course, today I can't seem to make it break. Maybe the last windows update fixed it.

Not just Open With, but Choose Default Program from within that menu. That will usually fix which program opens on double-click (unless the filetype doesn't exist in the registry properly).

I hate to resurrect an old thread, but this same thing (all image files - png, jpeg, jpg, etc.) are doing the same thing. I have assigned and re-assigned them to Microsoft Photo Viewer multiple times. It works in normal File Explorer, XYplorer, etc. I've tried all kinds of things no no avail.

Windows 11, version below:
Directory Opus Pro 12.30.2 (Beta) Build 8424 x64
OS 10.0 (B:22621 P:2 T:1) SP 0.0

Are you seeing an error message saying "The Specified Procedure could not be found", or do you just mean you can't change which program is used when those files are double-clicked?

Which things from the above thread have you tried?