Toolbar nightmare


I am having weird problems with the toolbars. When i click on customize the toolbar, i cant make a selection on the toolbar list, the checkmark doesnt always work and i end up having several copies of the same toolbar (ex: several application toolbars on dopus window).

All sort of behaviours happen when i try to fix the toolbar positions or turn on/off one of them.

Also i checked the buttons directory inside directory opus installation directory, and sometimes several files are created. For example, i have a Drives.dop file, then suddenly (after it makes me go crazy with auto creation of several toolbars on dopus) i get Drives.dop.dop, Drives.dop.dop.dop, etc.

Has this ever happened to anyone here? How can i fix it?

I know this might come out the wrong way, but could this be caused by zonealarm? I have it installed too.


These threads might be of use:

[Shared Config vs Personal Config)

[Strange customize problem)

Hey, nudel,

i read throught both threads and got some good ideas. The one that seemed to be the solution was about the location of the configuration files. I installed requesting it to be for a single user but it insisted to make it for a shared install. The problem is that no matter how i choose it to be in preferences->miscellaneous (i click and restart dopus), then it asks if i want to copy the configuration files to my private data folder, to which i reply yes (i check the option), but dopus still keeps it shared, completely ignoring my wish. :stuck_out_tongue:

So i still have the darn problem. Is there someplace/file where i can edit the path to the configuration files manually?

But shouldnt dopus work fine either way it stores the configurations? Weird. What sometimes feels like is that, although it stopres config files shared, it checks private folders. ahh, i dont know.

What i also find odd is that on the customize toolbar list, where we can check and uncheck, nothing works. I can click away at the toolbar items and it doesnt get a checkmark, but i keep getting copies of the toolbar in dopus.

Also tried to check the permissions, which seem ok, i can create files everywhere. I am logged in as administrator, using windows xp, and theres no other user on this computer.

Any other suggestion will be highly appreciated. Thanks in advance.

You have to restart Opus for that change to take effect. Were you doing that?

Still doesn't explain the .dop.dop.dop thing which I don't understand. Don't know really!

There were reports that something other than Opus seemed to be removing people's permissions from their own profile directories (which can be done even to an admin account, though an admin can always regain the permissions) but I don't think anyone ever got to the bottom of exactly what was happening.

I'd try removing/disabling ZoneAlarm to see if that helps. ZA breaks a load of stuff and generally seems to interfere with perfectly legitimate programs doing perfectly legitimate things. :frowning:

Let us know what you find.

I tried switching back and forth between global and shared configurations and did not seen this problem. Not sure of any way of 'breaking it'... but what happens if you shut down Dopus (tray icon->exit) then use explorer to manually move all of the DOP files out of the 'Buttons' folder. Restarting Dopus should regenerate the default toolbar DOP files... do you still see the problem after that?

Nudel: Yes, i restarted opus everytime i made any change.

Even if i try to work with dopus without zonealarm active (shutdown), the same problems exist.


Exited dopus, moved the buttons directory from the shared dir (c:\documents....\administrator\local settings\gpsoftware\directory opus\buttons), to the dopus install dir. Restarted dopus and i still have the same problems. Too weird for me.

I uploaded a picture for you guys to see how it is:

Notice the customize window on the lower left corner, it doesnt have any bars clicked, but you can see i am using application, path, drives, etc. And if i click on any of the items on the list, no checkmark appears and i get duplicate tabs on my dopus.

I installed dopus on my laptop to try it out too. Also have zonealarm in there. Dopus runs perfectly! I can customize all i want, and on miscellaneous...etc, the seeting for the configuration is "private folders", which is what i chose while installing. Like i did on this pc but its stubborn and keeps using shared.

Another question that you might ask is if i have any other weird progs in here. Its a clean windows xp install. I have zonealarm, microsoft antispyware and barely nothing else. The laptop has more junk and there it works. :stuck_out_tongue:

Again i ask, is there any way i can change the configuration settings from shared to private manually? This is driving me nuts, dopus is my tool of choice, i honestly believe windows will not run if i stop using it. :wink: In fact, windows should have dopus as its default file manager.

I would double-check the file permissions from the Buttons folder in your profile though each parent folder until you reach the root of C:. They should look similar to the screenshot below. (Where several Properties dialogs are on top of each other each one showed the same information.)

[Click the screenshot for a full-size version.]