TortoiseGit suddenly stopped working in DirectoryOpus

For years I use TortoiseGit and DirectoryOpus, and it works great. Suddenly, today that is no longer the case. Overlay icons show in Explorer, don't show in DirectoryOpus, context menu the same.

In Explorer:

In DOpus:

I use latest Windows 10 Pro, Directory Opus 12.12. And, everything was OK until today, yesterday it was working fine! I removed both TortoiseGit and DirectoryOpus, and reinstall them (same versions I used before), restarted Windows, but it is not working

How can I solve this?

If a context menu extension crashes inside the Opus process its GUID will be automatically added to Preferences / Miscellaneous / Advanced [Troubleshooting]: ignore_context_menus, so first off I'd check that setting and try clearing it to see if it makes it start working again.

This option is empty. And, even with the Shift / Right Click, the TortoiseGit is not shown.

Do the overlays and menu appear anywhere other than Explorer? e.g. Notepad's File Open dialog.

If TortoiseGit is similar to TortoiseSVN, then it has an option that excludes the overlays and context menus from everything except Explorer. Maybe that's turned on?

It was not turned on. But, I turned it on and saved. Opened settings again, turned it off, and saved. And, now menu is back in DOpus. It was something related to TortoiseGit settings, and this option on/off solved it.

Thanks for your help with this!

1 Like

@GDragoN that was an easy fix. :slight_smile:

I have the same issue and unfortunately the fix is n/a in my case. :frowning:
I use Opus 12.19 x64 build 7310 on Windows 10 Pro.
I have TortoiseGit and TortoiseSVN installed. Both work fine in the Windows File Browser. In Opus both used to work fine, now TortoiseGit disappeared, i.e. the context menu entries are not there and the shell overlays are not there either.

Preferences / Miscellaneous / Advanced [Troubleshooting]: ignore_context_menus is empty, so no crash there.

On the Windows File Browser the overlay icons disappeared when installing DropBox. After deleting the DropBox entries in regedit from [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ShellIconOverlayIdentifiers] and restarting the explorer process the overlays came back in Explorer, but not in Opus. (The context menu never disappeared in Explorer).

Turning overlays to none and back to default did not fix it.

Finally here are my overlay settings:

Any other suggestions to fix this?

You have this setting turned on:


Indeed! [v] Show overlays and context menu only in explorer was the culprit.
However, somewhat counter intuitive. The description of the feature is that it turns it off in save as dialogs. Just for kicks I unchecked it and tested in Opus and it was still not working. So then I reverted it to what seemed to be a useful default.

Now after your post I unchecked it once more AND restarted Opus. That fixed it.

The Tortoise documentation is assuming that file browse dialogs are the only thing outside of Explorer that show context menus.