Hi guys,

I received a zipfile with 215.209 files in it. I wanted to extract these files and tried this with DO. I went into the zipfile (fine); selected all files (fine) and started the process with Copy files. After 2 hours(!) still no files were extracted and I had to kill the process (seems to be hanging). I tried the same with TotalCommander and that did the trick: started copying the files after 2 seconds(!).

Unfortunatly I can't send you the zipfile: it consists of consumerinformation that I may not share with you,

Any idea what goes wrong? Thanks in advance!

Do you get similar results if you right-click the zip file and choose Extract to "ZipName"?

Would it be possible to generate some manual process dumps while the delay/freeze is happening, so we can take a look at which part of the code it's happening in? That might be enough for us to work out what's going wrong without an archive to repro the problem. Here's how to make the dumps: Crash dumps for bug reports

Hi Leo,

There is no dump (DO didn't crash; it just seemed to hang) and with the right-click I get the same result... already waiting for 10 minutes...

You can manually create dumps during lengthy operations or freezes. See the 2nd part of the post I linked for details.

Hi Leo,

The dump is 650 MB (even with 7Z it is 82,4 MB). I sent it to you via WeTransfer.

Cheers, Rien.

Oh yes,

DO is still busy with "initialising ZIP Batch Copy...."

Many thanks!

The .dmp file shows this is an inefficiency in the library we are using for zip files when the number of files becomes huge.

That should be fixed in the future as we're planning to replace the library with a better one, although I can't say exactly when at the moment.

Hi Leo,

That would be great. Thank you! In the mean time I will do it with TC :confounded:

Hi Leo,

No progress with this issue? Thanks in advance,


Replacing the zip library is a longer term plan. Won't happen until a lot of other ongoing work is out of the way.

Hi Leo,

That's disappointing news. For me DO has become unusable. I have to look for an alternative browser which supports a large amount of files.

Strange, you do a lot a bugfixes (not always that useful in my opinion) and this terrible bug you don't fix?


It's an unusual performance issue, caused by the design of the zip library we use.

Replacing the zip library is not a small task, since it is tied in to a lot of different things that all need testing, and other libraries work slightly differently.

It's on our list to do, but it's not trivial, nor high priority unless more issues with it emerge.

Extracting with other tools can be done from Opus, too. e.g. 7-Zip or WinRAR via the right-click menus.

Hi Leo,

Still no solution for this issue?

Thanks in advance.