GP Software • Twitter
Opus FAQs • Manual • Commands • Objects

Userdata.omd permission error after upgrading to 12.10.2b


#1

after updating from 12.10.1b to 12.10.2b, restart the pc and launhing dopus shows the following warning dialog

Clipboard%20Image

this happens every time after dopus launched for first time.


#2

If you open that file using notepad.exe, add a blank line to the end and save it, does that work?


#3

as per the enclosed image that file already has a blank line

but I still added another blank line and the behavior is same.


#4

The blank line is just a test.

Are you able to successfully save the change to that file? If you close and re-open the file, is your change still there, or is the file back to how it was?

The error message Opus is displaying indicates that something is blocking it from updating that file. That could be incorrect permissions applied to the file or folder it is in (sometimes to the whole user profile area where your settings are stored). It could also be something like an antivirus tool blocking the file from being updated for some reason, or another program preventing Opus from updating its config files because it has locked them for some reason.


#5

I'm experiencing the same problem after 12.11 update. Double checked userdata.omd permissions - looks ok. Tried to add a lane, save, then delete this lane and save again - no problem, I have full access to edit this file. However this error window appears everytime I start Windows. If you'll find a working solution, please post it here. Thank you, Igor


#6

It's possible something on your system is blocking Opus from modifying the files, if you're able to edit them OK in a text editor.

(Assuming nothing weird, like running Opus or the text editor under different accounts, or elevated with UAC.)

Usual suspects would be antivirus and similar 'security' programs.

If needed, generating a Process Monitor log file may reveal the type of problem:


#7

Thanks for the info, Leo. I just send a procmon logfile to crashdumps@gpsoft.com.au
I hope it helps! Thanks!


#8

Please check if there is a userdata.omd.tmp file in the same place as userdata.omd. If there is, delete that and see if the problem remains.

If the problem is still there, it looks like it may be being caused by Windows Defender for some reason, as it seems to be locking the tempfile. Adding that config directory to the Windows Defender exclusions list may fix things, and should be safe as it doesn't contain executable files. Failing that, changing antivirus may be recommended, as Defender is pretty terrible these days, sadly.


#9

There is no userdata.omd.tmp file unfortunately. I added whole GPSoftware folder in %APPDATA% to exceptions in Windows Defender's settings, but it didn't help. Today I also updated my laptop to the latest Dopus version and there is same problem there. If you need any logs from my laptop just let me know, but I think it will be roughly the same.


#10

Tried to turn off Windows Defender in Group Policy Editor, restarted PC - same error again, so I'm not sure Windows Defender is causing this. I will try to investigate further, but if you have any other recommendations I would be glad to hear them :slight_smile: Thank you!


#11

Sadly i'm having the same issue. Added the config folder to the exclusion list, same issue persists. It seems that another process however is blocking the file. Have not found out which one though as of yet.


#12

Please send us a procmon log if you can.


#13

logfile.zip (25.9 MB)

Absolutely can, hope it will help.


#14

It looks like Opus was already running before the Process Monitor log began, so the log doesn't have any record of Opus trying to read or write to userdata.omd.

Please run Process Monitor and start it logging before launching Opus, so it is logging when the error occurs.

(If needed, use File > Exit Directory Opus to close Opus, then you can restart it again while ProcMon is logging.)


#15

Oh geez, sorry, that was dumb of me. Hope this one helps: Logfile.zip (18.4 MB)

Oh as an additional info that i haven't shared yet, this issue started occuring since updating from 12.10 to:

Directory Opus Pro 12.11 Build 6927 x64
OS 10.0 (B:17763 P:2 T:1) SP 0.0

Haven't had it before.


#16

12.10 ignored the error, while we changed 12.11 to show a message box so you know something is wrong and needs fixing. The problem was still there before, it just would have been more subtle, like the release notes appearing on every reboot because Opus couldn't record that it had shown them for the new version.


#17

Thank you for further investigation of this issue. It's little bit strange though, because there is almost clean Win10 Pro install on my laptop and same error appears there. Probably Microsoft did something with one of the latest updates? Unfortunately I don't know how can I see, which app is blocking userdata.omd :frowning:

Thanks anyway, Igor!

PS I've reached the limit of the replies (I can post only 3 of them due I'm a new user), so I post it here as edited post.
"I also have Enpass UWP installed. Latest 12.1.1 Beta fixed this issue! Thank you"


#18

Hello
I'm having the same problem as well after updateing to 12.11 on Win10 yesterday.


#19

Please send us a procmon log if you can.


#20

Logfile.zip (586.8 KB)

Same issue here. Attached procmon log.