Video thumbnails in Directory Opus

Have spent quite some time on trying to solve the issue that I am encountering with regards to video thumbnails (mp4, flv, etc)

They show up like below

Changed codecs, from one codec pack to another and back again, did some 'recommended' registry settings, cleared thumbnails, reboots, searching on Internet, you name it.
Then, by mere coincidence I tried std WIndows Explorer and thumbnails were re-built.

So in Windows Explorer they all show up now, but in Directory Opus they still are like above, even after refreshing,
closing DO, relaunching.

Any suggestions ?
Frankly, am puzzled as to why the thumbnails were not being rebuilt by DO?
(it would have saved me a lot of time. to be honest, if I did not stumble over the rebuilding by Windows Explorer
I might still be searching for a solution)

Windows 7 64bit
DO 64bit


If you configure the Movie plugin and tell it not to generate thumbnails, Opus will ask Windows to generate them instead (at least if you clear the cache afterwards as well), so you'll see the same as in Windows Explorer.


That helped a lot, most of the thumbnails are now shown.

Quite some still not though, a number of mp4 are not displayed.
I did this movie plugin-thing, then a disk clean - thumbnails removal - reboot.

Below some examples of DO display vs Explorer.

Any suggestions?

FWIW: Codec Shark007 is installed.
(Don't know whether this has something to do with it..)

Thanks again.

The Windows Disk Clean-Up tool won't clear the Opus thumbnails cache. Use the Opus Preferences window for that.

I gave up long time ago trying to get all thumbnails to work. I had many missing .avi, .flv and a few .mpeg and .mkv thumbnails missing. Everything I did, I couldn't get it to work (In Dopus and Explorer, even though WMP played the files). Seeing this post, I decided to tackle this problem again. Read and tried all kinds of suggestions from many different sites (most didn't work).

I gave up and tried K-Lite 64bit codec pack (as a few suggested)(I hate codec packs but wanted to see if it would work and if so, what did it use). The 64bit version has an option during install to pick what thumbnails it will render. I Selected all and now 99.9% of thumbnails are working! Just a few random ones are not.

Turns out, it just using Codec Tweak Tool to do this thumbnail option. No need to install the codec pack. Just use Codec Tweak Tool -> Thumbnail Settings.

Another tool which could be helpful is Win7DSFilterTweaker. This can set which decoders are preferred so Windows will stop using it's own to try and generate a thumbnail. Installed along with Haali and/or LAV media splitters and FFDShow should be all you need.

Good Luck! I'm happy now that I got thumbs to work. The .1% that are not working, I'm just going to convert to mp4 and be done with it :slight_smile:

Hello again,
@Leo: Many thanks again! Yes, this did it! Great...!

@ktbcrash: well, about the codecs, I used to work with CCCP which is a straightforward thing and sofar always worked.
Not viewing the video thumbnails made me checking out other packs and it seems Shark007 is a good. I saw this Win7DSFilter thing as well.
Shark007 for 64bit is 27+16 = 43mb in total (CCCP is just 9,8mb) including MPC ... Maybe I go back to CCCP again.

Anyway, we should avoid getting into details about codecs here. As said, it is off-topic.

My 'problem' is solved though.

tks again!

By the way...

Just out of curiosity, is it not possible to keep these thumbnails in cache, or database (controled by Directory Opus I mean).
When scrolling thru the thumbnails, once the page is full and I go to the next page, the thumbnails are rebuilt, row by row.
With diskactivity.
(in DO, with me, preferences/thumbnails/cache thumbnails: cache is empty - Movie Plugin 'Generate thumbnails' is not tagged)

I am also using a program named Media Center. The thumbnails are all there, even if I go very fast thru all the pages / thumbnails
there is not split second of the delay:it is keeping it in its own database. Isn't there something similar to that within Directory Opus?

In case of too many thumbnails, Directory Opus crashes. :cry:

If the thumbnails come from the Windows shell (which they do in this case as the Opus Movie plugin's thumbnails have been disabled) then Opus doesn't cache them because the Windows shell should be caching them itself.

Turn on the option to generate all thumbnails in the current folder if you don't want the slight thumbnail delay when paging through folders.

Too many thumbnails would not cause Opus to crash. You most likely have some file that is causing some thumbnailer (possibly part of Opus, but more likely part of something else that installed a shell extension or video codec) to crash. See the FAQs about that.

Sure, I understand that Opus isn't caching it: I have the generate thumbnails untagged.
When tagged, I have black thumbnails.

Generate all thumbnails in the current folder : is this different from the above.
Tried to find answers on the resource.dopus site and in the FAQ - likely I am overlooking them.
Can see a lot has been written about this subject, though.

As for crashing, well, I don't know, but today DO crashed about 4-5 times in the process of
displaying thumbnails. Halfway it gets slower and slower and then stops generating the
thumbnails. It freezes and then crashes.

A further note:
So I had the movie plugin disabled and emptied the cache.
DO showed the video thumbnails alright.
Then whilst trying out options, I enabled the movie plug-in thumbnails again.
Result: thumbnails black.
Then I untagged the movie plug-in thumbnails again.
Thumbnails gone.
They all show the same 'standard' thumbnails.
Even after closing and launching DO a few times.


Oh, I forgot to say - Issue solved after rebooting PC

Turns out, it just using Codec Tweak Tool to do this thumbnail option. No need to install the codec pack. Just use Codec Tweak Tool -> Thumbnail Settings.[/quote]

Sorry to bring back an old thread. I left out some critical info.

When I switched to Windows 8, and just now needed thumbnails, I noticed I was missing a ton again. Forgetting what I did before, I remembered that I posted about this before. Trying the above tool (Codec Tweak Tool), did not work on it's own. In fact, Codec Tweak Tool's Thumbnail option isn't even clickable. I must of had something left over from the k-lite codec pack.

Turns out you still need to install Icaros. Install and activate Icaros (You need to Deactivate to change settings). What I really love about Icaros is that you can pick a percentage (default 25%) spot where the thumbnail gets pulled from within the movie file (1 hour movie gets it's thumbnail from around the 15 minute mark when set to 25%). I've only ran into a few .mpg's that are showing black frames (or frame 1. even when Dopus's Movie plugin is set to generate thumbnails and skip black frames).

Now you can run Codec Tweak Tool -> Thumbnails. Select All and Save.

If you want to use Dopus's Caching, then go to Preferences -> Viewer -> Viewer Plugins. Select Movie -> Configure. Make sure "Generate Thumbnails" is checked and "Skip over initial black frames" is UNchecked (I'm guessing it might interfere with the 25% Icaros setting if left checked).

If you want Windows to handle the video thumbnail caching, then UNcheck "Generate Thumbnails" in the above Movie plugin.

At first, I didn't think Dopus's would use this Icaros to help with the thumbnails, but it looks like it does from my testing. Is that because Icaros is a Windows Shell Extension?

Anyway, hope this helps.

This doesn't work 100%. With more testing, some video files still go to Windows Thumbnail cache, while others go to Opus. I get the best results by turning off the Opus Movie plugin and just let Windows cache what Icaros produces. It's almost as if the ones Opus couldn't get, it then let Windows/Icaros try.

That's exactly what happens. :slight_smile:

Both Opus and Windows depend on which video splitters and codecs you have installed, and the quality & compatibility of them for the files you're generating thumbnails for.

The FAQ about this stuff has suggestions on the codecs I use (64-bit FFDShow plus a few splitters from Media Player Classic Home Cinema work best for me).

Ahh :slight_smile:

Thanks for the clarification and tips.