View STL or .OBJ files in the preview pane


is there a way to preview 3d .STL or .OBJ files in the preview pane ?

Thank you

If there is a preview handler (works in Opus, File Explorer/Windows Explorer, and Outlook) or an ActiveX control (works in Opus and Internet Explorer) for the formats then it should work in the Opus viewer pane.

Otherwise, probably not, unless someone makes either of those things, or an Opus-specific viewer plugin.

(QuickViewPlus is a preview handler which can display a large number of formats, but I can't see .STL or .OBJ in its list of supported formats, unless they are under a descriptive name rather than the extensions, which some formats seem to be in the list. Most other preview handlers only handle a single format.)

(There may be preview handlers I don't know about, including shipped with related software for editing .STL and .OBJ files, so it is worth looking and checking with the software vendors.)

Right now I'm using this free program

It would be great if I could make it preview automatically in DOPUS instead of having to click open every file

Can this QuickpreviewPlus be confgured to preview in Dopus Pane ?

I don't know anything about Microsoft's 3D Builder, sorry.

If it installs something that lets File Explorer preview its files, then the same should work in Opus. Otherwise, you'd have to ask Microsoft. (And ask them why they aren't implementing their own preview handler API for their own file formats. ;))


you will see the 3D model in both thumbnail lister view and the preview panel

STL and OBJ viewer support is coming, for people using Windows 10:

this is not working after reinstalling opus .use to show the stl in viewer pane now only shows icon.

Does it work in File Explorer's viewer pane?

The SDL/OBJ viewer is not part of Opus. It's just something Opus can use.

Hey leo, well this is what happened. I cloned an SSD drive . I stalled it and it would not preview an STL file. So I then reset my entire OC back to factory because your post said it's an explorer thing.
Well when it was all do e and all updated to recent windows 10 still no view of my 3d files. Just the icon shows up. So I put back old SSD and it works.
Well now it stopped working. I don't know what's going g on . So now I'm reinstalling g windows all over again. This is so frustrating. So basically in starting from scratch.
I'm really upset that this program has had me racking my head the last 3 days. Hours and hours
Of troubleshooting with no resolve. All I can find is does it open In explorer. And yes it does. So why is it not in opus. please please Please help me fix this
I'm losing my mind because this has me so pissed off.Thanks ahead of any help. I just can't believe 12.32 worked and now it doesn't. I'm just dumbfounded to what to do next.
Thanks again Troy cola

Are you sure you didn't install something to view those files on the old OS? Either 3D Object Viewer or the viewer that's part of PowerToys?

AFAIK there's no STL/OBJ preview handler built into Windows.

No just opus. But I did install power toys to try and get it 5o work and it didn't help

Is the viewer you have in Explorer interactive or just a static thumbnail?

I'm reseting the PC back to factory. I hope it works this time. Because it didn't the first time.

To answer static icon

I did notice that when it was working with the old SSD drive that when I clicked on the icon the 3D image popped up and it said 3D view now all it says is icon the word itself says icon and it shows just an icon of my cura software that would open the program I then installed power toys and 3D viewer both try them both and it still didn't make opus use it or see the 3D thing it just kept coming up icon

Make sure Preferences / Viewer / Viewer Pane / Display shell thumbnails is on.

Maybe Display shell icons as well.

It's also possible the text viewer is handling them if they're just text files (depends on how they were saved). (Just saw the parallel reply. Can't be that if you're seeing an icon.)

Okay I'll double check that once I reinstall Windows but yeah I went into all the options man I spent hours checking and unchecking boxes and doing exactly what you said make sure the thumbnail views on and all that stuff but no they're STL files they're all STL files and they all came up before beautifully when I first bought opus and installed it it worked right off the bed I didn't have to do anything I just installed it and it showed them that's in fact why I bought opus because that's what people were saying so I don't know what happened but that was 12.32 version and every time I try to download the . 32 version it keeps giving me the 12.33 version so I can't even try to install an older version to see if that would work because on your site it's just the latest version I go to old ones and it drops down to 11 or something I can't remember now I'm so flustered because I tried everything

Will do I'll try that again thank you for your help I don't know it's 10:00 p.m. here in America I think you're from Austria if I read correctly so I have no idea what time it is there I hopefully I'm not keeping you up or anything but it's resetting the PC it's only a 8% so this is going to probably take all night so I will probably get back to you tomorrow and if I do get it to work I will definitely let you know again thanks for your help and I hope I can figure this out cuz I'm just at my wit's end thanks again Leo

Omg. It works. I just found a 12.32 very. And it works again

Which viewer does it say it's using? 12.32 -> 12.33 shouldn't have changed anything here AFAIK. I can try with the same viewer to check.

I have the 12.32, but it asked to update to 12.33 and I did and it is working. So I think that when I set my windows the first time I used the window that was already on my computer last night I reset my Windows computer but I downloaded a copy of the windows off the cloud so it was a brand new version of Windows so whatever was in my windows that was already on my computer obviously was a mess up so now that I got the new copy of windows installed with 12.33 but first I installed 12.32 and then it asked for the update I updated it and it still working I have no idea what happened or why it was doing that other than like I just said the windows that was already on my computer when I reset was corrupted. Thank you so much for your help there is other questions but I got to come across them like one is when I do a search box to search for a file and then I hit the back button on my browser it goes back to the folder and I lose all the search that I just recently searched