Viewer Behaviour - Only every other file can be viewed

I am experiencing strange behaviour using the viewer pane. I have installed X1 which uses the Stellent Filters and Opus picks up the location of those files to use for the MultiView Plugin ... no problem there.

But, when I click on the Show/Hide Viewer Pane and then select a file to view, only every other file will display in the viewer pane. So, if I have a list of say MS Word documents, I click on the first file in the list and I can view the document in the viewer pane, fine. Then I click on the second document in the list and the viewer pane is blank. Going down the list, the 3rd, 5th, 7th ... etc docs view OK and 2nd, 4th, 6th, etc. is blank in viewer pane. This is same if the list of docs is Excel workbooks, PDF files, PowerPoint docs.

This behaviour does not occur with JPG files.

I have my Plugin Preferences set with only the MultiView plugin enabled. All other plugins are disabled.

So, I changed my preferences to enable ActiveX Docs, PDF-Text, and PDF-ActiveX enabled. All others disabled. So, now the viewer at least displays every file, but Word, Excel, PDF docs take much longer to load and in the case of Word, Powerpoint, and Excel docs, it actually opens the ability to edit the document directly in the viewer ... which is way more function than I want in the viewer pane. I only want to quickly load a viewer so I can see the content ... don't want to edit in the viewer pane. So, I turn off the active X options, and the behaviour changes back to where only every file is displayed in the viewer.

Can you help to correct this flaw?


Steve B.

I'm no expert here, but there might be an issue with the version of the Stellant drivers you are using. Could you try something out to prove or disprove this?

Try downloading the Yahoo! Desktop Search (which also includes the Stellant drivers). Then in Opus, configure the Multiviewer to look for the YDS copy of the Stellant drivers. See if you can reproduce the same results with YDS copy of the Stellant. If you see the same results with both copies of the Stellant drivers, there is another issue here.

See this discussion thread here for how others have gotten the YDS-provided Stellant drivers to work with Opus. I also use the ones from YDS, and they work very well for me.

Thx for your reply.

Well, I did as you suggested and the Yahoo Desktop Search Stellant filters work just fine. So, I went back to X1 and the behaviour for Opus was as I described before.

Now, here is the curious thing. Yahoo Desktop Search is developed by X1 so one would expect that they perform the same .. and they do. I looked at both tools and they basically perform the same, with a couple of differences, they key one (for me) is that X1 includes the ability to index Lotus Notes where YDS does not ... and that is an important factor for me.

The directory structure of the actual program files and the Stellant filters is very similar and I am at a loss to understand why Opus file viewer will behave correctly when using YDS and it reverts to the strange behaviour when using X1.

Would you be willing to perform an experiment on your end ... install X1 desktop search and see if you get the same results that I do. You can get the free download of X1 here

I believe you will have to uninstall Yahoo Desktop Search first as I was prompted to uninstall X1 before installing YDS. I expect the two are tied together.

Steve B.

I actually no longer had YDS installed, I just kept the Filters subfolder, so no conflicts there.

[RANT]Well, I installed X1, I was immediately reminded why I do not like desktop search engines (regardless of who makes them). It's also a damned good thing I chose Custom Install mode or Yahoo! would've taken over my machine. What a Resource hog! It doesn't ask: if I wanted to index right away, or what I want to index, it just assumed "yes" and "everything". This is incredibly irresponsible programming, not to mention a huge security risk. I had to quickly find a way to kill the damned indexing, which hogged so many resources that the program GUI lagged at each click I made. I finally got the indexing killed when it was about 38% complete.[/RANT]

There seems to be a couple more drivers in this folder than in the YDS one. I opened the Opus Synchronize Utility to perform a Date, Size, and Byte comparison on the two folders, by all comparisons the X1 copy of Stellent is newer (v8.1.0.4044) than YDS (v8.0.0.3706).

The thing is both the X1 and YDS copies of Stellent are working fine for me. I simply viewed some Excel files, then some Word files, and some .zip files. All worked fine.

Perhaps you might consider uninstalling X1 and re-installing it?

Also. If you can recreate this. We need to know what file type is causing the issue and what steps you are going through to trigger the issue.

Aha! I can reproduce the symptoms now. And, yes, the issue only occurs with the X1 version of the Stellent viewers.

The key trigger was that you disabled all other Opus Viewer Plug-ins. Once I did this, I was able to recreate the every other file with both Excel and PDF files then. With other Viewer plug-ins enabled, the file was still getting displayed on my configuration (only by a different plug-in). This behavior becomes easier to see when adding a simple viewer plug-in back into the mix.

Folder Full Of: Excel files
Multiviewer Plug-in: Enabled, v8.1.0.4044 Stellent drivers (from X1)
Only Other Plug-ins Enabled: Text
Results by focused file--the file with the "unmarching ants" focus rectangle on it:[ol][li] Displayed correctly in Multiviewer Plug-in[/li]
[li] Viewed as Hex in Text Viewer[/li]
[li] Displayed correctly in Multiviewer Plug-in[/li]
[li] Viewed as Hex in Text Viewer[/li]
[li] ...[/li][/ol]

NOTE: Focused File #1 is not the first file at the top of the list, it is the first file that is focused on. If a file was selected half-way down the list prior to opening the Viewer Pane, that would be Focused File #1.

NOTE: Opus caches .pdf files in the %Temp% folder. So when trying to recreate this issue, Close the viewer pane, clear the %Temp% folder of all previously cached files, then open the Viewer Pane. Otherwise any previously cached files will be used, giving the illusion that the issue is not present.

I'm reporting the issue to GPSoftware right now. But I should point out that you can workaround the issue if you have three or more files of the same type (or that use the Multiviewer) in the same folder.

It is every other-file focused file that is being displayed incorrectly. Not every other file in the list (as sorted).

So if you had these files[ul][li] Excel 1.xls[/li]
[li] Excel 2.xls[/li]
[li] Excel 3.xls[/li][/ul]Focus on on Excel 1.xls to view it. Then if you want to view Excel 2.xls. Then switch focus (with the mouse) to Excel3.xls (which will not display correctly), then switch to Excel 2.xls (which will display correctly).

Yes, you are correct about the 1st focus file then every other file, etc. So, we are able to get the same results using X1's Stellant vs YDS's filters.

Maybe, the workaround for me is to get YDS filters and retain them in seperate directory for Opus' use and use X1 filters for X1 only stuff.

I found the same as you about X1 taking off and doing its indexing, but there are customizing features to enable less intrusive indexing, location of the indes files, etc. I found that after the initial indexing is complete, that it is not quite the resource hog that you found on your PC. Maybe it is just me, but I have not found that either X1 or YDS is particularly intrusive, but I expect that it certainly can be depending on your configuration.

Steve B.

I am having the very same problem and would appreciate it if this gets fixed.

I use X1 all the time and would like BOTH programs to work together.


I can't say this is a true fix, but it is a work around ...

Uninstall X1. During the uninstall of X1, you should be prompted if you want to retain the setting for future re-install ... say yes. If you say no, you will have to rebuild your indeces, which as you know, can take a while. Reboot, and then install Yahoo Desktop Search. Download YDS at Install the extra file support as well.

After you have installed Yahoo Desktop Search, copy the Stellant\Filters directory created by Yahoo to a seperate folder. You will find these under C:\Program Files\xxxxx where xxxx is the name of the directory created when you install YDS. I created a folder C:\Program Files\GPSoftware\Directory Opus\Stellent\Filters

Now uninstall Yahoo Desktop Search and reinstall X1. Your old X1 settings and index should have been retained.

Now go into DOPUS and click Settings, Preferences. Select "Plugins" on the left pane, and check-mark MultiView in the right pane. With MultiView highlighted, click "Configure" and then make sure the Stellent filters are correctly identified for Viewer Libraries ... use the the Locate button to navigate to the filters that you copied from YDS above. Click OK and close the window.

I found that using YDS search Stellant filters work fine whereas the X1 Stellant filters cause the condition noted in the prior posts. I don't have a clue why this is, and as this workaround does what I want, I haven't worried about exploring the reasons. In this way, you get the filter needed for DOPUS to work correctly and are able to continue to X1 as your desktop search engine.

Steve B.

Thanks for the tip, Bisel - this works for me! Note to others: no viewer version above 8.1.x.xxxx works, but that those below do (YDS viewers are, X1 are and the latest QuickView Plus 9 viewers are - X1 and QVP viewers exhibit same problem).