GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Viewer couldn't show the video thumbnail

As you can see, i want to use the viewer to see the video thumbnail, but some video it's worked the others couldn't show it , please solve the problem.%E6%89%B9%E6%B3%A8%202019-11-28%20184340

Do you see thumbnails for the same files in File Explorer?

yes, and sometimes in DO manager, it will consumes a lot of CPU resources, so i delete that video.

It isn't Opus itself that extracts video thumbnails (or plays video files, if the viewer is configured to play them). That's done by the video codecs/splitters installed on the system (or the viewer component configured for viewing videos).

If you use thumbnails mode instead of the viewer pane, does that work OK?

In File Explorer, did you try the viewer pane there, and/or thumbnails mode, on the same file?

Can you translate the word in brackets after the filename in your screenshot? That tells us which plugin or component is trying to view the file in the viewer pane.

you see it lot of consumes CPU resources, and use thumbnails mode is ok, just use viewer pane will have the problem, the word in brackets after the filename means landing.

It's not Opus itself doing that; it's whichever component is on the system that handles that type of video file. It is loaded inside the Opus process, but is a DLL from something else.

If you can answer my other questions above, that makes it easier to tell you which component might be involved.

Ok, Q1: yes Q2:yes, and use thumbnails mode is ok, just use viewer pane will have the problem;
Q3: if you say 加载中, it means "loading", i write a wrong word. and i can't show you English because in my DO don't have English option %E6%89%B9%E6%B3%A8%202019-11-28%20202600

Others video in viewer pane shows shell thumbnails

Under Preferences / Viewer / Viewer Pane, try turning off the Movie plugin. (It will still try to play the movies via a different plugin.)

I do it, but still have this probelm.

If you also disable the ActiveX + Preview + Office + Web plugin, do you still get the problem?

(Don't leave that disabled, it's just to test what happens. If the problem goes away with both disabled, there are some more things we can do to avoid turning off the whole plugin.)

Ok, i do it, but no use, still have the problem

If both plugins are turned off, and you also turn off these two options, do you still see the problem even then?

  • Preferences / Viewer / Viewer Pane:
    • Display shell thumbnails
    • Display shell icons

I do as you said, and the thumbnails will not show in viwer pane, it shows some number

Turn on one option again, then try turning that off and turn on the other option instead.

Which one causes the problem? Or do both of them?

I would not expect those options to cause a problem unless the same file also has issues in File Explorer's thumbnails mode or viewer, since both cause Opus to ask the Windows shell for the thumbnails. (Do you actually see the thumbnails for those files in File Explorer, or are they blank?)

Ok.when i turn off both of the two option, thumbnails will not show, just show some number;
and when i turn on the Display shell thumbnails, turn off Display shell icons, still have the problem,
when i turn on the Display shell icons, turn off the Display shell thumbnails, others video show the shell icons, this video is still have problem that viwer show nothing;
and i actually see the thumbnails for those files in File Explorer, it's not blank;
and when i colse the DO manager, i can't turn on it, must kill it in Task manager that i can open it,
it seems like some bug.

That tells us the shell* is getting stuck when we ask it for the video's thumbnail. (*Or something that the shell is asking, in turn. e.g. It could be a video splitter/codec that the shell depends on for the type of video data or container.)

I'm not sure why it would work in File Explorer but not in Opus, since it's basically the same mechanism being used in each (in this situation).

You could try generating a process dump and sending it to us. See Manually generated logs in Crash logs for bug reports for how to do that. Make the logs while the freeze is happening.

Based on that we might be able to see where things are stuck, or at least what is stuck. It might identify the splitter/codec that's causing problems, which may just need updating. Or maybe Opus is doing something wrong. The log will tell us.

Ok, i send the email to you, named Dump File, please check the mailbox, thank you very much!

Would it be possible to send us that MP4 file (or any other) which triggers the problem?

I think I can see what's going wrong, but I'd like to test my theory.

Ok,but it's a lagre video, it's about 6.4 GB, i don't know how to send to you.