GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Volume in Viewer Pane: Always 100%

Hello,

When I have the Viewer Pane open and I select a video file the default volume is always 100%. How can I set this lower? I image this might apply to audio files also, but I haven't tried.

Thanks,
Mark

Which viewer are you using to play the files?

It should say in brackets next to the filename, above the viewer. Make it wider if needed.

Hello Leo,

It shows the file name and next to it is "(Windows Media Player)".

Regards,
Mark

I don't think that viewer will remember its volume settings.

The Opus Movie plugin will, on the other hand. If it isn't being used in preference, the Movie plugin may be disabled, or it may be unable to play the files due to missing codecs/splitters.

Assuming you are using 64-bit Windows, 64-bit codecs/splitters are needed by the Movie plugin. (OTOH, Windows Media Player is usually the 32-bit version, so it may be using different codecs/splitters, which often explains why it can play something that the Movie plugin cannot.)

1 Like

Hello Leo,

Okay, so I don't recall specifying a particular player, but I may have years ago and the setting have carried over since DO 9/10. I went to the Viewer | Plugins and noticed that the "Movie Viewer Plugin" didn't have the ".mp4" extension, so I added it, but the player is still Windows Media Player. Can you point me to a page that shows how to configure which player plays which file types?

Thanks,
Mark

Try the guide I linked in my reply above.

Mr. Leo,

Okay, I am trying to understand the guide. First, at the very top the instructions state:

"Opus should be able to play MPEG & AVI (via the Movie plugin in viewer panes), MP3 & WAV (via the File -> File Commands -> Play Sounds built-in music player) out of the box. (Some AVI files will require an additional codec such as FFDShow. See the sections below for how to get it.)"

Are you referring to Windows Explorer or Directory Opus menu structure? Neither of this programs have "File -> File Commands -> Play Sounds built-in music player". Also, if I search for "File Commands" in the preferences dialog box there isn't an option for this.

Please correct me if I am wrong, but it seems that DO will use the registered application for the player in the Viewer Pane, is that correct? I don't want to change the registered program, I want DO to use a player of my choosing.

In the guide, it also states:

"If you don't want to change any registry settings then you can instead open an Opus window and go to Preferences / Viewer / Plugins, configure the Movie plugin and add any missing extensions to its list. Of course, this will only make the formats work in Opus."

So, if I go to Preferences -> Viewer -> Plugins -> Movie -> Recognized I have the following extensions

".asf,.asx,.avi,.div,.divx,.dvr-ms,.flv,.m1v,.m2v,.mkv,.mlv,.mov,.mp2v,.mpg,.mpeg,.mpe,.mpv2,.wm,.wmv,.wtv,.mp4"

Though, it is unclear if DO will use the built-in player or the registered player. I think the DO player since it states "Movie Viewer Plugin", though it isn't clear.

I really don't want to change the registered player for the file type (which is VLC), but I want DO to use a player that I specify.

One other item, in the guide it states:

"Windows Vista/7/8: Go to Control Panel -> Programs -> Default Programs and assign things to Windows Media Player there."

For Windows 7, do you mean Control Panel Default Programs given there is no "Programs" category/option other than "Programs and Features", at least on my WIndows 7 64-bit install.

Regards,
Mark

You can't use any player for the viewer, unless you write some kind of plugin. By default, the viewer is hooked to either the windows media player or to the movie plugin. You can choose between them on Opus preferences, by enabling/disabling one or the other for selected extensions.

Perhaps Leo can correct me and based upon what Mr. Andersonnunes stated I believe that I do have the "movie plugin" configured based upon the following:

Preferences -> Viewer -> Plugins -> Movie -> Recognized I have the following extensions

".asf,.asx,.avi,.div,.divx,.dvr-ms,.flv,.m1v,.m2v,.mkv,.mlv,.mov,.mp2v,.mpg,.mpeg,.mpe,.mpv2,.wm,.wmv,.wtv,.mp4"

I think what you need to do now is remove these extensions from "Plugins, ActiveX, Configure, Generic ActiveX". That way they will be handled by the movie plugin, not by Windows Media Player.

Mr. Andersonnunes, thanks, so once I removed ".mp4" from Generic ActiveX 32-bit the Windows Media Player is not used. Unfortunately, for me, now all that is shown is a "Shell Thumbnail"

This is what Movie Plugin Settings looks like

At least it is a step in the right direction.

Thanks,
Mark

You don't need to (and generally shouldn't) remove extensions from the ActiveX plugin. It is lower down the list and will only be considered if the Movie plugin fails to display the files. If you remove the extensions from it, you lose that second chance to get a working viewer.

The guide I linked to has suggestions on how to make the Movie plugin work with various file formats if it isn't working with them currently.

You don't have to make any permanent changes to associated video players, only temporary ones at most. The guide should explain this.

Unless I am missing something, then all you need now is to make sure that there is a 64-bit codec installed on your system that can handle these .mp4 files.

Mr. Andersonnunes, according to the guide that Mr. Leo referenced the following was stated:

Formats which should work "out of the box" (MPEG, MP4, MP3, AVI, WAV, WMA, WMV, MKV...)
"MP4 is supported out of the box by Windows 7 and above.

I have Windows 7 64-bit, so I must be missing something very obvious.

In case it was missed above:

Have you done everything in the section of the guide that you are quoting the start of?

  • Including assigning Windows Media Player as the default player to repair things?
  • You can change back to VLC afterwards.
  • Use the Open With dialog to put things back to VLC, as VLC has a history of breaking video filetypes for other software when taking over file types its own way.

So, I did have mp4 set to VLC, but I changed it to Windows Media Player as shown below, but DO is still using Windows Media Player.

Only basically to show that DO is using Windows Media Player

Is the Movie plugin enabled under Preferences / Viewer / Plugins?

Does it work with other formats, e.g. AVI?

Mr. Leo,

Here are the enable selections

When I preview an avi file it shows XVID Movie, is that the DO default movie player?

Regards,
Mark

That's the Opus Movie player playing the AVI file, yep. I can tell from the toolbar at the bottom of it.

So the Movie plugin is working, for AVI files, but not for MP4 files. That means a codec or splitter (64-bit) that it needs for MP4 files is not working correctly. The guide I linked has the best suggestions I have for that. You might need to install FFDShow (or similar) and an MP4 splitter, for example, if the built-in ones are not working or don't get repaired by assigning WMP to the MP4 type.

Video components can be difficult at times, unfortunately, but that's the best advice I have.