W8: Double-click on desktop not working?

I check DOpus icon (right click, properties, compatibility) and Privilege level "Run this program as an administrator" is not checked. If that can confirm that it's not running as admin.

A quick way to check that Opus is not running elevated is that you get a UAC prompt if you try to create a folder below C:\Program Files.

It might be worth installing Opus again over the top of itself (do not uninstall first, that's not needed and would remove your configuration; just install again over the top) and then reboot. (Rebooting is important.) That should ensure the EXEs and DLLs are all consistent with each other, which is needed for desktop double-click to work.

I could create folder in Program files, but when I want to delete it I got message that I need Admin permission to delete. So I believe it's OK. I'll try to install it again.

That sounds wrong, actually, unless you have the UAC slider set to its lowest level so that you never get UAC prompts. (The prompt when deleting sounds like the non-UAC prompt the recycle bin gives you, before it gives the actual UAC prompt if UAC prompts are enabled.)

If UAC prompts are enabled, and Opus is running normally, then you should get a UAC prompt (in addition to any other prompts) both when you create and when you delete a folder below Program Files.

You can use Process Explorer to see which processes are running elevated, if that is easier. It has an "Integrity" column you can turn on which will show "Medium" for normal processes and "High" (or "System", or nothing at all, depending on the process and the account's permissions) for elevated processes. Opus should always have Medium integrity.

I have UAC at lowest level. Checked with Process Explorer and dopus.exe is on medium integrity. But it helps installing again. Version (4645). Maybe it was beta?

it worked, without reboot, after i unapply the preference mentioned and applied again, ending in between all processes...

will let you know after a reboot what happens!



I have DO on a USB drive and when I double-click on the desktop on my Windows XP machine at work, nothing happens. It is setup to "Bring the last lister to the front". I do have a dual monitor setup if that matters. This is the first time I have been using DO on a USB, so it is not something that once was working and then stopped.

I have also checked the other possibilities identified on this topic but I could not find anything to correct.

Any help would be appreciated.

I'm sorry, I didn't realize this topic was Windows 8 and my problem is with WinXP.


just re-installed Windows 7 Ultimate completely. Downloaded latest DOpus. Doubleclick on desktop doesn't work. Any idea how can I get it working again? dropbox.com/s/5b6wdyc5twju3 ... k.jpg?dl=0

Looks like your dopusrt.exe is not running which is required for desktop double-click to work.

Go to Preferences / Launching Opus / From the Desktop. Make sure it's not disabled.

If it isn't disabled, try Disabling it. Click Apply. Enable it again. Click Apply.

I did exactly what you wrote but with no effect, unfortunately? Any other ideas? Please please, I love this DOpus feature the most and it doesn't work... :confused: :cry:

Help please!

Please link your account.


Thank you!

If you open Task Manager and go to the Processes tab, is dopusrt.exe running there? (Note: dopusrt.exe not dopus.exe)

Are you using anything that changes the Windows desktop at all? e.g. Widget tools, wallpaper tools (other than the built-in Windows wallpaper), Active Desktop type software, or "fences" or similar programs?

Make sure that Opus is not running as admin. If the main Opus process is elevated then then UAC would prevent the double-click message from reaching it. (Using the Admin Mode built into Opus is fine, but dopus.exe itself should not be launched elevated as that makes the entire program elevated instead of just the parts that need to be.)

dopusrt.exe is not running, see the screenshot: dl.dropboxusercontent.com/u/490828/dblclk.jpg

It's a newly installed Windows 7 x86. No customization software installed. Just the basic stuff like Catalyst, Chrome, etc.

It seems that DOpus is not running as admin. None of "Directory Opus" and "Directory Opus (Startup)" shortcuts are not running as admin.

However I am able to create folder in C: without an UAC prompt even though UAC is enabled...

What am I doing wrong?

Can you create folders in C:\Windows without a UAC prompt, or just C:? It's normal at the root of the drive. Check what happens in both Opus and Explorer.

Make sure Windows Defender and similar tools are not blocking dopusrt.exe from launching at startup.

If you open a Command Prompt and manually run the startup command, does the dopusrt.exe process start and remain running?

"C:\Program Files\GPSoftware\Directory Opus\dopusrt.exe" /dblclk

I tried to created folder in C:\Windows. First DOpus requester appeared, then 2 Windows requesters. I confirmed all of them.
Then I tried to manually start the dopusrt.exe and it run and remained.
Then I restarted Windows... and double click on desktop finally works! Strange activation process, but it works. Thanks!! Btw. I am big fan of this software since DOpus4 and then DOpus Magellan :slight_smile: Thanks again.

I would look at your antivirus and Windows Defender in that case (assuming it was not the first reboot you tried), since neither action should have changed what happens after a reboot.

Hello All,

I discovered that the Windows Defender was the cause of the desktop double click not working.

The fix was to create an exception for Directory Opus which stops Defender from finding it.

Start at Settings than select Update and Security. Under " Exclusions " create a exception for
dopusrt.com. Reboot and the double click should work. I has a problem so I set the exception
for C:\Program Files \ Directory Opus. That worked perfectly.

Hope this helps,