When synchronising folders why can't DOpus 'find specified file'?

I'm trying to synchronise two folders over a network. DOpus displays:-

I can scroll down to the file in the source window and even copy the file manually to the destination. Why can't Dopus copy it? N.B. There are many files that it says cannot be found.
Thanks in advance,

Is it a Windows NAS or something else?

What's the full path involved? Could you show a screenshot of the lister with the file in view?

A Process Monitor log might reveal what's causing the error: Process Monitor instructions

The files causing this error are on an internal SSD e.g. D:\Photos\2021\2021-01-January\P1010284.xmp
P1010285.xmp, P1010286.xmp etc. I aborted the synchronisation at this point.
The destination is mapped as Z: on my desktop PC (HP has been causing issues, everytime I tried to access files on it I was told I didn't have permission. Eventually this was solved by creating a local account just for network operations.)
The message implies that the source file can't be found, but as I said I can copy the files using DOpus???

PS I will try process monitor and provide screenshots, if the same error occurs next time I try to synchronise the PCs