Window Focus changes after deleting files

Sometimes (not all the time) the window focus changes to another window open when I delete a file. I'm trying to get more detail in regards to the circumstances under which this might occur. Are there any specific details of my installation that would be useful in diagnosing or repicating this?

Just now I was able to delete a few files, then switch into the dual-pane mode using my personal keyboard shortcut, then it switched windows after a delete. It seems to occur more with a "fresh" newly opened lister.

One time this was particularly annoying was when I was deleting a bunch of images using the preview window, and every time I deleted one, it would switch focus to another program.

Is this something others have noticed, or is it something to do with my specific configuration?

I notice this too, more at home than at work. I think it may happen more when controlled via the keyboard rather than the mouse but I'm not positive.


Hmm... well, I virtually always use the "Delete" key on the keyboard to delete stuff. If this happens chronically again during a big deleting session, I'll have to try using a mouse control and see if it makes a difference.

I used to get this sometimes (not always) during beta testing but could never find a way to reproduce it on demand.

The weird thing is, I haven't seen it happen in literally months. I don't know what I've changed to stop it happening but something solved it, for sure.

I have been facing this problem every now and again in the latest version ( Unicode, Win XP SP2): is anyone else still experiencing it? This quickly becomes infuriating when deleting a large number of files one at a time. It doesn't always happen, but I'm not sure what makes the difference.

Last time I observed this, I was force deleting (with Shift+Del on the keyboard) images selected one at a time (by mouse left-click) in thumbnails view in a single lister with only one tab. The number of select and delete operations permitted between activating the lister and focus being lost did not seem to be constant.

I used to get this all the time, as I'm just about always using shift+del to erase files. The thing that solved it for me, was to do the following:

  1. In a Dopus window, go to Help -> Keyboard Map
  2. Find the entry for Shift+ Delete
  3. Double-click it and change:
delete shift



This should pretty much do the same thing, except it doesn't cause the problems with Dopus loosing focus. Hope this helps :slight_smile:

Hello Dirhael ,

I'm totally unaware of this.
I've been attempting to reproduce this result for the last 20 minutes, but I have not been successful.
Can you reproduce the circumstances under which this happens ?
Does it have anything to do with the Preferences under Settings -> Miscellaneous -> Explorer Replacement ?

Good Find !


Thanks Dirhael. I have the "use recycle bin" and "Explorer replacement" preferences on, and intend to keep them on, so DELETE NORECYCLE (perhaps with FORCE) will certainly do what I wanted DELETE SHIFT to do. I'll keep it like this for a while and report back if it doesn't solve the focus problem. If the DELETE SHIFT behaviour is reproducible elsewhere, it is presumably still unintended and should be fixed in a subsequent version: do you know if the developers aware of the problem and workaround?

Zippo, what can you not reproduce: the problem of occasionally losing focus with DELETE SHIFT, or the solution of not losing focus with DELETE NORECYCLE?

Zippo, the thing is, I can't really reproduce now. Sometimes when I'm using Dopus without having changed those keyboard settings, it happens all the time using shift+del. Other times though, I'm not having any problem. The problem just comes and goes seemingly at random. After changing the settings to "delete NORECYCLE" (the force option isn't really needed to work around the problem) I haven't encountered it one single time though.

The thing that made me think of changing it was that the problem never happened when just using the del button on the keyboard, so I just figured it was worth a shot changing the setting. Seems like it was worth it :slight_smile:

sch29, I think I've seen a post here on this forum by a developer regarding this problem before, but I don't think they were able to pinpoint the problem, as it apparently is very hard to reproduce.

Thanks dirhael, I'll try that setting.

It's been a long time since I started this thread, but I guess the problem wasn't annoying me enough in recent months for me to want to check up on it.

Has any progress been made on this issue by the development team? Hopefully it'll be resolved in Version 9.