Windows 11 - DOpus 12.33 x64 - DbPowerAmp Context Menu

Right-click a supported audio file (e.g. Because.flac) shows the nested dbpoweramp menu, which contains "Convert To" and "Edit ID Tags" and other options.

Choosing "Convert To" opens the correct function, however the window opens behind the lister instead of in front of it.

Choosing "Edit ID Tags" rarely opens any dialog. Sometimes it works perfect, but 99% of the time nothing happens. Eventually a bunch of previously attempted openings will open all at once, behind the lister. Have not been able to identify a trigger for this.

This is a brand new laptop with very little on it - Office and some music utilities. All of these work together fine on my desktop. Biggest difference is desktop is running Windows 11 Pro, laptop is running Windows 11 Home.

Initially blamed this on dbpoweramp. Uninstalled, reinstalled, upgraded version, followed their support documentation on how to completely uninstall. No joy.

Tried all of the right-click functions using plain File Explorer and they all work exactly as expected. Un-oh!

I've purchased and downloaded the DOpus 13 upgrade but am holding up install until we get this figured out.

Any suggestions appreciated... (Thrilled to see an update after so many years!!!)


Device name Bob-XPS
Processor 13th Gen Intel(R) Core(TM) i9-13900H 2.60 GHz
Installed RAM 32.0 GB (31.7 GB usable)
Product ID ■■■■■■■■■■■■■■■■■■■■■■■
System type 64-bit operating system, x64-based processor
Pen and touch Touch support with 10 touch points
Edition Windows 11 Home
Version 22H2
Installed on ‎1/‎18/‎2024
OS build 22621.3007
Experience Windows Feature Experience Pack 1000.22681.1000.0

Directory Opus Pro 12.33 Build 8659 x64
OS 10.0 (B:22621 P:2 T:1) SP 0.0

If you already have Opus 13, it may be worth trying it first, as that could solve the issue by itself. We can now run a lot of context menus in a separate process, isolated from the rest of Opus, which sometimes helps with compatibility (as well as protecting our main process from shell extensions that crash).

For what it's worth, I've been using dBPowerAmp for a long time without issues, although I am still using quite an old version.

That said, if you want to stay on 12, or if you install 13 and see the same issue, we might be able to work out what's going on via some process snapshots.

Here are the instructions for making them: Manually generating process snapshots

Before making them, run the menu item a few times in a row. Until it's in a state like the one you described (new windows haven't appeared but seem to be building up). Then make a few snapshots via the method I linked to.

With those we might be able to see if there are a bunch of threads stuck waiting for something to happen, or similar. Although it will depend a lot on what's causing the delay and how the menu extension is implemented.

1 Like

Installing v13 solved the problem. dbpoweramp now works perfectly again. Agree it's a great tool for managing your music library, especially together with DOpus. Over 6,000 tracks in my 'production' collection. Couldn't do this without the two tools.

1 Like


which old version of dBPowerAmp are you using??

I've recently had issues [delays & freezing] within dopus caused from dbpoweramp v17. I've just uninstalled it for now. and switched to . which does all right. it also has video converting built in. but id still prefer dbpoweramp for converting flac. there's more options under the hood.


I'm on dBPowerAmp v16.

I've just purchased the update to the 2024 version. When I get a moment, I'll install it and see if I run into any issues.

1 Like

Let me if you remember. I have a v15 I might try.
I even sent a along a manual .dmp set to y'all that confirmed dbpoweramp was causing the 30+ second freezes. I had already uninstalled right after send the email.

No issues so far with dBPowerAmp 2024 and Opus 13.

Also, here's the command to put in a context menu if you want to de-clutter the menu but still see dBPowerAmp's items: