Windows 11 Issue with OneDrive icons in context menu

I have a small issue with DOPUS12
I just install W11 and latest version of DOPUS12 (12.25) and OneDrive share icon was disappeared form context menu.

I've read some posts on this forum and unfortunately I cannot solve this problem by my own, so I must ask for help.
Here is what I've done:

  1. DOPUS not running as Admin
  2. Prefrences -> Misc -> Windows Integration -> uncheck "Hide windows options..."
  3. reinstall OneDrive
  4. Prefrences -> Misc -> Advanced -> Ignore_context_menus is empty

Is there something i can do? or must wait for any W11 integration?
Thank you for any tip or help.
Best wishes


Most likely Microsoft re-wrote OneDrive yet again in Windows 11, broke compatibility with other things, and nobody reported it to them during the beta (or they ignored the reports), so it wasn't fixed before release.

We'll add it to our list to look at and see if we can find a workaround. I'd advise against jumping on Windows 11 this early unless you have a compelling reason to.

Edit: Thinking about it, they've probably dropped the old OneDrive context menu entirely and replaced it with the one that works with File Explorer's new context menu type. (The one that hides most items and takes several seconds to display a menu despite the menu being simplified. It's a trainwreck, this OS update.) We may need to add support for that style of menu item (if it's possible outside of File Explorer; they've done things in the past that wouldn't work in other processes) or a way to simply display the shell context menu itself, but it may also depend on how/whether other developers adopt it, and whether Microsoft backtrack on it (as the new menu implementation is being widely criticised, aside from the visual design which people seem to like)


Thanks for the information Leo, same issue here. we'll wait and subscribed to the topic.

Looking forward to an update for this.

1 Like

In my case, I have lost all OneDrive context menu items.

I used to have them all and although I am 99.99999% sure that the issue only occurred after upgrading to 12.25, if I completely uninstall it and then re-install the previous version, the issue is still there!

After upgrading to Windows 11, I used "Free up space" frequently; now it is no longer there in the DOpus context menu and I have to use File Explorer instead.

It's the same for everybody, Look at Leo reply above. I installed the Beta of W11 around July i think, and the onedrive no more in context menu was there since the beginning when i started it.

FYI: screenshots and further version detail of my experience at Windows 10 OneDrive context menu - #12 by gPaq. Note that VLC managed to make its way onto the context menu, other assorted items such as OneDrive unfortunately not... :frowning:

Please try the 12.25.3 Beta.

1 Like

OneDrive context menu items still missing.

Have you installed the beta?

If they're still missing, make sure Preferences / Miscellaneous / Windows Integration / Hide Windows items on file context menus (shift overrides) is not turned on, as that would hide them.

Yes 12.25 3 Beta is installed and this setting is not turned on. I tried switch it on/off to no avail.

Ah !!!!!!!!!! it's working here but the icons are missing in front of the text, so i was not seeing them !

Ditto experience: just installed 12.25.3 Beta, rebooted, made sure the Preference setting is not turned on: no Context items for OneDrive :frowning:

Maybe I need to set my Directory Opus to French like martyprod :slight_smile:

Microsoft OneDrive version 2021 build 21.220.1024.0005 64-bit on Windows 11 Home 21H2 OS build 22000.318, Windows Feature Experience Pack 1000.22000.318.0

1 Like

Hey, just wanted to let you know, I tried out the patch this morning, worked beautifully, I have full functionality of Onenote back. Ran the install, only had to restart the program, not the PC. Only have Windows 11 on my personal PC, which uses the home edition, haven't tried with sharepoint or enterprise.

1 Like

Aha, important update, perhaps useful to the programmers... The context menu in the Left pane does NOT show the OneDrive actions

while the context menu selected from an item in the Right pane DOES show OneDrive functionality

1 Like

Thanks for that info! Please try the 12.25.4 Beta and see if it works now.

I see other items but not OneDrive Share.

OneDrive context menu items aren't working for me either on Windows 11. They appear in explorer windows. I've tried 12.25, 12.25.3 and 12.25.4, using clean installs and using old profiles where it worked under Windows 10.

I have installed the production version 12.26 and OneDrive context menu is available on both vertical sides of a Directory Opus window. Thanks for that update, this seems to have fixed the issue... perhaps until Windows 12 :slight_smile:

This version fixed it. Thanks!