GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Windows 1903 and One Drive Icons

Honest guv, all I did was start my PC one sunny Friday afternoon:

OneDrive Folder On Opus

OneDrive Folder on Explorer

Of course, I have been Microsofted and received the new 1903 version of Windows 10 which appears to have screwed up the notification icons in Opus.

Explorer is showing the correct notification icons. The files are only available online.

I do not know if it is a clue, but if you put a new pdf into the folder and watch carefully, the first thing that appears is a green tick (albeit it very fleetingly) before the notification icon turns into the rotating symbol.

I did reset OneDrive, but it made no difference.

I'd just use Dropbox if I were you :slight_smile:

Looking at the emoji, I take it that that is a joke?
.

The 12.14.2 fix For this problem works great so far as the notification icons are concerned. However, when I now put new PDF files into OneDrive folders they refuse to thumbnail, even though they do in Explorer.

Tried clearing thumbnail cache to no avail.

Windows 10 1903 has broken OneDrive with regard to thumbnailing cloud files. Asking the shell for a thumbnail triggers the whole file to be downloaded, whereas before it would download just a thumbnail of the file from the cloud.

Accordingly, thumbnails in OneDrive folders are disabled in Opus if Windows is on the 1903 update, until when/if Microsoft fix things or a workaround is found.

You can roll back the Windows update if you want to go back to a better working OneDrive.

These big Windows updates seem to cause a lot more problems than they improve anything, and the constant changes to how OneDrive works (or if it works at all) are becoming a problem. It might make sense to look at alternatives to OneDrive.

Thanks For the heads up Leo. I am sick of Microsoft releasing updates and breaking things or changing settings.

The problem with abandoning OneDrive is financial. It comes as part of the Office Suite and it makes no financial sense to shell out for another solution.
I will temporarily give up on the PC and use my Ipad until you good guys figure it out.

You and us both :slight_smile:

2 Likes

I ran with 12.4.2 For a while, until it became obvious that having thumbnails of OneDrive PDFs was far more important to me than having the correct status icons.

To try to restore the the thumbs, I went back to the last stable release of Opus - 12.4. Now I have the thumbs back, though the icons are wrong, of course.

My question is: why, as I am still on Windows10 1903 do I not see the problem Leo alluded to of the new Windows downloading files instead of thumbnails?

As the problem lies with the new windows build, I can't see the logic.

The problem seemed random to me, so it may just be that you haven't noticed it yet. It also won't happen if the thumbnails are already in the shell's image cache.

This sounds incredibly like a problem I reported in November 2018, with Opus suddenly deciding to download OneDrive files that I did not request.

I eventually solved this problem by completely eradicating OneDrive from my system and re-installing it.

I have been using 12.4 For three days now, and have not seen the problem. I will continue to monitor it over the next couple of weeks and report back.

12.4?

Apologies For the typo - 12.14, the last stable release

I have now been using Windows 10 1903 with all Microsoft patches applied and Opus 12.14 For 10 days now. Naturally, the icons are screwed up as I would need 12.14.2 to fix this.

Over my testing period I have sent over 100 PDF files from as wide a range of sources as I can - magazines from the web,self-created PDFs, commercially produced PDFs from Adobe Acrobat et al.

In all the time I have never experienced the problem of Opus downloading random files once. For me that problem stopped when I installed the latest One Drive from Microsoft a few weeks ago. Even with 1903 the problem has not re-appeared,

However, what I have found is that a far as One Drive is concerned not all PDF files appear to be created equal when it comes to thumbnailing.

Firstly, One Drive seems to take a dislike to large PDF files. Any PDF much above 100 mbytes will not thumbnail. Pass the PDF through a reduction process and the problem disappears.

Another very common problem with PDF files downloaded from web sites appears to be a problem with either the structure of the file or the Postscript within them.

Typically these files will not thumbnail, but nor can I save them out from my PDF editor. However, if I re-save the files via Acrobat Reader, they can also be edited and will produce thumbnails every time.

This problem is so prevalent, that I now, as a matter of course, open PDFs in Acrobat Reader and re-save them before sending to One Drive.

The final problem I have encountered is where a PDF saves to One Drive and thumbnails OK. After a reboot, however, the thumbnail has disappeared. This can be solved by pulling the file to the desktop. and sending it back to One Drive.

So everything in Auden's one drive garden is rosy - apart from the screwed up Icons?

Any chance of another beta, where the icon situation is fixed, but One Drive thumbs are allowed. I would love to give it a try.

We added this in 12.15. Use at your own risk :slight_smile:

Thank you, Jon. I will give it a try and report back in a few days.

The 12.15 release will not produce thumbnails from OneDrive. The position is exactly the same as 12.4.2.
If I copy a PDF from One Drive to my PC and then attempt to put it back into One Drive, no thumb is produced, even though the thumb was OK before I moved it.

Returning to 12.4 returns the thumbs but stops the icons updating (which was fine in 12.15.

Did you set the registry flag? Nothing will change unless that is done.

What a silly boy - I completely missed that. Set it to 6 and the thumbs are back.

1 Like