GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Wrong paths in copy/move dialog


#1

Today, i restore a backup of my sdcard.
So i select all files in my temp folder "D:+temp\Nouveau dossier" to move to sdcard "J:".
I notice something strange (for me). When some files are move, i notice that paths in dialog are wrong.



You can see in my screenshoot that, file "com.ldf.tele7.view-2.asec" is in "D:+temp\Nouveau dossier.android_secure" but in dialog, it's "D:+temp\Nouveau dossier".
Same thing for destination path, it should be "J:.android_secure" but it's "J:".

It's not specific to this file, i have the same thing with others (screenshot 2). Also, it happen only if files are in folder and not in subfolder.



It's possible that it's a refresh problem of these paths?
I notice that when i move files from folder which have subfolder (screenshot 2), moving starts with files in folder (step 1), then some files in subfolder (step 2), to finish with files in folder (step 3). it's strange for me too (how it's generate files list to move? which order? ) but these operations refresh paths in dialog:

(step 1) Wrong paths, source "D:+temp\Nouveau dossier", destination "J:"
(step 2) Paths are refresh, so good paths, source "D:+temp\Nouveau dossier\PlayerPro\Stats", destination "J:\PlayerPro\Stats"
(step 3) Paths are refresh, so good paths, source "D:+temp\Nouveau dossier\PlayerPro", destination "J:\PlayerPro"


Directory Opus 10.0.5.3 (beta)
#2

There is no problem for us ?


#3

I can't reproduce it.

How are you copying/moving the files? Which action, and what command is that action configured to run?



#4

I move files from harddisk to sdcard mounted (android).
I just select folders (with files inside) and drag&drop to destination.

(Tomorrow, i'll try to reproduce with last beta)


#5

When you check with the latest beta, please also check which commands you have bound to drag & drop (Settings -> File Types -> All Files & Folders -> Events).

Also, see if it only happens via drag & drop or if it also happens via the toolbar Copy Files / Move Files buttons. That might provide a clue that helps us reproduce it.


#6

I test by drag&drop (command : copy movewhensame) and button (command : Copy TO={d!}) and it's the same thing.

I understand... and I don't think it's a "bug", look in my news screenshots.

  1. I select "folder" from "D:\Source" and I drag and drop to "J:\Dest".

  2. So dialog says: "D:\Source" to "J:\ Dest". And it's ok because "folder" is in "D:\Source" and i drop to "J:\Dest" even if file "file in folder.asec" is in "D:\Source\folder".
  3. Then file "file in subfolder.asec" is copy.

  4. So dialog says: "D:\Source\subfolder" to "J:\Dest\folder\subfolder". And it's ok because "file in subfolder.asec" is in "D:\Source\subfolder" and destination is "J:\Dest\folder\subfolder".

So it's maybe not a bug but it's disturbing. I think that source/dest paths in dialog should be paths of current copying/moving files.


#7

I just copy files and paths in copy dialog really disturb me...

I'm the only one?


#8

I've finally understood what you meant now, and have fixed it. :slight_smile:


#9

You are the boss !
Many thanks.