Zip error 18


I am trying to zip a few folders with all their files. When the process reaches

CSJO Logo_1.jpg

I get "Error opening input file. Zip error 18".

I move this file out of the way, and then, when zipping, I get the same error for the next jpg file in the same folder:

CSJO Logo.jpg

Any idea what could be the problem?


Hans L

Can you view those files by double clicking on them?

Could you post a screenshot of the error message? It doesn't sound like one from Opus itself unless something very unusual is happening.

Yes, I can open the files by clicking on them.

I would like to add that when zipping folders

01, 02, 03, 04, 05, 07, 08, 09, 10,

I get the error.

When zipping only folder 05, which contains the "error" file a few folder levels down, the zipping works fine.

Zipping 05 in combination with any folder on the same level (01, 02 ..) results in error.

Zipping 01, 02 ..., but NOT 05, works fine.

Removing the folder with the "error" files makes zipping 05 with other folders on the same level okay.

I will post a screenshot in a minute.

Regards/Hans L

Here is the screenshot.

Hans L

I took out the two files I mentioned,

CSJO Logo_1.jpg

and then, zipping of 05 works with other folders on the same lever. There are other jpg files left in the folder that the two offending files come from.

Guess there is something wrong with these two files. Would really be interesting to know what, since i can certainly open them.

Hans L

I changed the names of the two "error-prone" files, and brought them back to their folder, and then, zipping works fine again where it previously crashed.

I checked all folders for hidden files or system files with the same names, but found none.

And there are other files starting with the same "CSJO ...jpg".

What a strange thing!

Hans L

That is quite strange. It points to a problem opening either the two files in question, or the destination zip file itself, but after a point where the files have already been opened successfully by other parts of the process.

If something else was opening/locking the files at the same time then it could trigger that, I guess.

If you copy those two JPGs with their original names to your desktop, then zip them up there, does that work?

Leo, I have said a lot, so it is not easy to see what actually happened. I will summarize.



With the original bad files, zipping H:\xxx worked fine. Zipping H:\xxx\badfile.jpg worked fine.

It was only when I tried to zip H:\xxx together with H:\yyy, or any combination of folders on that particular level, that zipping failed.

And after I changed the name of badfile.jpg, all zipping worked fine.

So, in spite of the fact that I had

CSJO Logo.jpg [bad file]
CSJO Logo_1.jpg [bad file]
CSJO LOGO_early.jpg

it was only the two first files that caused a problem. When I changed their names (to Hanstest.jpg and Hanstest2.jpg), every zipping worked.

This is, indeed, strange!

Hans L