Avira antivirus preventing Opus licence being accepted

[Thread title has been updated to help people searching for similar issues. --Leo]

For some reason DOpus 12 seemed to crash and lose my customisation. I tried restoring a backup but then a dialog appeared indicating my licence had expired. It won't accept my licence certificate and gave some message indicating my registration code was different form certificate etc.
I uninstalled/reinstalled and now when I try to either import licence or retrieve from server, I get a message indicating I must have admin rights. I've even launched DOpus using run as administrator or logged in as administrator to no avail. See below:

I'm running latest version on win7 x86

Please check under C:\ProgramData\GPSoftware\Directory Opus

If there is a file called dopus.cert there already, delete that and try again. It's possible the permimssions on the folder blocked you from replacing the old file, e.g. if it had previously been installed under a different Windows machine/account (the current machine vs the backup, as far as Windows is installed).

While in that folder, check if you're able to create a new file there. (A new text document or similar will do as a test. Delete it afterwards, if it's created successfully.)

If you haven't already, re-running the Opus installer over the top of your installation may fix the permissions on that folder. (No need to uninstall, which would wipe your config; just install over the top.)

If none of those solve things, please let us know. There are a couple of other things we can do to diagnose the problem.

I've tried the above but no avail. I ran Procmon and do see issues relating to the file below - not sure if thats any help

Also in the same folder "changelanguage.xml" gives me an access denied if I try to open in notepad. however I am able to create files in the same folder,


Is that Opus 12.12, or an earlier version?

If it's earlier, please try with 12.12, and be sure to reboot after the install finishes, when prompted. Older versions would trigger a bug in Windows where Windows Store apps could lock things like globaldata.omd from being written. (The bug is in Windows, but is triggered by a combination of Opus and certain Windows Store apps, e.g. F.Lux. Opus 12.12 contains a workaround for it.)

I've just downloaded today from site so presume its 12.12.

Heres what I've done:
Opened globaldata.omd in notepad and can see my registration code in there.
Also can open changelanguage.xml in notepad after reboot.
Successfully imported cert file.

However I now get an error indicating some registration code mismatch:

At this point changelanguage was removed by the program and I cant open globaldata.omd in notepad.

So in summary, I can import the cert after a clean reboot but then I get a registration code mismatch and I'm advised to import cert again. Subsequent attempts fail with the access denied. Then I reboot and rinse and repeat - I'm stuck in this reg code mismatch loop,


Correct, it should be (unless there's a browser/caching issue). You can open Properties > Details on the installer to check if needed.

Are you able to add a blank line to the end of it, save the change, then close & re-open the file and see the blank line is still there?

Please try using Lost Registration Retrieval to get the website to email you your latest certificate, and install that via "Install New Certificate" on the left of the licence manager.

I've tried both methods - getting my registration code and certificate emailed and also the retrieve licence when I input my registration code.
Both methods lead to the registration code mismatch.

  • Please check the installer version via right click, Properties > Details in case an old version was cached somewhere.

  • Are you able to modify globaldata.omd? Not just open it but save changes to it and see they are still there when you re-open it.

  • Just in case, be sure to reboot right after the 12.12 installer is finished, before trying to install the certificate.

  • If you still get the error message, please send us a process monitor log and we'll see if we can work out what's going wrong. Process Monitor instructions

I've run a procmon trace and emailed you download link.

I can confirm I am running latest version (12.12).
I am using the cert file that has been mailed to my when requested. The mail indicates "Your registration code is: xxxxx-xxxxx-xxxx-xxxxx (Directory Opus 12).

I remove Opus, reboot. I verify GPSoftware folders are no longer present. I install Opus, reboot. When I go to ProgramData folder, globaldat.omd is not present.
I run Opus and am immediately informed it has expired (2016) and needs a licence.
I browse to my downloaded cert I save from the earlier email.
The cert file is accepted but it then shows a mismatch between cert and registration code as per error message included in earlier thread of this ticket.
At this poit I cannot open globaldat.omd - I just get an error (nothing specific just an error saying it can open file)
I reboot.
This time I can open globaldat.omd and can see my reg code is correct and there is a CRLF at end of first line.

Opus had been working fine with no issues. I recently did an update on a video editing package (MovAvi) and found that Opus seemed to have lost its customisation I had applied from way back. It may be only coincidental but its worth mentioning. I did a restore of settings from a backup and its then I got into the situation with the licencing. The backup was one I did with Opus 12 and not an earlier version,


Can you please post a screenshot of the exact error message you're getting?

@Jon: The full message is here/above: Avira antivirus preventing Opus licence being accepted - #5 by deisceart

That sounds like there is something locking files on your system. You can use a tool like Process Explorer (not Process Monitor, but from SysInternals as well) to find out what's locking it, via its Find menu.

What do the permissions on globaldata.omd look like?

From the procmon log you sent, everything works fine until the new globaldata.omd is saved and replaces the other one (after the permissions are copied over to it as well). After that, the operating system acts as if something has an exclusive lock on the file, even though nothing appears to have made one based on the log.

It could be something weird with the file permissions on that file or folder.

Another possibility is your antivirus or similar is blocking the file from being read. Perhaps an "anti ransomware" type functionality sees something in the file it thinks is private data and blocks any program from opening the file? Check the logs of any security tools to see if they say they're blocking anything, or try uninstalling them to see if it makes a difference.

Permissions and everything is fine on all folders. The issue I am having is exactly as the one in this thread here:

I can verify using ProcExp that it is System (PID 4) that is holding the file open:

I've disbaled Antivirus etc etc and the issue still persists. Oddly the ProcExp indicates the file locked is globaldata.omd.tmp but this file is not visible in the folder - only globaldata.omd.

As per the issue in the thread linked above, it seems this problem has only occurred in rcent build of Opus - is it possible for me to download earlier version eg 12.8 to see if that works OK?


@deisceart Is that with 12.12 or an earlier version?

To both of you: Which Windows Store apps do you have installed that aren't by default? Please try removing them if possible, in case there is a second way the bug in Windows 10 can be triggered.

(If a Windows Store app is caused to open one of our config files, the OS locks the file from any further access. The only known cause of this was fixed in 12.12, once it is installed and you have rebooted.)


I'm using Windows 7 Pro


That could be a different issue in that case.

System locking files usually means something has them open via a network share.

It could also mean antivirus / anti-ransomware is blocking them, which is a problem that is becoming more common (and unfortunately many of those tools are badly designed and don't tell you when they block/break things).

I've no network shares and have verified no files being accessed over the network in the GPSoftware folder.
I have disabled my antivirus. At any rate there is nothing in quarantine in my antivirus folder
Where can I get an earlier version of v12 to see if that works OK?

12.10 installer is here: Can't download 12.10 again

I had the same issue with locked omd files using the 12.10 version.
Previously I had used the option to disable the real time scanning in my antivirus but now I decided to to uninstall my antivirus, reboot and try a clean install again of Opus.
This time it worked and I was able to import certificate licence with no issues.
Removed Opus, rebooted and reinstalled antivirus, rebooted, installed Opus and issue with locked files has returned and I'm unable to install Opus licence.
The antivirus I'm using is Avira and it does allow folder/process exclusions. I tried excluding the process dopus.exe, the path "C:\ProgramData\GPSoftware\Directory Opus" and I still get the locked files when trying to import licence.
At this stage I've given up on Avira so decided to install Kaspersky Free. This has worked fine and I've no issues licencing and now running the latest version of Opus.
I would like to point out that I've had Opus and Avira on my PC for years and have had no issues until last week when all of a sudden it seemed to crash and then come up unlicenced. Perhaps the Avira vendor has pushed out a new set of virus defs or config which caused the issues.
Anyway everything is now working fine again and thanks for your help and guidance,

1 Like

Glad it's working for you now.

Any antivirus that blocks things and doesn't tell you it's blocking them is more trouble than it's worth, IMO. If there really is a threat, you need to know to take further action. If it's a false-positive, you need to know so you understand why things aren't working. To not tell you in either case is terrible.