GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Custom Lister Context Menu (as seen in Opus 9 preview)

A couple of people asked for the customised Lister Context Menu shown in my Opus 9 preview so here it is.

To use the menu:

[ul][li]Type /dopusdata/Buttons/Menus into the location field.[/li]
[li]Copy the downloaded .dop file over the top of ContextMenu.dop[/li]
[li]Restart Opus (if the change isn't immediate).[/li]
[li]If you wish to restore the default menu later, you can do so via Settings -> Customize -> Context Menu.[/li][/ul]



Custom-ContextMenu.dop (9.1 KB)

[quote="ahmedmb"]When i press the right mouse button over a clear area of the Lister the windows default Menu open even in power mode.
How to activate The Lister context menus ? :confused:[/quote]
That will happen in folders like My Computer which Explorer controls. Try right-clicking when in C:\ or some other normal directory.

You also need to make sure full row selection is NOT turned on.

[quote="ahmedmb"]no way
not working[/quote]
I couldn't get this work either - until I copied nudel's file to the button folder with the rest of the files. It wouldn't work when the file was located elsewhere.

That's because I have reversed the default sort order of my date columns:


Couldn't see how your preferences would affect my setup. :smiley:

I tried both settings as indicated in your previous post and it made no difference to the behaviour of the menu items...

...until I changed the arguments of the menu iitems themselves. I just swapped the SortReversed=On/Off settings for each menu item

If you reverse the fields' default sort order then you also reverse the meaning of the SortReverse argument. :slight_smile: Since I have reverse the default sort order for the date columns, the buttons in my context menu were named to reflect that and will be the wrong way around if you haven't also done the same.

If you reverse the fields' default sort order then you also reverse the meaning of the SortReverse argument. :slight_smile: Since I have reverse the default sort order for the date columns, the buttons in my context menu were named to reflect that and will be the wrong way around if you haven't also done the same.[/quote]
OK, you're confusing me now (not all that difficult actually :confused: )

I have not modified the date sort order as depicted in your post showing the Preferences window (timed at 13:45). Mine are still set at the default i.e. not reversed.

All I did with your context menu was change the SortReversed switch from Off to On and Off to On for the two items respectively (Newest first and then oldest first).

The menu items works as you have named them. Thinking about it, it should have worked when I just changed the default sort order to reversed in the Preferences screen - shouldn't it?

Hang on, I'll have another play and see what happens ... OK, I've figured it out. I was setting the date (modified) as opposed to date/time (modified) in preferences. Now that I have selected reversed sorting in preferences for date/time (modified), it now works as you have set it to.

That was fun :confused: