Error (32) on delete

I'm getting constant error messages from DoPus saying "An error occurred deleting [filename/directoryname] : The process cannot access the file because it is being used by another process. (32)", with retry/skip/skil-all/abort button options. This occurs when deleting large directories over the network (i.e. directories on other machines). I understand this type of error but I can't see how any of the files this reports are being accessed by any processes other than dopus - these files/directories are on machines that are not being used. The weird thing is that hitting the "retry" button ALWAYS works - so it's only a momentary file lock. It's annoying however since these are huge directories that take a long time to delete; I like to set up these deletions and file backups and do 'em overnight but I come back to find it's all stalled because of this error. Any insights would be appreciated - I don't get this problem performing the same deletions with Windows Explorer.

Hi AQ,
I really have no idea what is going on,
but it does seem to me that the fact that Retry works is key .

I know that if I'm working on a command line program,
and screw something up, that this kind of thing can happen.
However, Retry Normally Won't Fix it !
I need a total restart in these situations.

Well AQ, perhaps this will get other people thinking.
I do wish you luck.

:opusicon: Porcupine

It may be that Opus, on a separate thread, is trying to populate the lister with information by inspecting the files. This will happen if you have the Description column turned on, or any other such as image width, music artist, and so on, which requires looking inside the file. Of course, thumbnails mode will do the same thing.

If that's taking a long time to happen then when you try to delete files Opus may be tripping over itself.

You can removed the Description column from network drives (see the Folder Formats FAQ for how to do this). I've done this myself, athough I did it to avoid wasting time and network resources populating the column, rather than to avoid this particular problem (which I've only seen once or twice).

I suspected something of that ilk but had no idea of the specifics; I'll test it out ASAP - thanks for the suggestion.

Had a look and it's not the description column; I haven't got that set to display anywhere. The (32) error is pretty regular occurance - will happen a dozen time whilst copying a few gig's of directories, but "retry" always works. Any other suggestions are more than welcome!

Do you have automatic directory size calculation turned on? I don't know if it can cause this problem but if it's on it's worth a try to turn if off.

Apart from that, which columns are you showing and which view mode (Details, Power, etc.) are you using?

The "Calculate Folder sizes automatically" option is OFF if that's what you mean. The view mode is always "details", columns visible are Name, Size, Type, Modified, Attributes. I haven't tested these operations with any other settings. I'm always using a Dual Horizontal layout for the file copies, copying from a local drive in the top panel to a network drive in the lower panel. These are large directory deletions over the network, always using the same combinations of machines and drives. The delete operations operate with no problem using Windows Explorer; it's only DOpus that throws up the file-locked error, and, as mentioned, it always seems OK once you hit retry. I'm getting more convinced that this is a bug in Dopus rather than a network or file access problem. Cheers.

With just Name, Size, Type, Modified, Attributes displayed the only thing Opus should be opening the files for is to find their type and/or get their icons.

If you turn on Preferences / Folders / Options: Display generic icons for network drives and/or remove the Type column, does the problem appear to go away?

I totally agree that this is a bug and should be fixed. If we can track down which thing is causing the lock it'll be easier for GPSoft to correct.

1 Like

One other 'settings' question... what are your settings on the Prefs->File Operations->Deleting page? Is the Count files in folders before deleting option enabled?