F-Secure manual scan option gone since SAFE version 8.1

Fixed ? F-Secure SAFE context menu not appearing. The 1st beta does not change a thing in my Windows 10 configuration. Tried: single file, group of files, single directory, group of directories.

Does it appear if you hold shift while right clicking?

Tried: without holding any Shift key, tried holding the left Shift key, tried holding the right Shift key.
All to no avail. Windows 10. Detail:
The right click menu has 22 instead of 15 entries when holding a Shift key pressed while right clicking, yet no option of F-Secure or any ' anti-virus scan ' entry visible.

It's working here with the current F-Secure SAFE installer just downloaded from their website:

2022-01-21 22-28-44 Clipboard Image

Do you see the menus in any software other than File Explorer? Some tools have options to only show their menus in Explorer.

Does Help > About in Opus show it's running 12.26.1?

Versie 12.26.1 (Beta) x64
Versie 8055, 20-1-2022 14:12:08
F-Secure SAFE - F-Secure Corporation Installed at: 7-12-2021 Size: .. Versie: 18.2

Why introducing a non-specified genre of ' tools ' ? What tools ? So far only 3 aps are involved, afaik:
1: Directory Opus, recently missing entries; 2: F-Secure, 3: Microsoft File Explorer, which still offers in the properties menu the opportunity to scan selected files / directories. I am unsure what you mean by ' tools ' and I am guessing about any reason introducing a fourth (4th) software.

"Other tools" as in any literally other software that displays a context menu. The File > Open dialog in Notepad is often a good test.

Some software literally has an option (and some is even hardcoded, but that's not the case here) to exclude its menus from anything other than explorer.exe, which is why it's worth checking in more than just File Explorer and Opus.

Just tried the ap / the program (not: " Tool " imho) Notepad. The menu does show indeed, like Microsoft File Explorer, the regular entry to scan (with anti-virus) a given selection (both Files and Directories) for viruses. Generic mentioning, not explicit "F-Secure", just: Scan for viruses.

So the same as in my screenshots? In that case I don't know why it would not show in Opus with the new beta, unless it's some difference between a fresh install of F-Secure SAFE and an update over an existing install. (Or things we already covered by testing with the Shift key, etc.)

It's a standard term, going back decades. But let's not get sidetracked by silly arguments about which word to use to describe a piece of software.

Yup, agree (standard term apparently). I could try an uninstall, then re-install of F-Secure, right ?

Worth a try.

Before un-install F-Secure, running CCleaner Registry & reboot the all-time fully up-to-date Windows 10 by chance I tried some shortcuts residing at my desktop. Funny enough, this is so far the only genre I found which actually did not lose it's menu entry of "Scanning for viruses".
After downloading a fresh ' exe ' from My F-Secure service, a swift and error free new install of F-Secure SAFE, version 18.2.
Guess what ? Same results as before: all entries absent, except for shortcuts.

Does this exist in your registry?

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shell\F-Secure Virus Scan

Done: < regedit > < search > " full hive key above "
Output, effect:
" Searching the registry is complete. "
Apart from this mini popup window I don't see any result.
No output, either when clicking on "OK" .
So my impression, answering your question, is " No, the string is not found in the Windows 10 registry ".

I don't think RegEdit can search for a full path. You'd need to either search for the last component (F-Secure Virus Scan) and see which places it's in (it should be in more than one), or go directly to the path in the tree to check if it's there.

Computer\HKEY_CLASSES_ROOT\AllFilesystemObjects\shell\F-Secure Virus Scan
Computer\HKEY_CLASSES_ROOT\DesktopBackground\Shell\F-Secure Virus Scan
Computer\HKEY_CLASSES_ROOT\Directory\Background\shell\F-Secure Virus Scan
Computer\HKEY_CLASSES_ROOT\Drive\shell\F-Secure Virus Scan
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AllFilesystemObjects\shell\F-Secure Virus Scan
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\DesktopBackground\Shell\F-Secure Virus Scan
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\background\shell\F-Secure Virus Scan
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Drive\shell\F-Secure Virus Scan

What's in the AllFilesystemObjects one?

FIY: 1:1 Dutch will do Leo? else I can translate

Computer\HKEY_CLASSES_ROOT\AllFilesystemObjects\shell\F-Secure Virus Scan
Naam Type Gegevens
ab (Standaard) REG_SZ (geen waarde ingesteld)
ab ExplorerCommandHandler REG_SZ {BEB62674-6209-497B-A2F9-8FBD0F051C5B}
ab MultiSelectModel REG-SZ Player

That looks correct, and matches what's on my machine.

So Opus 12.26.1 should be talking to their DLL (fsscanwizardcontextmenu_64.dll) to ask if it wants to add any context menu items.

It's possible the DLL fails to load (which could be the antivirus itself blocking dopus.exe from opening its DLL; we've seen that happen once or twice) or has a problem on its side, or some other registry data needed to load the DLL is missing.

A Process Monitor log of both registry and filesystem activity when a folder is right-clicked might reveal something.

Thanks for making the log!

It shows the registry entries are being found correctly, at least. After that, it seems to skip to processing other menu items, but I can't tell why. It could mean the shell extension failed to load or didn't add any items, but could also be due to other things.

In Opus 12.26.2, we'll add some additional logging to the context_menu_debug troubleshooting setting, which should tell us more about what's happening on your machine. Once 12.26.2 is out, please install it and then:

  • Go to Preferences / Miscellaneous / Advanced and turn on context_menu_debug

  • Get Microsoft's DebugView and run it (doesn't require any installation; ignore any messages about Dbgv.sys as we don't need it).

If you then right-click a file that should show the menu item, you should see output from Opus in DebugView. Please save that to a text file (File > Save As in DebugView) and attach it or put the contents in a code block:

[Paste text here]

(If you do that with 12.26.1, it might show something useful, but it depends how far it's getting. The extra information I've added for 12.26.2 should make it more useful for this particular issue.)

Remember to turn off context_menu_debug when you're finished, as leaving it on will slow down right-clicks.


Leo: thanks for solving my issue. Got several configurations (computers) and all is 'back to normal'.