Folder Tree expansion slow w/ Microsoft Security Essentials

I am evaluating Dopus and like what I see.

There is only one issue which seems to be bafflingly unusable.....the desperately slow folder tree. I have searched these forums for clues to fix this and have added dopus.exe as an exception to Microsoft Security Essentials as recommended. But performance is still abysmal, taking up to a minute or more to update (vs seconds for Explorer). GPsoft have clearly invested a huge amount in providing a vast number of outstanding features, yet this fundamental feature seems frustratingly overlooked (or instructions & settings for solving this are).

Is there anything else I can do to make this work snappily like Windows Explorer does?

Many thanks,


Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz
Windows 7 Professional 64-bit Service Pack 1
12GB Ram
NVIDIA Quadro K2000M
Crucial_CT240M500SSD1 222.83 GB (132.29 GB free)

Can you be more specific? In what way is it slow?

When I click on the triangle to list contents of a drive or directory it appears to freeze and takes ages to populate, almost as if it is trying to read the contents of every directory & subdirectory in the tree. All I really want is a listing of the first level directories & files. Then I can click on a subdirectory of interest to see further data if necessary. No need to read the whole disk.

If I click on a directory in the right hand file list, it opens and shows the contents immediately. Can't the tree do the same? MS seems to be able to manage it.



That's not the normal behaviour. What other software do you have installed? Maybe try disabling your virus checker and see if it makes a difference.

If the tree takes longer to list a folder than the file display, it is possibly due to EXE files (or possibly zip and other archives) below the directory which the tree is inspecting to see if they are archives, which may in turn trigger anti-virus scans. (It's also something Explorer doesn't do.)

Try turning off Preferences / Folder Tree / Contents / Zip files and other archives.

It could also be other things, like an involved shell extension going wrong in Opus and not Explorer, due to only being tested with Explorer, for example.

Thanks for the fast reply.

Preferences / Folder Tree / Contents / Zip files and other archives was already off.
I was mistaken, Dopus.exe was not excluded in any part of Microsoft Security Essentials.
I tried disabling MSE Real Time Protection and the Dopus tree loads fast.
I then tried re-enabling MSE with Dopus.exe added to the Excluded Processes window. Performance was back to very slow.
I then switched off MSE Scan Archive improvement. (I think this only applies to scans, not real time protection). Switched it on again.
My root directory only has a bunch of regular directories, plus the following files & sizes:
...mp3 55mb
...mp3 11mb
...pdf 5mb
...exe 3mb
all other assorted files are under 1mb (probably 50 files).

Any other suggestions?
Why would the tree be triggering shell extensions when the file list window doesn't? If it does, wouldn't it be a good idea to provide a switch to disable that?


It's worth reporting this to Microsoft as if their anti-virus scanner is causing normally fast operations to be extremely slow, they will want to know and fix it (and it most likely affects other programs in other ways).

Shell extensions are probably not involved, given the MSE connection.

That sounds like a slow and difficult fix :slight_smile:

Do you have other users using MSE with Dopus successfully? I can't believe I'm the only one with this problem.

Any other suggestions?


Using a tool like Process Monitor might provide more indication of exactly what's going wrong, if it points to a file or operation that is taking an excessive amount of time. (The 'stack' option in Process Monitor can also then show which components are involved.) I've made a note to see if I can reproduce this & investigate myself, but it will take me some time to get there and there's no guarantee I'll see the same problem.

Since it's fast with MSE's scanning disabled, and slow with MSE's scanning enabled even when dopus.exe is excluded from MSE, it's hard to imagine it can be anything other than a bug in MSE (at least unless the exclusion isn't configured properly in some way, or another process is involved somehow).

I was also having problems with MS Security Essentials.

I confirm that there was significant speed issues with just folders with pictures (without any EXE file). I have my photos sorted to folders by date, currently having 484 subfolders in my Photos-folder. Inside those folders is just jpg's and raw images (total of 112 gigs). It takes very long (maybe over a minute) to get list of those 484 subfolders in folder tree, with security essentials' real time scan enabled. But with Microsoft's own file explorer, there was no such delay.

This was the reason I was forced to change Security Essentials to COMODO Internet Security, which is working fine with DOpus. It takes just few seconds now to get folder list.

I uninstalled Microsoft Security Essentials and installed Norton Internet Security. This seems to have fixed the problem.


I found a permanent solution (in my case at least) and I posted it on this link:

Just in case, I copy what I wrote there, here:

I've been having the same problem for a few years now and I have tried EVERYTHING and nothing worked... EVERY suggestion in this forum and other forums didn't work... I searched high and low... disabled everything using shexview, used so many other tools... uninstalled all antivirus and firewalls, etc... I had two computers with the same problem, one with Windows 7 and the other with Windows 10.

The curious thing was that only Directory Opus seemed to be affected. Windows Explorer, Total Commander, and Speed Commander (yes, I have a few other file manager that I collected over the years, up until I found Directory Opus) were totally unaffected... go figure.

Anyhow, no matter what, Directory Opus always displayed/populated the directory tree way way too slow... I even went back and installed version 9 from back in the days that I remember it worked lightning fast... nope, didn't work. Then, if the problem persisted even when installing the older version which I remember was almost instantaneous at showing the folder tree, then the problem had to be with the OS... so, just by good karma (and an ounce of mischief), I uninstalled a program I no longer needed (Impulse Icons Manager) and it left me with all my desktop (and everywhere else) icons as white pages... there are other programs that produce the same problem when uninstalling, but this one was very connected to the icons. Anyhow, the icon Registry Key handler in Windows was left damage and when applying the fix below, it also fixed the Directory Opus problem (by the way, in another computer where I didn't have Impulse, Directory Opus still had the same problem and after applying this fix it also went back to normal, to populating the directory tree instantaneously - therefore, at least in my case, the problem was the Icon Handler registry key).

This is what fixed it for me:

  1. Open REGEDIT and go to the following key:


  1. Inside that folder "Shellex" (it's actually a key, but it looks like a yellow container folder), delete the whole folder or container called "IconHandler". This will also delete everything inside that container.

  2. Reboot the computer. Voila! Done. DirectoryOpus love at first sight all over again!!!

1 Like