GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Font-Viewer (ttf, otf)

32-bit-only
no-unicode-support
superseded
#1

Notes:

  • This plugins is 32-bit only and won't work with 64-bit versions of Opus.
  • Windows Vista and above have a font preview handler built-in which Opus will use automatically.
  • So you only need this plugin if you are using 32-bit Windows XP.

This ViewerPlugin lets you preview FontFiles (TrueType (ttf) and OpenType (otf)) within the Dopus-ViewerPane.

It works with installed and non-installed FontFiles!

Configure the included Ini-File to change the text and the fontsizes the text will be displayed.

The lower RichEdit is not read only so you are able to type your own text (temporarily)

It should work under 32bit XP and Vista.

Feedback is welcome :slight_smile:

Current Version: 1.1.1 (11.02.09)

Please take a look at these files:
readme.txt => further information and usage
history.txt => changelist

ATTENTION:
Referring to this post, please use my PlugIns only with DOpus 9.1.1.8 or higher! I'll limit the usage to this version in a further release. Thanks.

FontViewer.zip (257 KB)

Heads-up: dopus_fileinfo crashes and solution
Font viewer (ttf/otf)?
#2

Thanks very much. It works very well for me, fast and smooth. I've been eager to have this extra capability in my file manager.

I have one question for you. Is it possible to have the viewer give the name of the font? That would be helpful to me. Often I don't recognize the *.ttf or *.otf name.

#3

Take a look at the StatusBar :wink:


#4

Excellent, thanks...

#5

Thanks. I should have seen that. Looks very good.

#6

Great to have a Viewer Plugin to preview FontFiles for WinXP! :smiley:
The plugin only works with the WINDOWS\Fonts directory if you choose to have DOpus display the WINDOWS\Fonts folder as a real folder: :wink:


#7

oops, sorry - I forget to mention this :frowning:
I think this will be considered to every plugin.

#8

Great work! Thank you

However, I can't get FontViewer.ini to work. I try to save the file in ANSI, UTF8 or Unicode with no sucess.

I have the last version to date: 19/01/2009 16:55:38

Config: XP SP3, DOPUS 9.1.1.6

#9

There is a Font Name column which you can turn on in Opus to tell you the name of each font.

Also, this plugin seems to work fine with the Fonts folder shown as virtual, although it didn't initially for some reason. (I enabled the unrelated MultiView plugin, to test if it would show something to prove to myself that plugins can see files in virtual folders and after doing that the FontViewer plugin worked fine for some reason, even if I then disabled MultiView.

Edit: Next two paragraphs crossed out. Turns out it works okay on Vista but there is indeed a problem on XP.

Dinkelhopper, it might be worth debugging the file paths you get when files in the virtual font folder are selected. Maybe they're in an unexpected format?

The Text viewer plugin has no problems showing files in virtual folders (as hex in this case) so it definitely should work for all plugins.

Good work, BTW. Nice to see some new plugins!


#10

Works the very best! Many thanks for this. Very useful!

#11

When I enable the MultiView Plugin and/or the FontViewer Plugin (in WinXP) it also doesn't show anything with the Fonts folder shown as virtual:
(but it's not a big problem for me, because it works fine with the Fonts folder shown as real)


#12

Just tried on XP and you're right. Must be something different with XP and Vista.

Since the text plugin also doesn't show anything Dinkelhopper is right in that it isn't the plugin's fault. I'll report that to GPSoft so they can take a look at it. For now, as Christiaan said, you can tell Opus to treat the Fonts folder as real to work around the problem on XP.

BTW, anyone using Vista should have a font viewer built in. (The Opus ActiveX plugin will use the Font preview handler which ships with Windows. That works with both 32-bit and 64-bit.) So the combination of this plugin and the ActiveX plugin means that everyone can now examine fonts in the viewer pane, one way or another, except for the small number of 64-bit users running Windows XP.

#13

Thanks for your assistance.

#14

Could you attach your FontViewer.ini, please?

#15

My Fontview.ini is attached.

The Fontview.ini doesn't change text or font sizes from the default settings whether it is in the Viewers sub-folder or not.

Everything else works nicely.
FontViewer.zip (219 Bytes)

#16

It's ok with my own ini file on USB installation but don't work with the same file in my standard installation...

#17

Ok, I think I found the reason, the Ini could not be loaded.
There was a bug with detecting used directories; I fixed that.

In addition I added a Debugmode. Please take a look at the readme for further information using this mode.

Please let me know, if this bugfix works for you.

New Release 1.0.1 added to my first post.

#18

Oh strange things with your last release...
When i change police files, pane is not refresh correctly...
Instead of refresh preview lines, another lines are display at the end...

#19

Yep, I've noticed that 5 minutes after I've released the last bugfix - you'll get an update within the next 10 minutes. Please check post #1.

I apologize for the trouble caused :cry:

#20

Perfect... :stuck_out_tongue: