Launching DO via Double Click on the Desktop [DisplayFusion]

I use the above with the 'Open a saved Lister layout' option selected. In the latest beta however double clicking on the desktop does nothing I have to launch DO from the taskbar.

Did you forget to reboot after installing the update?

(Or did you launch dopus.exe as admin under UAC? That will break desktop double-click; info here.)

No to both. I always reboot after installing a new beta. And I run DO as I always do as the Windows 8 default Admin user.

Is dopusrt.exe /dblclk running in Task Manager?

Try setting Preferences / Launching Opus / From the Desktop: Disable, Apply, then set it back to what it was and apply again. That should stop (if it's running) and then restart the dopusrt.exe process which handles desktop double-click.

Singing...... "Leo is my hero"... repeat..... I had thought I'd tried that already, but I guess not as it is now working again :slight_smile:

This has reoccurred three times now. Fixed by applying the solution above or rebooting the PC.

Are you using DisplayFusion by any chance? (Or anything similar.)

I am using Display Fusion (beta) yes...... as I've a multi-monitor setup.

There's an issue where if Opus installs its hooks before DisplayFusion installs its own, then Opus's hooks don't seem to get called. If it happens in the reverse order (e.g. by turning off the option and then turning it back on, so the hooks are removed and then re-instated) then it works.

We're investigating this with the DisplayFusion team at the moment.

Ah ha - good news in that case as I've got a lot of confidence in both dev teams :slight_smile:

This is resolved now as long as you have the current Opus beta ( and the current DisplayFusion beta (5.1.1 Beta 3).

It is indeed, good news!

3 posts were split to a new topic: Double-click on one monitor opens Opus on another