One Drive and Opus Downloading

I reported in the middle of December that I seemed to have bottomed the problem with OneDrive and DOpus taking upon itself to randomly download files. I was being very premature. With a week the problem had started again.

The original post was:

# One Drive and Opus Downloading

but much of it is irrelevant in the light of what I have discovered

Three weeks ago, DOpus took it upon itself to download a whole folder full of PDF files from OneDrive and dump it on my PC. That was over 1.25 gigs of files.

In an attempt to try to make some sense of this, I re-installed windows and checked I was using what was then the latest version of OneDrive. I also stopped using Opus to deal with OneDrive and used Explorer.

The result was a faultless implementation of OneDrive with Icons changing as the files were taken on and off-line, just as it says on the box.

The only problem is that hate Explorer with a vengeance, so I needed to return to Opus.

It soon became obvious that opus was not keeping up with me as I took files on and off-line. When I took a file off-line the status icon changed to a green circle instead of blue cloud.

Assuming that the off-line request had not worked I took the file off-line again. Still no cloud icon. Very soon I had a folder full of PDFs and I really did not know which were on-line and which were off-line. Then Opus started its downloading tricks.

Then, by chance, I found something very interesting. I used Explorer to make sure that all my PDFs were off-line. I checked for a new version of OneDrive (Build: 19.012.0121.0011), which is dated March 2018 and installed it.

It did nothing to help with the problem of the Opus icons not changing, but at least it had a fix to prevent me from setting a file that was already off-line to off-line again. The option is now greyed out. Which also kind of proves that Opus is not up-to-date with the OneDrive status icons. OneDrive knows about the change - Opus does not.

Then I discovered that if I quit Opus altogether and re-started it from the desktop, the OneDrive status icon problem magically disappeared. They were all correct. This "fix" appears to work for me every time, but it is hardly convenient.

Any ideas how to fix this?

Are we talking about OneDrive that is built into Windows 10, or the OneDrive that is part of Office?

The OneDrive that's built into Windows 10 is usually managed by Windows and not something you'd normally mess around with yourself. (Doing that can really mess it up, I have found.)

The OneDrive that's part of Office is quite different to the normal built-in OneDrive, so if that is involved then we need to know so we're all on the same page.

How do I tell, Leo. I have a subscription to Office, so I am assuming that it is OneDrive For Office?

When I log on to OneDrive it tells me I am using Premium One Drive Features with my Office 365 plan

What did you install, that you mentioned earlier?

I downloaded the latest released version of OneDrive from this link at Microsoft.
(ie 19.012.0121.0011)

That's the Office OneDrive, given the URL. It is quite different from the normal OneDrive built into Windows.

(Unfortunately, Microsoft have used the same name for two different products that both do the same thing.)

Opus works with both versions or OneDrive but the way they behave can be quite different, and the Windows one is the more common one, and probably better tested as well. (I don't have much to do with the OneDrive support in Opus so I can't tell you exactly what is different.)

Based on the threads I linked above, it sounds like the Office OneDrive has problems with things triggering it to download files, including Windows Search Indexing (which I'm assuming you still have turned on). Opus might be an additional trigger, perhaps in conjunction with or as well as the indexing service, but it does seem like an issue people are seeing generally, without Opus always being involved.

You might want to try using the Windows OneDrive instead, unless you have a reason to favor the Office OneDrive.

There are a couple of problems with your suggestion Leo. I do not think I will be able to simply install the Windows vanilla version of OneDrive. If I uninstall and re-install OneDrive, I automatically get the Office version. I think it must be something to do with my Microsoft account which seems to know I have an Office 365 subscription.

Also my subscription gives me a terabyte of storage on OneDrive which I would probably lose if I could install the vanilla version. Obviously that is not acceptable.

I will persevere with the latest version of OneDrive, which is a big improvement as it will not allow me to move a file on-line more than once, which I am convinced was what was starting all the tricks with Opus downloading at random.

The worst case scenario is that I have to wait until Opus restarts to get the correct icons.

Stopped the indexing of PDF files, and it made no difference.

I can confirm that when I use the "Save space" option in OneDrive and the cloud icon does NOT appear in Opus, every time I ask Opus to refresh the icon of the file Opus downloads the file.

Maybe that gives clue.

Any idea why your system was on such an old version of the OneDrive client, and hadn't already installed the March 2018 update?

Have other updates also been missed?

If not already, I'd reboot after updating it as well, to ensure none of the old components are still loaded into anything.

You may possibly onto something here, Leo. I started to research the auto update facility for OneDrive. It is run from the task scheduler. When I opened the Task Scheduler on my system this is what I found:

There are multiple tasks in place to update OneDrive. I have disabled all but the latest.

When I examine that task, I see:

Showing that the task is configured to run for Windows Vista and not Windows 10. Surely some mistake here?

This is a screenshot of the right hand side of the first screen shot:

Based on this information, I have disabled all of the OneDrive update tasks saved the last one to be run.

I have NOT changed from "Windows Vista" to "Windows 10" as I was not sure that this was the correct thing to do.

Whilst I was researching this I also found 1.86 gigs of old OneDrive installations in my AppData folder. Which I have temporarily moved to another location.

The Vista thing seems normal in Task Scheduler, but I don't know about the rest.

There is no doubt a problem with Opus refreshing OneDrive icons on my system. It works flawlessly in Explorer, but in Opus the icons do not update properly.

My system:

Windows 1809 (OS Build 17763.348)

**OneDrive: (version that comes with an Office 365 subscription - I believe at one stage this may have been called One Drive Business) **
Version: 2019 (Build: 19.012.0121.0011)

This version of OneDrive that was released at the beginning of march has one very useful feature that previous version did not appear to possess.

If you use the command to "Clear Space"on a file, you are prevented from re-issuing the command - it is greyed out. This has had the effect of stopping the apparently random downloads by Opus of my PDF files which is the source of my original post, and giving me an idea of what might well by happening.

This is the sequence of events when I add a PDF file to OneDrive:

  1. When the file arrives in the one drive directory a green rotating icon appears as the file is copied.

  2. This changes to a green tick icon indicating that the file is on OneDrive but also resides on my computer.

  3. I issue the command to Clear Space on the new PDF. The green rotating icon appears to be followed once again by the green tick. Opus - at least icon wise thinks the file is still on my disk. This is definitely not true. If I issue something like at open command the file is immediately downloaded from OneDrive and back onto the hard disk of my computer, which is exactly what I would expect to happened.

  4. Issue the Clear Space command on the downloaded PDF. The green rotating icon appears to be followed once again by the green tick. Opus - at least icon wise - thinks the file is still on my disk.

  5. Close down the Opus session using Exit from the main menu.

  6. Wait 20 seconds. Double click the desktop to open a new Opus session. Navigate to the OneDrive PDF folder. The tick icon has changed to a Cloud icon.

This method works every time. The icons are only refreshed when you quit and restart Opus. BTW all my OneDrive PDF folders are accessed through tabs.

Try the Availability column, maybe it will be more reliable for you.

Sorry Jon, absolutely no difference. I still need to end the session of Opus and restart a new session to update to the Cloud icon.

Very frustrating, but at least the constant downloading by Opus seems to have stopped.

Ignore the icon, what does the Availability column do?

I copy a new PDF into my OneDrive folder

The new PDF has an Availability column that says the file is Available on this device

I issue the Clear Space command on the newly arrived file. The availability column entry for the file flickers a few times, but remains as Available on this device

I close Opus and open a new session.

The availability column entry for the file reads Available online

In other words it mirrors exactly what I see when I few my PDFs on OneDrive in my preferred mode of Thumbnails

What about the attributes column? When the file is in the cloud the O attribute should be set.

I copy a new PDF into my OneDrive folder

The new PDF does not have the o Attr set

I issue the Clear Space command on the newly arrived file. The attr column entry for the file flickers a few times, but remains unset

I close Opus and open a new session

The o Attr is set**

Exactly the same behaviour as the Availability column

Give the new beta a try and see if it helps.

Many thanks, Jon. Your fix seems to work perfectly. I will keep my eye on in over the next few days and report is I have any problems.