GP SoftwareTwitter
Opus FAQsManualCommandsObjects

One Drive and Opus Downloading


#21

Did you check in Folder Formats / Folder Options for any labels there?


#22

Yes, Leo - it was one of the first things I tried after you said you thought the problem was labels. I cannot think of where else to look for for labels, but I am not 100 per cent convinced that is the problem. Turning off all the labels never made any difference, After all.

Maybe Microsoft have been playing with OneDrive again in build 1809. I had never seen that black downloading box until I was moved to 1809. I think I will pause and await the promised re-release of 1809 and possibly your suggested label fix.

Many thanks for you patience and suggestions.


#23

Did you look in both Preferences / Favorites & Recent (the global list of labels) and in folder options for each of the tabs in your lister (the labels assigned to specific tabs or folder formats)?


#24

Yes, Leo, I tried both those avenues. I even tried disabling every label I have via /Favorites And Recent. Disabling made all my labels disappear, so I am sure it worked.


#25

Give the new beta a try with your full configuration and see if it helps.


#26

Sorry to say, Jon, but the new beta makes no difference to my problem. The second I try to "clear space" the black box pops up and Opus downloads all the files I marked to clear.


#27

Could you make another Process Monitor log using the new beta? Maybe there were two things triggering the downloads and we've only cured one of them.


#28

I will do that later today. In the meantime does this scenario help?

I have a folder of PDF file on oneDrive. Dealing with them in Opus incurs all the problems I have already outlined.

However when I point Opus to another folder that is not on onedrive and use Explorer to clear the space on those files, Explorer stores the files online as expected.

Now when I use Opus to look at the folder of PDFs, they do NOT start downloading. I then ask Opus to open one of the files in Acrobat reader and it duly does, and the rest of the files are not downloaded. I close the Reader file and run clear space on it from within Opus. All the files are immediately downloaded as before.

I also go back to the point I made that my registry shows that Opus should not be downloading files. Why is it doing this even though the registry entry to stop this action is enabled?


#29

Here is the process monitor log.

Logfile.zip (8.8 MB)


#30

Thanks for the log file!

  • It looks like label-filters are still in use. Is that correct? Were some created/restored after you disabled them all?

  • Would it be possible to generate a similar log file but without any filtering?

    The log only shows what dopus.exe is doing, so we can't tell if another process is triggering the download (possibly triggered by something Opus is doing in turn), which makes it hard to tell exactly what is happening.

  • Could you do a config backup (Settings > Backup & Restore) and email that to crashdumps@gpsoft.com.au for us to try with that? (Don't attach it here, in case there's anything private in the data.)


#31

I hope this what you need from procman

No_Filters_Logfile.zip (44.0 MB)

Yes, I did turn to labels back on - they are more important to me than OneDrive.

My config is on its way to the email address


#32

Was the config sent over? I can't see it in my inbox. Wondering if it was sent OK or if you got a bounce or anything.


#33

As requested I sent the config file to

crashdumps@gpsoft.com.au

It never bounced back.

To be sure, I have sent it again


#34

Hasn't come through, at least yet. I've checked my spam folder and it's not in there either. Jon also gets those emails but also hasn't seen it yet.

Could you try attaching it to a private message instead?


#35

Sorry Leo, I can't work out how to attach the zip to a private message, iI have sent the config to you personal (leo@gpsoft.com.au )email at opus. I think the zip file is being blocked as a security threat, perhaps


#36

Click Leo's name, click the image button, then in the message editor click theimagebutton or just drag and drop the file onto the editor.


#37

Thanks Jon

Config sent


#38

Your config still has Dimensions and Date Taken columns as part of the User Default folder format, which is being applied in the OneDrive folders.

Those columns will cause the files to be downloaded. (Maybe they shouldn't, but that's how they work right now, as mentioned above.)


#39

Actually, I may be wrong there. Those columns already know to check if a file is offline and ignore it, so they shouldn't matter.

I'll keep looking.


#40

You are right in that my Default format has Dimensions and date taken. But I thought 12.0.2 covered that issue.

Anyway I changed the default format and it made no difference. I use the OneDrive Clear Space and Opus immediately re-downloads the files, rendering OneDrive useless.

I checked the formats in the tab I used. there are two:

Default for OneDrive

Content Type PDFs

Looking at he columns in those formats indicates to me, that perhaps this is not the problem.

But to give a real indication about how serious the problem is: I accidentally looked at the OneDrive folder where I keep images. Opus downloaded over 1000 files onto my disk.