GP SoftwareTwitter
Opus FAQsManualCommandsObjects

One Drive and Opus Downloading


#41

I think we have a fix for this now, or at least an improvement. It's hard to be 100% sure as even with your config I can only make this happen intermittently, but I've fixed a couple of places that I can see were causing problems.

Once a new beta is out, please try that and see if it's better for you. If it isn't, please make a new procmon log so we can see what's still accessing the files.

Many thanks for your help tracking this down!


#42

I will check the beta when it arrives. Many thanks for your efforts.


#43

I've built a test version for you to try, please let us know if it helps.


#44

Many thanks Jon.

I have done test with the config, and I am afraid to say it makes no difference. The problem still remains.

The procman file I have created and zipped is too big. I will place it on my ftp server and privately message you a login. It will be later today


#45

Please try disabling Windows Search indexing, or tell it to exclude the OneDrive folder and/or .pdf files.

It looks like the files are made offline by OneDrive.exe, then SearchProtocolHost.exe (the Windows Search background process) looks at them, and they're still offline, then it does some things to them, and then Opus looks at them afterwards and they are no longer offline, causing Opus to try reading from them.

Nothing else touches the files between SearchProtocolHost.exe (where they start offline) and Opus (where they're no longer offline when Opus asks). So either something very strange is happening or SearchProtocolHost.exe is what's undoing the offline attribute.

This seems similar to this report about SearchProtocolHost.exe always downloading all the PDF files in OneDrive:

It's also different to that report, in that SearchProtocolHost.exe is not pulling the actual data down, but it seems to be causing the "offline" attribute to be lost, which in turn makes Opus think it's safe to read from the files, and that in turn causes the data to be pulled down.

(I think SearchProtocolHost.exe is reading some metadata about the files, not the main file data, which may be enough to trigger the Offline status to be lost, without triggering the "xyz.exe is downloading from onedrive" message to appear. That's just a guess, though.)

(Keep using the test Opus version as well, since it can still stop some cases where Opus could have downloaded the files even without SearchProtocolHost.exe getting involved. The issue you're seeing most likely has several causes.)


#46

I have always felt that the problem came wit the latest Windows 10 update. Anyway, many thanks for your efforts.

I am using the test Opus, but I am also reconstructing my Config bit by bit.

The strange thing is that since I have been doing this and testing the the OneDrive downloading problem after each change, I have only seen one random instance of it, and that only downloaded one file.

Stopping Windows indexing is simply not an option for me, I would get rid of OneDrive before I did that, but I will stop it from indexing PDF files and let you know, but it does seem at the moment that my problems spring from something in my config.


#47

I have now done the following:

Reinstalled Windows Build 1803 after asking the installer to put in any updates. As I figured this installed the 1803 and upgraded it to the November 2018 version 1809 with all subsequent updates.

I uninstalled and re-installed OneDrive.

I now seem to have completely different problem - I am still using your test config - in that whereas before when I asked to open a OneDrive PDF in Acrobat Reader, Dopus opened the file, now the file is opened by Acrobat Reader itself.

Having closed the file and Acrobat Reader, I asked OneDrive to clear space for the file a had just had in Reader.

Whereas before the space was cleared followed Opus re-downloading the file, the file will not clear space and Opus downloads the file back onto the OneDrive folder on my PC

What that means I have no idea.

But on a more positive note now Opus does not insist on downloading every file in a OneDrive folder.
Not being able to clear space makes OneDrive pretty useless, but perhaps not quite as useless as before.


#48

I have now been running with the Beta Jon made for me for a couple of days now since I re-installed Windows 10 and OneDrive.

The situation has been improved by the beta,

Whereas before if I set a file to "Clear Space" Opus downloaded every file in the folder to my hard disk, now it downloads just the file I have asked to "Clear Space on,

Also, the behaviour is consistent, too.

Of course, it still renders the "Clear Space" facility as totally useless, but at least I am not faced with potentially downloading scores of files when I use OneDrive.

One other difference - which may or may not pertain to the problem - if that before when I asked to view a PDF on OneDrive in Acrobat reader, the file was downloaded by Opus, now it is downloaded by Reader.

Having made so many changes, this morning ran and sfc /scannow and it fixed quite a few errors. However the one only mention of OneDrive in the cbs.log is a problem with a link in my Start Menu, which it says was fixed. The other fixes I am afraid are way above my knowledge threshold.


#49

I am happy to say that I appear to have fixed this problem. Though I have no idea why my fix would work.

The supposition by you good guys that it was something in my config looks like it was right.

Basically I completely eradicated all trace of the formats and Tabs that were showing the problem with OneDrive. I then reconstructed them and then saved the results as folder formats.
ét voilà!

Many many thanks for all your efforts.


#50

I think, at long last I have solved this problem, though I am still not sure what it was, but it was NOT Opus.

I was lulled into a false sense of security in thinking I had fixes, because I was only trying four or five times.

When I tried my various fixes around 10 to 15 times OneDrive always failed,eventually.

When I repeated this in Explorer, OneDrive always eventually failed - it just took a little longer.

I installed the very latest version of OneDrive and then began to stop and start OneDrive, examining what OneDrive was doing after each restart. After several restarts I noticed that OneDrive was reporting it had around 5,000 updates to perform, which considering I was only dealing with two folders with around 20 PDFs each, seemed a little strange.

I left OneDrive to get on with it. And bingo - a working OneDrive - at least for the last 10 days.

Icons still do not refresh automatically,but f5 sorts that out easily enough. Thanks guys, for your help and suggestions.


#51

I reported in the middle of December that I seemed to have bottomed the problem with OneDrive and DOpus taking upon itself to randomly download files. I was being very premature. With a week the problem had started again.

The original post was:

# One Drive and Opus Downloading

but much of it is irrelevant in the light of what I have discovered

Three weeks ago, DOpus took it upon itself to download a whole folder full of PDF files from OneDrive and dump it on my PC. That was over 1.25 gigs of files.

In an attempt to try to make some sense of this, I re-installed windows and checked I was using what was then the latest version of OneDrive. I also stopped using Opus to deal with OneDrive and used Explorer.

The result was a faultless implementation of OneDrive with Icons changing as the files were taken on and off-line, just as it says on the box.

The only problem is that hate Explorer with a vengeance, so I needed to return to Opus.

It soon became obvious that opus was not keeping up with me as I took files on and off-line. When I took a file off-line the status icon changed to a green circle instead of blue cloud.

Assuming that the off-line request had not worked I took the file off-line again. Still no cloud icon. Very soon I had a folder full of PDFs and I really did not know which were on-line and which were off-line. Then Opus started its downloading tricks.

Then, by chance, I found something very interesting. I used Explorer to make sure that all my PDFs were off-line. I checked for a new version of OneDrive (Build: 19.012.0121.0011), which is dated March 2018 and installed it.

It did nothing to help with the problem of the Opus icons not changing, but at least it had a fix to prevent me from setting a file that was already off-line to off-line again. The option is now greyed out. Which also kind of proves that Opus is not up-to-date with the OneDrive status icons. OneDrive knows about the change - Opus does not.

Then I discovered that if I quit Opus altogether and re-started it from the desktop, the OneDrive status icon problem magically disappeared. They were all correct. This "fix" appears to work for me every time, but it is hardly convenient.

Any ideas how to fix this?


#52

Are we talking about OneDrive that is built into Windows 10, or the OneDrive that is part of Office?

The OneDrive that's built into Windows 10 is usually managed by Windows and not something you'd normally mess around with yourself. (Doing that can really mess it up, I have found.)

The OneDrive that's part of Office is quite different to the normal built-in OneDrive, so if that is involved then we need to know so we're all on the same page.


#53

How do I tell, Leo. I have a subscription to Office, so I am assuming that it is OneDrive For Office?

When I log on to OneDrive it tells me I am using Premium One Drive Features with my Office 365 plan


#54

What did you install, that you mentioned earlier?


#55

I downloaded the latest released version of OneDrive from this link at Microsoft.
(ie 19.012.0121.0011)


#56

That's the Office OneDrive, given the URL. It is quite different from the normal OneDrive built into Windows.

(Unfortunately, Microsoft have used the same name for two different products that both do the same thing.)

Opus works with both versions or OneDrive but the way they behave can be quite different, and the Windows one is the more common one, and probably better tested as well. (I don't have much to do with the OneDrive support in Opus so I can't tell you exactly what is different.)

Based on the threads I linked above, it sounds like the Office OneDrive has problems with things triggering it to download files, including Windows Search Indexing (which I'm assuming you still have turned on). Opus might be an additional trigger, perhaps in conjunction with or as well as the indexing service, but it does seem like an issue people are seeing generally, without Opus always being involved.

You might want to try using the Windows OneDrive instead, unless you have a reason to favor the Office OneDrive.


#57

There are a couple of problems with your suggestion Leo. I do not think I will be able to simply install the Windows vanilla version of OneDrive. If I uninstall and re-install OneDrive, I automatically get the Office version. I think it must be something to do with my Microsoft account which seems to know I have an Office 365 subscription.

Also my subscription gives me a terabyte of storage on OneDrive which I would probably lose if I could install the vanilla version. Obviously that is not acceptable.

I will persevere with the latest version of OneDrive, which is a big improvement as it will not allow me to move a file on-line more than once, which I am convinced was what was starting all the tricks with Opus downloading at random.

The worst case scenario is that I have to wait until Opus restarts to get the correct icons.


#58

Stopped the indexing of PDF files, and it made no difference.

I can confirm that when I use the "Save space" option in OneDrive and the cloud icon does NOT appear in Opus, every time I ask Opus to refresh the icon of the file Opus downloads the file.

Maybe that gives clue.


#59

Any idea why your system was on such an old version of the OneDrive client, and hadn't already installed the March 2018 update?

Have other updates also been missed?

If not already, I'd reboot after updating it as well, to ensure none of the old components are still loaded into anything.


#60

You may possibly onto something here, Leo. I started to research the auto update facility for OneDrive. It is run from the task scheduler. When I opened the Task Scheduler on my system this is what I found:

There are multiple tasks in place to update OneDrive. I have disabled all but the latest.

When I examine that task, I see:

Showing that the task is configured to run for Windows Vista and not Windows 10. Surely some mistake here?

This is a screenshot of the right hand side of the first screen shot:

Based on this information, I have disabled all of the OneDrive update tasks saved the last one to be run.

I have NOT changed from "Windows Vista" to "Windows 10" as I was not sure that this was the correct thing to do.

Whilst I was researching this I also found 1.86 gigs of old OneDrive installations in my AppData folder. Which I have temporarily moved to another location.