Opus sometimes hangs on launch if TortoiseSVN installed

Evaluating DO and likely to purchase, but now its dead. As soon as I launch it, it shows the window but the title bar is " (Not Responding)"

This has been happening for about a week now, even through reboots. For me DO is now dead and unusable. No matter how long I wait, it just persists and I have to kill it.

That kind of problem is usually caused by one of three things:

  • A shell extension something else has installed is locking up when asked to get information about certain files or folders.
  • Something in the configuration (usually toolbar buttons, or sometimes script add-ins) is causing something to be accessed which is very slow, or hanging.
  • A device that Opus is trying to read a folder (or icons, etc.) from is very slow or hanging.

If you've waited at least 30 seconds and the program is still hung, you can rule out the last possibility, and most cases of the second (unless there are two such problems, which could cause a 30 second delay per device; most likely with network drives that cannot be reached, if the delay is that long; shorter delays can occur due to drives that have spun-down to sleep).

This guide covers the first possibility, as well as some related possibilities:

We can also sometimes tell you what is causing a freeze if you make a manually-generated process dump using Task Manager and zip & email the dump to us:

I just tried to launch it again. Now out of the blue its isn't doing that but instead says "Reading foler...." with an abort button...

It is trying to open a local folder that is part of an SVN repo and I do have TortoiseSVN installed. TSVN however works fine on same folder in Windows Explorer.

if I click abort, and navigate to C:, it repeats.. reading folder.....and I can wait and wait and wait..... nothing ever seems to complete.

There have been no updates to TSVN recently and it was working fine the first 2 weeks or so.

That sounds like a hang I've been seeing from TortoiseSVN as well. In the end I had to disable its Icon Overlay shell extensions using ShellExView. (The context menu extension is fine.)

I did some investigation and it looks like TortoiseSVN is deadlocking itself when asked to do two thing at once, or something like that, but I didn't investigate in depth beyond checking that Opus did not seem to be involved. (Haven't gone to the TSVN source code or anything like that yet.)

Opus can show the same overlay icons in a separate Status column (if the option to do so is enabled), so for me there wasn't any disadvantage to disabling the Icon Overlay shell extensions, and I haven't had any issues since.

I tried "Show tsvn status icons".. but then I have to add the column and all I see is text status ,no icons which is not very desirable.

I also checked "Disable TSVN icon overlays"... but it still hang often on start up if a SVN dir is the last one open. Sometimes just killing DO and restarting fixes it.

Why does TSVN deadlock with DO but not Windows Explorer?

You need to disable the shell extension DLLs using ShellExView. It's not something you can fix inside the Opus Preferences dialog.

I don't know why they hang in Opus and not Explorer. Probably Opus asking about two things at once or something like that, which should (and used to) be fine but is triggering a problem.

It needs more investigation, or reporing to the TSVN developer. I plan to when I have more time to gather info.

It's also possible it does happen in Explorer but is harder to trigger.

Yes I understand that I need to disable them in TSVN - however the option in DO only shows text status, no icons... and I dont think that disabling the icon overlay is going to make them appear in a column in DO?

It sounds like you've added the tsvn status column instead of the general Opus status column.

1 Like

Thanks. That was it.

TSVN has several options regarding overlay. I will try to play with them and let you know which ones might make a difference. For now Ive set it to "none" simply because I have work to do.

Copying my reply from this related thread: DOpus gets stuck on Reading Folder on boot:

We have what we hope is a fix for this coming in the next beta.

It's hard to test the fix because the problem, which was happening several times a day for me with the TSVN icon overlay extensions re-enabled, stopped happening as soon as I started investigating it again 3 days ago, and hasn't happened since, even after making changes which should have stressed the problem further.

I'm starting to suspect a third component was involved, or possibly changes to how Windows 10 loads DLLs, since the start of the problem did not coincide with an Opus or TSVN update. That could also explain why it seems to have spontaneously stopped happening. On the other hand, it could come down to a timing issue (which is what the potential fix we've made aims to address).

If you still see the problem after the next update, please let us know.

Thanks. Does DO auto update or check? Or do I need to manually watch for updates?

Only for "stable" releases, not for betas: