I have problems with pictures. Opus 11.19 doesn't seem to integrate well with Windows 10 Fall Creator Update

  • when I open a picture with Photo app (my default images viewer) I can't switch to previous or next images. I can view only the opened image
  • I set as my default images editor. When I try to modify a png picture Adobe ImageReady is opened. I don't have this problem with jpg and bmp images
  • right click context menu shows a wrong entry

I did a clean installation but these problems occur again

Ask one question per thread, please. (And don't forget to search first.)

That is the Windows Photos app choosing to do things differently depending on how it is launched, and there's no other documented way to launch it that we are aware of, as with a lot of the "Metro" side of Windows.

The same problem happens if you launch that viewer via the Open With dialog in Opus, but not the same dialog in Explorer, even though both dialogs are handled entirely by the operating system. It seems Explorer does something special, and possibly undocumented, when it launches “Metro” applications. I can only speculate but it may have an API to pass the application the list of other files in the same folder, instead of the application working that out for itself, but I’ve never seen that API documented if there is such a thing.

For more detail, see my reply here (and in several similar threads, but I think that one covers it).

Does the same thing happen in File Explorer? What's different about the JPG and PNG types? How are you editing the files (e.g. double-click, or right-click > edit, or something else)?

That's due to Microsoft adding yet another new way to name context menu items in a Windows 10 update. One of the threads about it is here: Context Menu Item for Picture Files

Support for that was added in Opus 12.6, if I recall correctly. While Opus 11 got several years of free updates, updates to Opus 11 ended before this, so Opus 11 won't be getting the change. However, you can edit the registry to change the name that you see in the menu.

(There was also a similar change back in Opus 11, for a slightly different menu naming format that Microsoft started using, but I think only Office used that: Context menu in Windows 10 )

It doesn't happen in File Explorer.
With JPG and BMP Paint.NET is opened correctly
I'd like to edit the PNG picture with right-click and choosing Edit. I edited the registry to have this entry:

@="\"C:\\Program Files\\\\PaintDotNet.exe\" \"%1\""

There are other places in the registry which might be used. Have you tried looking at the filetype via Opus's filetype editor instead of regedit?

Opus’s filetype editor solved this problem.

I report that "%ProgramFiles%\\PaintDotNet.exe" is not accepted. I had to use
"C:\Program Files\\PaintDotNet.exe"

%ProgramFiles% expands to a path that contains a space, so you may need to put quotes around the path, but it should work in general, assuming the program is in there (and not e.g. Program Files (x86)).

I already put the path in quotes, but it doesn't work